Bug 26352 - pdf2djvu missing dependency djvulibre
Summary: pdf2djvu missing dependency djvulibre
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: All Linux
Priority: Normal major
Target Milestone: ---
Assignee: QA Team
QA Contact:
Whiteboard: MGA7-64-OK
Keywords: advisory, validated_update
Depends on:
Reported: 2020-03-17 03:44 CET by nikos papadopoulos
Modified: 2020-04-01 03:58 CEST (History)
5 users (show)

See Also:
Source RPM: pdf2djvu-0.9.12-3.mga7.src.rpm
Status comment:


Description nikos papadopoulos 2020-03-17 03:44:15 CET
Description of problem:
Pdf2djvu complaint about not finding csepdjvu.
It didn't work without it.
The pdf file was created with Libre Office Writer.

Version-Release number of selected component (if applicable):
   pdf2djvu 0.9.12
   DjVuLibre 3.5.27

How reproducible:
I just tried it once.

Steps to Reproduce:

+ Install pdf2djvu with the command...
   urpmi pdf2djvu

+ Try to convert a pdf file into djvu , and read the output.
   pdf2djvu -o 001.djvu -v 001.pdf
   - page #1 -> #1
     - image size: 2480x3508
   External command "/usr/bin/csepdjvu ..." failed: No such file or directory

+ Failure. The file was not converted.

+ The csepdjvu was found in the djvulibre rpm

+ Install

+ Try once again to convert the file.
   pdf2djvu -o 001.djvu -v 001.pdf
   - page #1 -> #1
     - image size: 2480x3508
     - 4857 bytes out
   - page #2 -> #2
     - image size: 2480x3508
     - 3900 bytes out
   - page #3 -> #3
     - image size: 2480x3508
     - 3937 bytes out
   - page #4 -> #4
     - image size: 2480x3508
     - 4150 bytes out
   - page #5 -> #5
     - image size: 2480x3508
     - 3429 bytes out

+ Success!
Comment 1 David GEIGER 2020-03-17 06:14:34 CET
Assigning to QA now,


There's a missing required dependency on the pdf2djvu package from Mageia 7.
If no other packages pulling 'djvulibre' are installed on the computer, pdf2djvu can't convert a file without csepdjvu. This update adds this missing dependency.


Packages in 7/core/updates_testing:

Source RPM: 

CC: (none) => geiger.david68210
Assignee: bugsquad => qa-bugs

Comment 2 Len Lawrence 2020-03-17 18:49:22 CET
mga7, x86_64

Removed djvulibre and tried:
$ pdf2djvu -o test.djv UsingDocker.pdf
- page #1 -> #1
PDF syntax warning: Invalid Font Weight
PDF syntax warning: Invalid Font Weight
External command "/usr/bin/csepdjvu ..." failed: No such file or directory

Updated pdf2djvu.
$ sudo urpmi pdf2djvu
To satisfy dependencies, the following packages are going to be installed:
  Package                        Version      Release       Arch    
(medium "Core Updates (distrib3)")
  djvulibre                      3.5.27       5.1.mga7      x86_64  
(medium "Core Updates Testing (distrib5)")
  pdf2djvu                       0.9.12       3.1.mga7      x86_64  

$ pdf2djvu -o test.djv UsingDocker.pdf
- page #1 -> #1
PDF syntax warning: Invalid Font Weight
PDF syntax warning: Invalid Font Weight
- page #2 -> #2
- page #355 -> #355
0.016 bits/pixel; 2.135:1, 53.16% saved, 8551169 bytes in, 4005297 bytes out
$ djview4 test.djv

The converted file displayed fine in the PDF viewer.
$ pdf2djvu -o python.djv --hyperlinks=#f1ccd8 ProfessionalPython.pdf
- page #290 -> #290
0.011 bits/pixel; 2.064:1, 51.54% saved, 5227754 bytes in, 2533181 bytes out

The output looked fine in djview4 but during the conversion there were numerous messages of this kind: - Warning: Unable to convert link with a JavaScript action.  Running the command as a straight conversion also showed the warnings.

Going back to first test PDF...
$ pdf2djvu -o test2.djv --hyperlinks=#118800 UsingDocker.pdf
worked fine, no errors, and the hyperlinks were highlighted in dark green when the mouse hovered over them, which helped to distinguish them from some of the red text highlights.

Leaving the other options for the curious.

Giving this the OK because the error quoted above is probably not relevant to the update.

Whiteboard: (none) => MGA7-64-OK
CC: (none) => tarazed25

Comment 3 Thomas Andrews 2020-03-18 16:34:44 CET
Validating. Advisory in Comment 1.

Keywords: (none) => validated_update
CC: (none) => andrewsfarm, sysadmin-bugs

Dave Hodgins 2020-04-01 00:10:51 CEST

Keywords: (none) => advisory
CC: (none) => davidwhodgins

Comment 4 Mageia Robot 2020-04-01 03:58:17 CEST
An update for this issue has been pushed to the Mageia Updates repository.


Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.