Bug 25339 - Error message. Anki terminates after clicking OK.
Summary: Error message. Anki terminates after clicking OK.
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA7-64-OK
Keywords: advisory, validated_update
Depends on:
Blocks:
 
Reported: 2019-08-21 22:12 CEST by Largo43
Modified: 2019-09-06 23:10 CEST (History)
6 users (show)

See Also:
Source RPM: anki-2.0.52-2.mga7.noarch.rpm
CVE:
Status comment:


Attachments

Description Largo43 2019-08-21 22:12:23 CEST
Description of problem:

Anki doesn't open when run. Instead it gives an error message and terminates. 


Version-Release number of selected component (if applicable):

Name         : anki
Version      : 2.0.52
Release      : 2.mga7
Architecture : noarch
Size         : 10.85 MB
Source       : anki-2.0.52-2.mga7.noarch.rpm
Repository   : 
From repo    : mageia

How reproducible:

Install Anki and run.

Steps to Reproduce:
1. Install Anki using DNF.
2. Run Anki.

Actual results:

The following error message shows up:

Startup Error
Please notify support of this error:
Traceback (most recent call last):
File "/usr/share/anki/aqt/__init__.py", line 194, in run run()
File "/usr/share/anki/aqt/__init__.py", line 246, in _run pm = ProfileManager(opts.base, opts.profile)
File "/usr/share/anki/aqt/profiles.py", line 73, in _init_ self.maybeMigrateFolder()
File "/usr/share/anki/aqt/profiles.py", line 125, in maybeMigrateFolder oldBase = self. oldFolderLocation()
File "/usr/share/anki/aqt/profiles.py", line 122, in _oldFolderLocation return os.path.join(loc, "Anki")
File "/usr/1ib64/python2.7/posixpath.py", line 70, in join elif path == " or path.endswith('/'):
AttributeError: 'QString' object has no attribute 'endswith'


Anki terminates after clicking OK.

Expected results:

Anki runs properly.

Comment :

Same error on Fedora 30 : https://bugzilla.redhat.com/show_bug.cgi?id=1701691
papoteur 2019-08-22 07:38:05 CEST

CC: (none) => yves.brungard_mageia
Assignee: bugsquad => rverschelde

Comment 1 David GEIGER 2019-08-25 16:55:17 CEST
An update should fix this issue with anki-2.1.15-1.mga7 in Core/Updates_testing repo. It is now ported to PyQt5 and Python 3.

Please test it, thanks in advance!

CC: (none) => geiger.david68210

Comment 2 David GEIGER 2019-08-26 06:24:59 CEST
Assigning to QA now,


Advisory:
========================

Our anki package is a quite old and doesn't work/start anymore.
So this update fixes this issue and also ports it to PyQt5 and Python 3.

========================

Packages in 7/core/updates_testing:
========================
anki-2.1.15-1.mga7.noarch.rpm

Source RPM: 
========================
anki-2.1.15-1.mga7.src.rpm

Assignee: rverschelde => qa-bugs

Comment 3 Len Lawrence 2019-09-01 01:36:43 CEST
mga7, x86_64

$ anki
Traceback (most recent call last):
  File "/usr/bin/anki", line 5, in <module>
    import aqt
  File "/usr/share/anki/aqt/__init__.py", line 12, in <module>
    from aqt.qt import *
  File "/usr/share/anki/aqt/qt.py", line 7, in <module>
    import sip
ImportError: No module named sip

Installed the update and pulled in a number of python3 packages.

$ anki
/usr/lib/python3.7/site-packages/bs4/element.py:16: UserWarning: The soupsieve package is not installed. CSS selectors cannot be used.
  'The soupsieve package is not installed. CSS selectors cannot be used.'
qt: QXcbConnection: XCB error: 3 (BadWindow), sequence: 586, resource id: 18987039, major code: 40 (TranslateCoords), minor code: 0

Gui launched - selected English.
-> Create Deck
padawan
-> Get Shared
<That brought up a page in firefox - selected Physics -> periodic table pegs -> downloaded an html file (?)>
-> Import File - chose the downloaded html file

Stopped at that point because it started to get complicated - closed and backed up.

No obvious problems.  Good for 64-bits.

Whiteboard: (none) => MGA7-64-OK
CC: (none) => tarazed25

Comment 4 David GEIGER 2019-09-03 07:45:38 CEST
Tested here on my mga7 for x86_64, now anki start and work as expected!
Comment 5 Thomas Andrews 2019-09-05 14:25:06 CEST
Validating. Advisory in Comment 2.

Keywords: (none) => validated_update
CC: (none) => andrewsfarm, sysadmin-bugs

Thomas Backlund 2019-09-06 18:53:43 CEST

CC: (none) => tmb
Keywords: (none) => advisory

Comment 6 Mageia Robot 2019-09-06 23:10:46 CEST
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2019-0114.html

Status: NEW => RESOLVED
Resolution: (none) => FIXED


Note You need to log in before you can comment on or make changes to this bug.