Bug 25138 - keepassxc fails with unknown machine instruction
Summary: keepassxc fails with unknown machine instruction
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: All Linux
Priority: Normal major
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA7-64-OK
Keywords: advisory, validated_update
Depends on:
Blocks:
 
Reported: 2019-07-16 20:06 CEST by Marc Krämer
Modified: 2019-09-21 13:08 CEST (History)
5 users (show)

See Also:
Source RPM: argon2-20171227-2.mga7.src.rpm
CVE:
Status comment:


Attachments

Description Marc Krämer 2019-07-16 20:06:18 CEST
start keepassxc, select new database, continue, click create -> crash

on command prompt you see "unknown maschine instruction"
Comment 1 Lewis Smith 2019-07-16 20:25:13 CEST
@Marc : Can you provide any console output, please.

Assigning to Sander.

Assignee: bugsquad => mageia
CC: (none) => lewyssmith

Comment 2 Marc Krämer 2019-07-16 21:27:51 CEST
$ keepassxc
Ungültiger Maschinenbefehl


not much....

running in strace gives me
[pid   978] eventfd2(0, EFD_CLOEXEC|EFD_NONBLOCK) = 29
[pid   978] write(29, 0x7faf8dad6908, 8) = 8
[pid   978] prctl(PR_SET_NAME, 0x5628e61c4538) = 0
[pid   978] --- SIGILL {si_signo=SIGILL, si_code=ILL_ILLOPN, si_addr=0x7fafa5c8a3a9} ---


Tried to recompile, tried newer version 2.4.3 on cauldron and tried fedora build (https://koji.fedoraproject.org/koji/buildinfo?buildID=1297141).
All result in the same error...

Anything processor dependend in there ? I'm using i7 M620 .
Comment 3 Marc Krämer 2019-07-16 21:37:25 CEST
It only happens if I use the default settings with Argon2 (KDBX 4).
Lewis Smith 2019-07-18 11:04:54 CEST

CC: lewyssmith => (none)

Comment 4 Sander Lepik 2019-07-27 14:39:59 CEST
I can't reproduce this on my system (i5-5300U)

Ever confirmed: 1 => 0
Status: NEW => UNCONFIRMED

Comment 5 Marc Krämer 2019-07-28 14:07:35 CEST
I think it is the same issue as this:
https://github.com/keepassxreboot/keepassxc/issues/1711
Looks like it has to be built with "OPTTARGET=none"
Comment 6 Marc Krämer 2019-07-28 14:10:39 CEST
see this post too
https://dev.getsol.us/T6009
Comment 7 Sander Lepik 2019-07-28 14:31:02 CEST
So we should probably fix argon2 build. CCing David.

CC: (none) => geiger.david68210

Comment 8 Marc Krämer 2019-07-28 14:49:49 CEST
looks like it is an libargon2 problem. Maybe they use some optimization not supported by older processors (like mine from ~2010)
Marc Krämer 2019-08-14 02:51:40 CEST

Assignee: mageia => geiger.david68210
Source RPM: keepassxc-2.4.1-1.mga7.src.rpm => argon2-20171227-2.mga7.src.rpm

Comment 9 Marc Krämer 2019-08-14 03:12:35 CEST
@David: I've tested this. After the change it works as expected. Adding 
export OPTTARGET=none

before makebuild results in 
"Building without optimizations"

If this is not set, the optimizations of the built system are used which is unlikely everyone can use them.

I hope you don't mind, checked in the fix (mga7) and pushed to updates_testing.
Comment 10 Marc Krämer 2019-08-17 12:39:26 CEST
Updated agron2 packages fix processor incompability.
Due to an compiler optimization the package will raise an invalid instruction exception if the target platform does not match our build infrastructure.

========================

Updated packages in core/updates_testing:
========================
argon2-20171227-3.mga7
lib64argon2_1-20171227-3.mga7
lib64argon2-devel-20171227-3.mga7
argon2-debugsource-20171227-3.mga7
argon2-debuginfo-20171227-3.mga7
lib64argon2_1-debuginfo-20171227-3.mga7

SRPM:
argon2-20171227-3.mga7.src.rpm

Assignee: geiger.david68210 => qa-bugs

Comment 11 Brian Rockwell 2019-09-16 03:13:26 CEST
MGA7 - 64 running on Cinnamon

$ uname -a
Linux localhost.localdomain 5.2.13-desktop-2.mga7 #1 SMP Sun Sep 8 10:54:20 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Installed the argon2 packages and then keepassxc.

I chose 4 version as noted and it worked fine.

Whiteboard: (none) => MGA7-64-OK
CC: (none) => brtians1

Comment 12 Hartmut Goebel 2019-09-19 16:46:15 CEST
I can confirm this issue: I had the same issue, on a CPU from ~2010.

Rebuilding lib64argon2_1-20171227-2.mga7.x86_64.rpm on my machine solved this issue.

Also installing lib64argon2_1-20171227-3.mga7.x86_64.rpm from Core Updates Testing solved the issue.

CC: (none) => h.goebel

Comment 13 David GEIGER 2019-09-19 16:50:29 CEST
So I think this update should be validated now as per comment 9 and 12

Ever confirmed: 0 => 1
Status: UNCONFIRMED => NEW

Thomas Backlund 2019-09-21 11:53:44 CEST

CC: (none) => tmb, sysadmin-bugs
Keywords: (none) => advisory, validated_update

Comment 14 Mageia Robot 2019-09-21 13:08:41 CEST
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2019-0131.html

Status: NEW => RESOLVED
Resolution: (none) => FIXED


Note You need to log in before you can comment on or make changes to this bug.