Bug 25022 - Intel UHD Graphics 620 videocard - black screen in several desktop environments
Summary: Intel UHD Graphics 620 videocard - black screen in several desktop environments
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: All Linux
Priority: Normal major
Target Milestone: ---
Assignee: Thomas Backlund
QA Contact:
Depends on:
Reported: 2019-06-29 19:01 CEST by Dave Hodgins
Modified: 2019-08-11 17:44 CEST (History)
0 users

See Also:
Source RPM: kernel-5.1.14-1.mga7.src.rpm
Status comment:


Description Dave Hodgins 2019-06-29 19:01:30 CEST
On a newly purchased Star Labtop MK III, many desktop environments are not
displaying properly, including gnome and kde plasma. Workaround is to use
xfce4, which is working fully.
lspcidrake|grep Card shows
Card:Intel 810 and later: Intel Corporation|UHD Graphics 620 [DISPLAY_VGA] (rev: 07)

Varies desktop environment tests from run level 3 using startx $de shows ...

startkde blackscreen except mouse cursor. Semi functional as clicking on where the icons should be seems to be working,
though menu images remain shown when they are no longer active.

cinnamon-session-cinnamon2d blackscreen except mouse cursor. Not functional.

cinnamon-session-cinnamon crashes, after which desktop backround is black, but it is working

startgnome_classic blackscreen except mouse cursor. Not functional

gnome-session blackscreen except mouse cursor. Not functional

icewm black desktop, panel displayed and working

icewm-session fully working

startlxde fully working

startmate fully working except display of systray icons having overlapping icons

startopenbox fully working

startxfce4 fully working
Comment 1 Dave Hodgins 2019-06-29 19:05:57 CEST
Adding the kernel option dis_ucode_ldr has no effect
Comment 2 Dave Hodgins 2019-06-29 19:10:34 CEST
Same with noxorgconf. No effect
Comment 3 Dave Hodgins 2019-06-29 19:28:31 CEST
The labtop came with ubuntu 18.04.2 LTS where gnome does work.
That's running kernel 4.18.0-21-generic with gnome 3.28
Comment 4 Thomas Backlund 2019-06-29 23:29:31 CEST
please always use "-v" with the lspcidrake command so we can get the actual pci ids too
Comment 5 Dave Hodgins 2019-06-30 00:43:11 CEST
Sorry. Here's the card with -v ...
Card:Intel 810 and later: Intel Corporation|UHD Graphics 620 [DISPLAY_VGA] (vendor:8086 device:5917) (rev: 07)
Comment 6 Dave Hodgins 2019-08-08 21:34:42 CEST
The display does work when using wayland, from run level 3 ...
"startplasmacompositor" from plasma-workspace-wayland works to start plasma,
"XDG_SESSION_TYPE=wayland dbus-run-session gnome-session" works for gnome.
Comment 7 Thomas Backlund 2019-08-08 22:17:26 CEST
Does the new mesa 19.1.4 and/or kernel 5.2.7 help at all (both currently in testing) ?
Comment 8 Dave Hodgins 2019-08-09 21:36:48 CEST
No difference. "startx startkde" still gives a black screen with the mouse
cursor. Right clicking brings up the context menu where konsole works. Moving
the mouse around and right clicking leaves many context menus drawn on the
screen, with the most recently drawn being the only one working.
Once konsole is started, programs such as kcalc do work, but with no window

I've tried with nokmsboot, and/or nomodeset. If either or both options are
specified, X fails to start.
Comment 9 Thomas Backlund 2019-08-09 21:44:52 CEST
(In reply to Dave Hodgins from comment #8)

> I've tried with nokmsboot, and/or nomodeset. If either or both options are
> specified, X fails to start.

This is expected, the Intel ddx is a modeseting driver, so it will fail with those options...

You seem to be booting to runlevel 3 and using startx & co...

Does it work any better if you boot in runlevel 5 ?

And what display manager are you using ?

And another thing is to try the modesetting driver
Comment 10 Dave Hodgins 2019-08-09 23:01:19 CEST
Specifying kernel option xdriver=modesetting has no effect.

Switching to use run level 5, both gnome and kde work. Tested with both sddm
and gdm.

So it looks like the problem is due to my habit of normally booting to run
level 3 and then using startx.

Want to close this report, or dig further?
Comment 11 Dave Hodgins 2019-08-10 22:24:18 CEST
The changes in ldetect-lst-0.6.3-1.mga7 do fix the problem. I can boot to run
level 3 and use "startx startkde". Thanks!
Comment 12 David Walser 2019-08-11 17:44:52 CEST
Looks like you forgot to close the bug :o)

Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.