Bug 24941 - xdvi is not rendering ps/eps figure anymore
Summary: xdvi is not rendering ps/eps figure anymore
Status: RESOLVED WONTFIX
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: All Linux
Priority: Normal minor
Target Milestone: ---
Assignee: Marc Krämer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-11 16:19 CEST by Chris Denice
Modified: 2021-03-23 11:02 CET (History)
1 user (show)

See Also:
Source RPM: texlive-20180414-12.mga7.src.rpm
CVE:
Status comment:


Attachments
source latex file (402 bytes, text/x-tex)
2019-06-11 16:20 CEST, Chris Denice
Details
A postscript figure that is included. (40.92 KB, image/x-eps)
2019-06-11 16:21 CEST, Chris Denice
Details

Description Chris Denice 2019-06-11 16:19:58 CEST
When compiling a latex file containing a postscript figure, viewing the dvi file afterwards with xdvi does not render the postscript figure. That used to be fine with mga6 and our previous version of texlive.

Files attached for checking.

Compile with:
latex test.tex
this produces the file test.dvi. Open the file with:

xdvi test.dvi

enjoy the missing figure. You can check that the dvi file is correct, if you open it with, for instance "emacs", the figure is properly rendered.

Cheers,
Chris.
Comment 1 Chris Denice 2019-06-11 16:20:32 CEST
Created attachment 11078 [details]
source latex file

The file to compile with "latex"
Comment 2 Chris Denice 2019-06-11 16:21:33 CEST
Created attachment 11079 [details]
A postscript figure that is included.

Postscript figure that should be in the same directory as the test.tex file before compiling with "latex test.tex"
Comment 3 Marja Van Waes 2019-06-15 11:20:47 CEST
Assigning to our registered texlive maintainer.

Assignee: bugsquad => mageia
CC: (none) => marja11

Comment 4 Marc Krämer 2019-06-15 13:10:58 CEST
It looks like this is a ghostscript problem:
https://bugs.archlinux.org/task/56284

1) requirement to ghostscript-module-x is added for the future
2) made a few tests, looks like ghostscript is to blame, using ghostscript from mga6, xdvi works as expected.

So as stated by arch linux there is a API change, we use texlive 2018 and gs 9.27, so both should work with the new API.

I know xdvi is a small and handy tool, but maybe some of the desktop tools like evince kdvi, ... are working better.
Comment 5 Chris Denice 2019-06-22 17:30:58 CEST
Nope, that does not seem to be the cause of the bug, ghostscript-module-X is installed, it is indeed 9.27.1mga7 together with texlive 2018.

The bug is opened for mga7 only, I had no issue with mga6 in the past, so there is a breakage with 9.27 and 2018.

cheers,
chris.
Comment 6 Marc Krämer 2019-06-23 03:05:54 CEST
as said, xdvi works with "old" ghostscript but not with the newer one. So I guess ghostscript has done some more api changes which not have been adapted to xdvi (2018).
I'll have a look, if a newer version of xdvi fixes this issue.

Severity: normal => minor

Comment 7 Chris Denice 2019-06-23 10:58:57 CEST
Ok, I understand what you say. So report it upstream,that's clearly a texlive bug, they do maintain xdvi!
Comment 8 Marc Krämer 2019-06-23 19:15:44 CEST
@Chris: for testing purpose, I've built the latest 2019 package, bit still not image in xdvi.

E.g. atril (with atril-xdvi) works as expected.
Comment 9 Chris Denice 2019-07-09 16:10:39 CEST
Thanks for the suggestion of alternatives. I've also tried okular and evince.

It is amazing that none of this new dvi readers are actually as good as xdvi!!!

atril and evince do not support hyperlink...okular does, but it takes like more than 5 secs on my super fast machine (xeon 2 cpu 3.1GHz, 48 cores, 132Gb of RAM) to open a dvi file... no comment :)
Comment 10 Marc Krämer 2019-07-09 17:10:05 CEST
did you report this issue upstream? any feedback yet?
Comment 11 Chris Denice 2019-07-09 17:12:02 CEST
Nope, I thought you did... ;) I will then!
Comment 12 Chris Denice 2021-03-23 11:02:35 CET
Finally, this bug has been fixed upstream, xdvi works again in mga8.

Let's close as wontfix for mga7.

Resolution: (none) => WONTFIX
Status: NEW => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.