Bug 24688 - new version of java-1.8.0-openjfx
Summary: new version of java-1.8.0-openjfx
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: has_procedure MGA6-64-OK
Keywords: advisory, validated_update
Depends on: 24682
Blocks:
  Show dependency treegraph
 
Reported: 2019-04-18 12:21 CEST by Nicolas Salguero
Modified: 2019-05-12 11:36 CEST (History)
4 users (show)

See Also:
Source RPM: java-1.8.0-openjfx
CVE:
Status comment:


Attachments

Description Nicolas Salguero 2019-04-18 12:21:42 CEST
Hi,

There is a new version of openjfx.

Best regards,

Nico.
Comment 1 Nicolas Salguero 2019-04-18 12:22:59 CEST
Suggested advisory:
========================

The updated package provides OpenJFX 8u202.

========================

Package in core/updates_testing:
========================
java-1.8.0-openjfx-1.8.0.202-1.b07.1.mga6

from SRPM:
java-1.8.0-openjfx-1.8.0.202-1.b07.1.mga6.src.rpm

The test procedure is in bug 20220, comment 3.

Status: NEW => ASSIGNED
Whiteboard: (none) => has_procedure
Source RPM: (none) => java-1.8.0-openjfx
Assignee: bugsquad => qa-bugs

Comment 2 Len Lawrence 2019-04-18 18:39:31 CEST
Updated cleanly for mga6, x86_64.

$ java -version
openjdk version "1.8.0_201"
OpenJDK Runtime Environment (build 1.8.0_201-b09)
OpenJDK 64-Bit Server VM (build 25.201-b09, mixed mode)

$ rpm -qa | grep openjfx
java-1.8.0-openjdk-openjfx-1.8.0.201-1.b09.2.mga6
java-1.8.0-openjdk-openjfx-devel-1.8.0.201-1.b09.2.mga6
java-1.8.0-openjfx-1.8.0.202-1.b07.1.mga6

$ javac -cp ".:/usr/share/java/*" helloworld.java
$ java helloworld
Exception in thread "main" java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:498)
	at sun.launcher.LauncherHelper$FXHelper.main(LauncherHelper.java:767)
Caused by: java.lang.RuntimeException: java.lang.UnsatisfiedLinkError: Can't load library: /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.201-1.b09.2.mga6.x86_64/jre/lib/amd64/libglassgtk2.so
	at com.sun.javafx.tk.quantum.QuantumToolkit.startup(QuantumToolkit.java:267)
	at com.sun.javafx.application.PlatformImpl.startup(PlatformImpl.java:211)
	at com.sun.javafx.application.LauncherImpl.startToolkit(LauncherImpl.java:675)
	at com.sun.javafx.application.LauncherImpl.launchApplicationWithArgs(LauncherImpl.java:337)
	at com.sun.javafx.application.LauncherImpl.launchApplication(LauncherImpl.java:328)
	... 5 more
Caused by: java.lang.UnsatisfiedLinkError: Can't load library: /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.201-1.b09.2.mga6.x86_64/jre/lib/amd64/libglassgtk2.so
	at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1827)
	at java.lang.Runtime.load0(Runtime.java:809)
	at java.lang.System.load(System.java:1086)
	at com.sun.glass.utils.NativeLibLoader.loadLibraryFullPath(NativeLibLoader.java:201)
	at com.sun.glass.utils.NativeLibLoader.loadLibraryInternal(NativeLibLoader.java:94)
	at com.sun.glass.utils.NativeLibLoader.loadLibrary(NativeLibLoader.java:39)
	at com.sun.glass.ui.gtk.GtkApplication.lambda$new$5(GtkApplication.java:151)
	at java.security.AccessController.doPrivileged(Native Method)
	at com.sun.glass.ui.gtk.GtkApplication.<init>(GtkApplication.java:140)
	at com.sun.glass.ui.gtk.GtkPlatformFactory.createApplication(GtkPlatformFactory.java:41)
	at com.sun.glass.ui.Application.run(Application.java:146)
	at com.sun.javafx.tk.quantum.QuantumToolkit.startup(QuantumToolkit.java:257)
	... 9 more
 
No gui button of course.

CC: (none) => tarazed25

Comment 3 Len Lawrence 2019-04-18 18:47:10 CEST
There were several openjdk packages in the update list so I installed those, on the off-chance, and recompiled.

$ java helloworld
Hello World!

The widget appeared and pressing the button invoked the response in the terminal.

$ rpm -qa | grep openjdk
java-1.8.0-openjdk-devel-1.8.0.212-1.b02.1.mga6
java-1.8.0-openjdk-demo-1.8.0.212-1.b02.1.mga6
java-1.8.0-openjdk-headless-1.8.0.212-1.b02.1.mga6
java-1.8.0-openjdk-javadoc-zip-1.8.0.212-1.b02.1.mga6
java-1.8.0-openjdk-openjfx-devel-1.8.0.212-1.b02.1.mga6
java-1.8.0-openjdk-openjfx-1.8.0.212-1.b02.1.mga6
java-1.8.0-openjdk-1.8.0.212-1.b02.1.mga6
java-1.8.0-openjdk-javadoc-1.8.0.212-1.b02.1.mga6
java-1.8.0-openjdk-src-1.8.0.212-1.b02.1.mga6
java-1.8.0-openjdk-accessibility-1.8.0.212-1.b02.1.mga6
Comment 4 Len Lawrence 2019-04-18 19:20:59 CEST
Backtracked on this and ran the test pre-update on another mga6 partition.
Installed java openjfx, which pulled in the necessary openjdk packages.
Compiled and ran the helloworld tests, which succeeded.

Updated just the openjfx package and ran the test, which failed again.

This confirms that the openjdk update #24682 needs to be tested first - it does have an earlier bug id.
Comment 5 Len Lawrence 2019-04-18 19:40:43 CEST
https://bugs.mageia.org/show_bug.cgi?id=24682 has now been tested independently so this bug is done.  64-bit OK.

Whiteboard: has_procedure => has_procedure MGA6-64-OK

Comment 6 Len Lawrence 2019-04-18 20:37:40 CEST
To summarize, where A is openjdk and B is openjfx, - is before update, + is after update: there are four scenarios involving the compile test.

A-, B- : OK
A-, B+ : fail
A+, B- : OK
A+, B+ : OK
Comment 7 Thomas Andrews 2019-05-02 16:28:09 CEST
OK, then. Since I validated Bug 24682, I will validate this one as well. Suggested advisory in Comment 1.

Sysadmins, going by Len's testing, please make sure that the packages from Bug 24682 go out either before or at the same time as this one.

Keywords: (none) => validated_update
CC: (none) => andrewsfarm, sysadmin-bugs

David Walser 2019-05-02 17:14:09 CEST

Depends on: (none) => 24682

Thomas Backlund 2019-05-12 10:36:34 CEST

CC: (none) => tmb
Keywords: (none) => advisory

Comment 8 Mageia Robot 2019-05-12 11:36:51 CEST
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2019-0032.html

Resolution: (none) => FIXED
Status: ASSIGNED => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.