Bug 23646 - Backport request: nvidia-current-410.57-1.mga6.nonfree
Summary: Backport request: nvidia-current-410.57-1.mga6.nonfree
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: Backports (show other bugs)
Version: 6
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA6-64-OK
Keywords: validated_backport
Depends on:
Blocks:
 
Reported: 2018-10-06 21:49 CEST by Thomas Backlund
Modified: 2018-10-14 09:33 CEST (History)
1 user (show)

See Also:
Source RPM: nvidia-current
CVE:
Status comment:


Attachments

Description Thomas Backlund 2018-10-06 21:49:46 CEST
Note,
this is mainly for being able to support the new nVidia RTX20xx (Turing) on Mageia 6. And the reason for not pushing the driver as a normal update is that nvidia-current beginning with 4xx series are 64bit only, and drops support for some older

I've confirmed it works with a RTX 2080

SRPMS:
ldetect-lst-0.3.7.9-2.mga6.src.rpm

nvidia-current-410.57-1.mga6.nonfree.src.rpm


x86_64:
ldetect-lst-0.3.7.9-2.mga6.x86_64.rpm
ldetect-lst-devel-0.3.7.9-2.mga6.x86_64.rpm

dkms-nvidia-current-410.57-1.mga6.nonfree.x86_64.rpm
nvidia-current-cuda-opencl-410.57-1.mga6.nonfree.x86_64.rpm
nvidia-current-devel-410.57-1.mga6.nonfree.x86_64.rpm
nvidia-current-doc-html-410.57-1.mga6.nonfree.x86_64.rpm
x11-driver-video-nvidia-current-410.57-1.mga6.nonfree.x86_64.rpm
Comment 1 Len Lawrence 2018-10-07 17:13:32 CEST
This did not go very well.  Installed all the packages but on reboot was switched to the nouveau driver.  Logged in and uninstalled dkms-nvidia-current then reinstalled it.  Was advised to run XFdrake but when nvidia proprietary driver was selected a message came up about the driver not having been installed correctly, defaulting to nouveau driver.

# dkms status
nvidia-current, 410.57-1.mga6.nonfree, 4.18.12-desktop-1.mga6, x86_64: installed 
virtualbox, 5.2.18-1.mga6, 4.14.68-tmb-desktop-1.mga6, x86_64: installed  (WARNING! Diff between built and installed module!) (WARNING! Diff between built and installed module!) (WARNING! Diff between built and installed module!) (WARNING! Diff between built and installed module!)

$ rpm -qa | grep nvidia
x11-driver-video-nvidia-current-410.57-1.mga6.nonfree
nvidia-current-cuda-opencl-410.57-1.mga6.nonfree
nvidia-current-devel-410.57-1.mga6.nonfree
nvidia-current-doc-html-410.57-1.mga6.nonfree
dkms-nvidia-current-410.57-1.mga6.nonfree

# modprobe nvidia
modprobe: FATAL: Module nvidia not found in directory /lib/modules/4.18.12-desktop-1.mga6

$ ll /lib/modules/4.18.12-desktop-1.mga6/dkms/drivers/char/drm
total 9748
-rw-r--r-- 1 root root 9255372 Oct  7 15:51 nvidia-current.ko.xz
-rw-r--r-- 1 root root   17392 Oct  7 15:51 nvidia-drm.ko.xz
-rw-r--r-- 1 root root  418160 Oct  7 15:51 nvidia-modeset.ko.xz
-rw-r--r-- 1 root root  282360 Oct  7 15:51 nvidia-uvm.ko.xz

CC: (none) => tarazed25

Comment 2 Len Lawrence 2018-10-07 17:14:47 CEST
The card is GTX970.
Comment 3 Thomas Backlund 2018-10-07 17:16:40 CEST
Ouch :/

Can you post lspcidrake -v for that card ?
Comment 4 Len Lawrence 2018-10-07 17:24:32 CEST
$ lspcidrake -v | grep NVIDIA
snd_hda_intel   : NVIDIA Corporation|GM204 High Definition Audio Controller [MULTIMEDIA_AUDIO_DEV] (vendor:10de device:0fbb subv:1462 subd:3171) (rev: a1)
Card:NVIDIA GeForce 420 series and later: NVIDIA Corporation|GM204 [GeForce GTX 970] [DISPLAY_VGA] (vendor:10de device:13c2 subv:1462 subd:3171) (rev: a1)

Meanwhile, it works fine on the core i9 system with NVIDIA GTX1080Ti.

I shall try another partition on the suspect system to try and eliminate disk errors.
Comment 5 Len Lawrence 2018-10-07 17:43:17 CEST
Re comment #4.  On another partition everything was fine.  teapot running at 1700fps.  Maybe time to run e2fsck.
Comment 6 Len Lawrence 2018-10-07 18:19:35 CEST
Re comment #5.

Ran e2fsck on /dev/sda2, which came up clean.
Switched to sda2 and tried removing and reinstalling the nvidia modules.  No problems apparent at that stage but because the current driver was nouveau the XFdrake advice was posted again.  That baulked at the proprietary driver again - driver not properly installed, defaulting ....

All I can do now is a complete reinstall on that partition (production system).
Comment 7 Len Lawrence 2018-10-07 21:27:40 CEST
Continuing from comment 6.  After the reinstallation and update nvidia 410.57 was running fine from the sda2 partition.  Another of life's little mysteries.
Comment 8 Len Lawrence 2018-10-12 15:51:26 CEST
Mageia 6, x86_64
Updated nvidia-current, ran update-grub2 and rebooted
NVIDIA 410.57 running fine on an Aorus X5 laptop with GTX965M.
$ uname -r
4.14.70-desktop-2.mga6
Comment 9 Len Lawrence 2018-10-12 15:54:54 CEST
Looks like nobody has a Turing system so on the basis of it working on earlier hardware this should be pushed.
Len Lawrence 2018-10-12 15:55:18 CEST

Whiteboard: (none) => MGA6-64-OK

Comment 10 Thomas Backlund 2018-10-12 16:04:02 CEST
(In reply to Len Lawrence from comment #9)
> Looks like nobody has a Turing system so on the basis of it working on
> earlier hardware this should be pushed.

Quoting comment 1:

"I've confirmed it works with a RTX 2080" which is Turing series :)
Comment 11 Len Lawrence 2018-10-13 01:13:55 CEST
Sorry - I did read that - I meant anybody else.
Len Lawrence 2018-10-13 01:14:47 CEST

Keywords: (none) => validated_backport

Comment 12 Thomas Backlund 2018-10-14 09:33:51 CEST
Packages moved

Status: NEW => RESOLVED
Resolution: (none) => FIXED


Note You need to log in before you can comment on or make changes to this bug.