Upstream has issued an advisory on August 21:
The issue is fixed upstream in 4.8.3:
Mageia 5 and Mageia 6 are also affected.
Assigning to the registered maintainer.
Fixed in Cauldron by Marc.
since this issue is not severe and the patch is not applicable to our version, I won't fix it for mga6.
Since phpmyadmin is a standalone package I think you can simply update to latest version, somewhat like what we mostly do for php...
@Thomas: no, this version has still issues that affect the normal workflow.
I'll have to make some more testing on the latest version, but this update has to many changes.
openSUSE has issued an advisory for this on August 27:
Updated phpymadmin packages fix security vulnerabilities:
A Cross-Site Scripting vulnerability was found in the file import feature, where an attacker can deliver a payload to a user through importing a specially-crafted file.
We ship the current stable version of phpmyadmin.
Updated packages in core/updates_testing:
Links in Comment 0 should also be in the advisory references, and the updated package is actually:
Sorry, I'll have to revert that update.
We'll have to stay with 4.7.x since 4.8 officially requires PHP 7.1 .
So, instead of updating, I'll apply the patch. I don't want to have trouble with releases PHP 5.6, even if it runs.
I'll skip this patch. The patch is only valid for 4.8.x and the structures totally changed. I'm not really sure, if 4.7 is really affected. And even phpmyadmin guy say "We consider this attack to be of moderate severity.", which is my opinion too.
When we push php7 to mga6, we can do this update as well. I'll close it for now.
It sounds like 4.7 isn't affected then.