Bug 2326 - Feature Request for wmctrl
Summary: Feature Request for wmctrl
Alias: None
Product: Mageia
Classification: Unclassified
Component: New RPM package request (show other bugs)
Version: 1
Hardware: All Linux
Priority: Normal enhancement
Target Milestone: ---
Assignee: QA Team
QA Contact:
Keywords: validated_update
Depends on:
Reported: 2011-07-29 10:49 CEST by Cornel Ahlers
Modified: 2011-09-18 02:04 CEST (History)
6 users (show)

See Also:
Source RPM:
Status comment:


Description Cornel Ahlers 2011-07-29 10:49:38 CEST

I would like to see wmctrl in the official Repositories, as it is a very useful tool needed for example for the option of resizing windows to the left or right half of your screen.

wmctrl has been in Mandriva 2010.2 afaik and is not a big deal, I presume.

Thank you very much,

Comment 1 D Morgan 2011-08-29 01:57:31 CEST
update pushed in update_testing.

Please test.

CC: (none) => dmorganec
Assignee: bugsquad => qa-bugs

Comment 2 Dave Hodgins 2011-08-29 03:36:20 CEST
Testing complete on i586, for the srpm

Ran wmctrl -l, copied one of the window titles (everything after the
hostname), and ran wmctrl -R window title.

It brought the window to the foreground.

CC: (none) => davidwhodgins

Comment 3 Derek Jennings 2011-08-29 15:07:02 CEST
Testing complete on x86_64
Checked man pages are present. Tried out a variety of command line switches including -a -m -r -R -b -p -d -k -s

All worked but I noticed that not all running applications appeared in the list of windows produced by wmctrl -l
Opera, plasma-desktop, and kcalc did appear in the window list, but firefox, konsole, libreoffice and konqueror did not. Thinking it might be something to do with KDE I tried again with LXDE with similar results. Under LXDE rxvt, libreoffice and firefox did not appear in the list of managed windows. (These are just the applications I happened to have running.)

Where a window appears in the list of windows managed by the window manager wmctrl works, but I cannot explain why some windows are not manageable. Is this expected behaviour?

CC: (none) => derekjenn

Comment 4 Dave Hodgins 2011-08-29 19:54:49 CEST
Strange.  On my i586 system ...
$ wmctrl -l
0x01e0014a -1 hodgins.homeip.net plasma-desktop
0x01e00147 -1 hodgins.homeip.net plasma-desktop
0x01c0001c  0 hodgins.homeip.net log : tail
0x0640000a  0 hodgins.homeip.net Inbox (393) - Opera 11.51, Build 1084
0x01c01b90  0 hodgins.homeip.net dave : bash
0x06a00096  0 hodgins.homeip.net Mozilla Firefox

So firefox is showing up here.  Note that it's the window title that shows,
which varies depending on what website is currently open.
Comment 5 Derek Jennings 2011-08-29 20:42:16 CEST
I have confirmed it is only the x86_64 version of this package with a problem. (I suppose that is why we test both)

With wmctrl-1.07-4.1.mga1.x86_64.rpm installed
$ wmctrl -l
0x01e00112 4294967295 derek.localdomain plasma-desktop
0x01e0010f 4294967295 derek.localdomain plasma-desktop
0x01a0000a  0 derek.localdomain Bug 2326 â Feature Request for wmctrl - Opera

With wmctrl-1.07-4.1.mga1.i586.rpm installed
$ wmctrl -l
0x01e00112 -1 derek.localdomain plasma-desktop
0x01e0010f -1 derek.localdomain plasma-desktop
0x01a0000a  0 derek.localdomain Bug 2326 â Feature Request for wmctrl - Opera
0x0120001c  3 derek.localdomain derek : bash
0x05600121  1 derek.localdomain Oracle VM VirtualBox Manager
0x05a00164  1 derek.localdomain mageaia (mageia) [Running] - Oracle VM VirtualBox
0x05800062  3 derek.localdomain ftp://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/distrib/1/i586/media/core/updates_testing

I also tried it out with the Mandriva packages for wmctrl and they behaved exactly the same. The x86_64 version does not list all the open windows.

Since wmctrl has not been touched upstream since 2005 would the simplest solution be to push only the i586 version?
Comment 6 Derek Jennings 2011-08-29 21:22:04 CEST
Apparently Fedora has a fix for this
Comment 7 Samuel Verschelde 2011-09-10 00:43:13 CEST
Fedora had a fix indeed, but it looks like they removed the package totally from Fedora 15, due to the package having no active owner.

See shortlog in http://pkgs.fedoraproject.org/gitweb/?p=wmctrl.git

As dmorgan imported it I'll suppose the package has an owner for mageia :)

CC: (none) => stormi

Comment 8 Samuel Verschelde 2011-09-10 01:11:00 CEST
I submitted wmctrl-1.07-4.2.mga1 with a fix from debian (that was taken by fedora too). Please test the new package on both i586 and x86_64.
Comment 9 Dave Hodgins 2011-09-10 03:51:01 CEST
Testing of the srpm 
complete on i586.
Comment 10 Dave Hodgins 2011-09-17 00:27:58 CEST
Still need an x86-64 tester.  See comment 2 for testing method.
Comment 11 claire robinson 2011-09-17 12:21:02 CEST
Tested OK x86_64 with various options. All windows appear to be listed and manipulated with no issues.

Update validated.

SRPM: wmctrl-1.07-4.2.mga1.src.rpm



This update adds wmctrl which was present in Mandriva 2010.2 but missing from Mageia 1.

Wmctrl provides command line access to almost all the features defined
in the EWMH specification. Using it, it's possible to, for example,
obtain information about the window manager, get a detailed list of
desktops and managed windows, switch and resize desktops, change number
of desktops, make windows full-screen, always-above or sticky, and
activate, close, move, resize, maximize and minimize them.

The command line access makes it easy to automate these tasks and
execute them from any application that is able to run a command in
response to some event.

Please note that wmctrl only works with window managers which implement
this specification.


Could somebody from sysadmin please push from core/updates_testing to core/updates.


Keywords: (none) => validated_update
CC: (none) => eeeemail, sysadmin-bugs

Comment 12 D Morgan 2011-09-18 02:04:15 CEST
update pushed.

Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.