Bug 23254 - Kmymoney 5.0.1 crashes every time I try to create a new account
Summary: Kmymoney 5.0.1 crashes every time I try to create a new account
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA6-64-OK
Keywords: advisory, validated_update
: 23260 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-06-30 10:57 CEST by regis carles
Modified: 2019-01-11 22:09 CET (History)
9 users (show)

See Also:
Source RPM: kmymoney-5.0.1-1.mga6
CVE:
Status comment:


Attachments

Description regis carles 2018-06-30 10:57:53 CEST
Description of problem:
Kmymoney 5.0.1 crashes every time I try to create a new account.

Version-Release number of selected component (if applicable):
kmymoney-5.0.1-1.mga6.x86_64

How reproducible:
Just try to create a new account, and after clicking on last button of the creation account wizard : Kmymoney crashes.

My configuration :
KDE plasma 5.12.2, and KDE Framework 5.42.0.


(gdb) bt
#0 0x00007ffff60a214b in MyMoneyInstitution::pixmap(int) const ()
at /lib64/libkmm_mymoney.so.5
#1 0x00000000007ff4f1 in InstitutionsModel::slotObjectModified(eMyMoney::File::Object, MyMoneyObject const*) ()
#2 0x00007ffff18ffc7e in QMetaObject::activate(QObject*, int, int, void**) ()
at /lib64/libQt5Core.so.5
#3 0x00007ffff61181b0 in MyMoneyFile::objectModified(eMyMoney::File::Object, MyMoneyObject const*) () at /lib64/libkmm_mymoney.so.5
#4 0x00007ffff605655b in MyMoneyFile::commitTransaction() ()
at /lib64/libkmm_mymoney.so.5
#5 0x00007ffff60602d5 in MyMoneyFileTransaction::commit() ()
at /lib64/libkmm_mymoney.so.5
#6 0x00000000006253d1 in NewAccountWizard::Wizard::newAccount(MyMoneyAccount&) ()
#7 0x000000000050c862 in KAccountsView::slotNewAccount() ()
#8 0x00007ffff18ffc7e in QMetaObject::activate(QObject*, int, int, void**) ()
at /lib64/libQt5Core.so.5
#9 0x00007ffff23b3532 in QAction::triggered(bool) ()
at /lib64/libQt5Widgets.so.5
#10 0x00007ffff23b5a00 in QAction::activate(QAction::ActionEvent) ()
at /lib64/libQt5Widgets.so.5
#11 0x00007ffff24ad080 in QAbstractButtonPrivate::click() ()
at /lib64/libQt5Widgets.so.5
Comment 1 Marja Van Waes 2018-07-01 07:02:44 CEST
Assigning to the registered kmymoney maintainer, CC'ing the KDE maintainers

CC: (none) => kde, marja11
Assignee: bugsquad => lists.jjorge

Comment 2 Marja Van Waes 2018-07-02 06:51:20 CEST
*** Bug 23260 has been marked as a duplicate of this bug. ***

CC: (none) => mnspiegel

Comment 3 Marja Van Waes 2018-07-02 06:52:33 CEST
CC'ing all packagers collectively, because the assignee is unavailable for 3 weeks.

Source RPM: kmymoney-5.0.1-1.mga6.x86_64 => kmymoney-5.0.1-1.mga6
CC: (none) => pkg-bugs

Comment 4 Martin Spiegel 2018-07-03 08:53:28 CEST
(In reply to regis carles from comment #0)
I can confirm this. Every time I try to create a new account in kmymoney 5.0.1 it causes a segmentation fault aand crashes. The bug was not present in the previous version (4.8. series).

Martin
Comment 5 José Jorge 2018-07-19 08:44:28 CEST
Please report Upstream if you can provide a debug info as it seems they still consider 4.8 version as the stable one.

As a workaround, you can still downgrade to this version in Mageia 6.

Status: NEW => ASSIGNED

Comment 6 regis carles 2018-07-19 17:26:41 CEST
I downgraded to 4.8.0 version.

But I can't launch kmymoney anymore :

[regis@localhost ~]$ kmymoney
kmymoney: symbol lookup error: kmymoney: undefined symbol: _ZN23onlineJobAdministration10m_instanceE

Do you have another advice ?

Thanks.
Comment 7 José Jorge 2018-07-22 17:02:50 CEST
(In reply to regis carles from comment #6)
> I downgraded to 4.8.0 version.
> 
> But I can't launch kmymoney anymore :
> 
> [regis@localhost ~]$ kmymoney
> kmymoney: symbol lookup error: kmymoney: undefined symbol:
> _ZN23onlineJobAdministration10m_instanceE
> 

You would have to downgrade all kmymoney libs. My only advice is to report upstream, as they may already have a
Comment 8 José Jorge 2018-07-22 17:03:46 CEST
(In reply to José Jorge from comment #7)
> You would have to downgrade all kmymoney libs. My only advice is to report
> upstream, as they may already have a

patch for it.
Comment 9 José Jorge 2018-07-22 17:11:26 CEST
I've seen in the MGA forum it works on OpenSuse, with KF 5.45 and Plasma 5.12.5. So it seems a MGA problem. Assigning to KDE team, as they should much better know how to upgrade our MGA6 plasma...

French Ref : https://mageialinux-online.org/forum/topic-25269+kmymoney-5-0-1-ne-peut-pas-creer-de-nouveau-compte.php

CC: (none) => lists.jjorge
Assignee: lists.jjorge => kde

Comment 10 Jerome C 2018-10-22 18:09:23 CEST
Hello everyone,

I've been facing the same bug for a few days trying to create a new account on kmymoney. After several attempts I noticed that it is possible to create anyway a new bank account if we don't fill Institutions values.

So I tried to simply create a new institution and there ... crash!
Perhaps it can help finding the bug source to look into the institutions code ? 

Config: Mageia 6 64bits; Kmymoney 5.0.1; KDE Plasma 5.12.2 KDE framework 5.42.0; Qt 5.9.4

CC: (none) => jerome.castaings

Comment 11 José Jorge 2018-10-22 18:49:55 CEST
(In reply to Jerome C from comment #10)
> So I tried to simply create a new institution and there ... crash!

Thanks for the hint, it is a good workaround. In fact, it does not crash also in Cauldron, so it is unfortunately the kdelibs version in MGA6 that trigger this bug..
Comment 12 Martin Spiegel 2018-10-24 17:52:27 CEST
(In reply to Jerome C from comment #10)
> Hello everyone,
> 
> I've been facing the same bug for a few days trying to create a new account
> on kmymoney. After several attempts I noticed that it is possible to create
> anyway a new bank account if we don't fill Institutions values.
> 
> So I tried to simply create a new institution and there ... crash!
> Perhaps it can help finding the bug source to look into the institutions
> code ? 
> 
> Config: Mageia 6 64bits; Kmymoney 5.0.1; KDE Plasma 5.12.2 KDE framework
> 5.42.0; Qt 5.9.4

Thanks for the workaround, works for me too!
Comment 13 José Jorge 2018-11-05 19:30:05 CET
I have submitted to updates/testing bugfix version 5.0.2 let's see if it fixes this bug... at least it fixes OFX import dialog
Comment 14 Dan Fandrich 2019-01-10 10:23:02 CET
I fixed the build issue that was preventing the build of 5.0.2 in mga6, so it's now available as kmymoney-5.0.2-1.mga6 in core/updates_testing.

CC: (none) => dan

Comment 15 José Jorge 2019-01-10 16:03:43 CET
(In reply to Dan Fandrich from comment #14)
> I fixed the build issue that was preventing the build of 5.0.2 in mga6, so
> it's now available as kmymoney-5.0.2-1.mga6 in core/updates_testing.

Thanks for your work Dan. Assigning to Q/A. Dan, would you like to add the package list here following the mageia advisory example?

Assignee: kde => qa-bugs

Comment 16 Dan Fandrich 2019-01-10 16:38:03 CET
I'm happy to do that. I'm still doing a bit of testing myself first. I've already fixed some dependencies and dupe files and have built kmymoney-5.0.2-2.mga6
Comment 17 José Jorge 2019-01-10 18:47:25 CET
(In reply to Dan Fandrich from comment #16)
> I'm happy to do that. I'm still doing a bit of testing myself first. I've
> already fixed some dependencies and dupe files and have built
> kmymoney-5.0.2-2.mga6

Cool. You must add a conflict in main package against kmymoney-plugin-weboob <=5.0.1 :

[live@cavalo ~]$ LC_MESSAGES=C sudo urpmi --searchmedia testing kmymoney
To satisfy dependencies, the following packages are going to be installed:
  Package                        Version      Release       Arch    
(medium "Core Updates Testing (distrib5)")
  kmymoney                       5.0.2        2.mga6        x86_64  
  lib64kmm_icons5                5.0.2        2.mga6        x86_64  
  lib64kmm_menus5                5.0.2        2.mga6        x86_64  
  lib64kmm_models5               5.0.2        2.mga6        x86_64  
  lib64kmm_mymoney5              5.0.2        2.mga6        x86_64  
  lib64kmm_payeeidentifier5      5.0.2        2.mga6        x86_64  
  lib64kmm_plugin5               5.0.2        2.mga6        x86_64  
  lib64kmm_settings5             5.0.2        2.mga6        x86_64  
  lib64kmm_widgets5              5.0.2        2.mga6        x86_64  
1.5MB of disk space will be freed.
13MB of packages will be retrieved.
Proceed with the installation of the 9 packages? (Y/n) 


installing lib64kmm_models5-5.0.2-2.mga6.x86_64.rpm lib64kmm_plugin5-5.0.2-2.mga6.x86_64.rpm lib64kmm_settings5-5.0.2-2.mga6.x86_64.rpm kmymoney-5.0.2-2.mga6.x86_64.rpm lib64kmm_icons5-5.0.2-2.mga6.x86_64.rpm lib64kmm_menus5-5.0.2-2.mga6.x86_64.rpm lib64kmm_mymoney5-5.0.2-2.mga6.x86_64.rpm lib64kmm_widgets5-5.0.2-2.mga6.x86_64.rpm lib64kmm_payeeidentifier5-5.0.2-2.mga6.x86_64.rpm from /var/cache/urpmi/rpms
Preparing...                     ################################################################
Installation failed:    file /usr/share/kmymoney/weboob/kmymoneyweboob.pyc from install of kmymoney-5.0.2-2.mga6.x86_64 conflicts with file from package kmymoney-plugin-weboob-5.0.1-1.mga6.x86_64
        file /usr/share/kmymoney/weboob/kmymoneyweboob.pyo from install of kmymoney-5.0.2-2.mga6.x86_64 conflicts with file from package kmymoney-plugin-weboob-5.0.1-1.mga6.x86_64
Comment 18 Dan Fandrich 2019-01-10 23:45:27 CET
That problem was due to me dropping the weboob plugin directory from the main package but not the contents of the directory. It should be fixed now. Here are the new packages:

SRPM:
kmymoney-5.0.2-3.mga6

x86_64:
kmymoney-5.0.2-3.mga6
kmymoney-debuginfo-5.0.2-3.mga6
kmymoney-devel-5.0.2-3.mga6
kmymoney-plugin-weboob-5.0.2-3.mga6
lib64kmm_csvimportercore5-5.0.2-3.mga6
lib64kmm_icons5-5.0.2-3.mga6
lib64kmm_menus5-5.0.2-3.mga6
lib64kmm_models5-5.0.2-3.mga6
lib64kmm_mymoney5-5.0.2-3.mga6
lib64kmm_payeeidentifier5-5.0.2-3.mga6
lib64kmm_plugin5-5.0.2-3.mga6
lib64kmm_settings5-5.0.2-3.mga6
lib64kmm_widgets5-5.0.2-3.mga6

i586:
kmymoney-5.0.2-3.mga6
kmymoney-debuginfo-5.0.2-3.mga6
kmymoney-devel-5.0.2-3.mga6
kmymoney-plugin-weboob-5.0.2-3.mga6
libkmm_csvimportercore5-5.0.2-3.mga6
libkmm_icons5-5.0.2-3.mga6
libkmm_menus5-5.0.2-3.mga6
libkmm_models5-5.0.2-3.mga6
libkmm_mymoney5-5.0.2-3.mga6
libkmm_payeeidentifier5-5.0.2-3.mga6
libkmm_plugin5-5.0.2-3.mga6
libkmm_settings5-5.0.2-3.mga6
libkmm_widgets5-5.0.2-3.mga6

Hardware: x86_64 => All

Comment 19 José Jorge 2019-01-11 18:05:58 CET
Tested with x64_64, all bugs fixed : creating a new account, importing an OFX do not crash anymore.

Suggested advisory :
Kmymoney 5.0.2 comes with a lot of bugfixes including crashes on creating a new account.
REF : https://kmymoney.org/release-notes.php

Whiteboard: (none) => MGA6-64-OK

Comment 20 Lewis Smith 2019-01-11 20:19:45 CET
Thank you José for your knowledgeable tests.
Advisory from comments 19 & 18.

CC: (none) => lewyssmith, sysadmin-bugs
Keywords: (none) => advisory, validated_update

Comment 21 Mageia Robot 2019-01-11 22:09:10 CET
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2019-0002.html

Resolution: (none) => FIXED
Status: ASSIGNED => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.