Bug 23122 - Missing depency to switch graphic cards on optimus hardware
Summary: Missing depency to switch graphic cards on optimus hardware
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA6-64-OK
Keywords: advisory, validated_update
Depends on:
Blocks:
 
Reported: 2018-06-06 18:00 CEST by Patric Schramm
Modified: 2018-06-14 20:15 CEST (History)
4 users (show)

See Also:
Source RPM: mageia-prime-0.4-1.mga6.nonfree.src.rpm
CVE:
Status comment:


Attachments

Description Patric Schramm 2018-06-06 18:00:19 CEST
Description of problem: 
When installing mageia-prime and executing /usr/sbin/mageia-prime-install it pulls all packages for the nvidia drivers to work. But when you reboot the screen stays black when trying to start X. 

You need to install xrandr to make the switching process work properly.

How reproducible:

Install the package and switch to the nvidia card. Then try to login.

Solution:

1: urpmi xrandr
2: reboot
3: everything is working as expected
4: switching back to intel graphics also works fine now.
David Walser 2018-06-06 18:57:32 CEST

Assignee: bugsquad => ghibomgx
CC: (none) => rverschelde

Morgan Leijström 2018-06-06 22:41:10 CEST

CC: (none) => fri

Comment 1 Rémi Verschelde 2018-06-06 22:51:22 CEST
Thanks for the report, fixed in Cauldron and pushing an update candidate for Mageia 6. I've also added systemd-units as dependency since the tool uses /bin/systemctl.

@joeghi: mageia-prime really needs a man page/--help output, I always need to check the readme in the GitHub repo to use it so I imagine it's far from user-friendly for other Mageia users.

@QA: The only change is the addition of two dependencies (Requires) on xrandr and systemd-units, so testing that the package pulls in xrandr/systemd-units if not installed is enough (and if xrandr is installed, `urpme --test xrandr` should tell you that it wants to remove mageia-prime).

Note: I messed up the subrel/rel, it's 2.1.mga6 when it should have been 1.2.mga6, but it should be OK as is (Mageia 7 has 3.mga7 so it's safe).

Advisory:
=========

Updated mageia-prime package fixes missing dependency

  The mageia-prime utility requires the xrandr and systemctl commands,
  but they were not explicitly listed as dependencies. This update fixes it.

SRPM in core/updates_testing:
=============================

mageia-prime-0.4-2.1.mga6

RPM in core/updates_testing:
============================

mageia-prime-0.4-2.1.mga6

Assignee: ghibomgx => qa-bugs
CC: (none) => ghibomgx

Comment 2 Rémi Verschelde 2018-06-07 09:10:02 CEST
Tested successfully on Mageia 6 x86_64:

$ urpmq --requires mageia-prime --searchmedia release
--requires behaviour changed, use --requires-recursive to get the old behaviour
dnf
dnf-command(config-manager)
dnf-command(install)
drakxtools-backend
grub2-common
kmod
libc.so.6()(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.3.4)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
pciutils
urpmi

$ urpmq --requires mageia-prime --searchmedia testing
--requires behaviour changed, use --requires-recursive to get the old behaviour
dnf
dnf-command(config-manager)
dnf-command(install)
drakxtools-backend
grub2-common
kmod
libc.so.6()(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.3.4)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
pciutils
systemd-units
urpmi
xrandr

# urpme --test xrandr
To satisfy dependencies, the following 3 packages will be removed (6.1MB):
  lutris-0.4.16-1.mga6.noarch
   (due to missing xrandr)
  mageia-prime-0.4-2.1.mga6.x86_64
   (due to missing xrandr)
  xrandr-1.5.0-1.mga6.x86_64
Remove 3 packages? (y/N) N

Whiteboard: (none) => MGA6-64-OK

Comment 3 Rémi Verschelde 2018-06-07 09:11:14 CEST
Advisory uploaded, validating.

Keywords: (none) => advisory, validated_update
CC: (none) => sysadmin-bugs

Comment 4 Mageia Robot 2018-06-14 20:15:51 CEST
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2018-0116.html

Status: NEW => RESOLVED
Resolution: (none) => FIXED


Note You need to log in before you can comment on or make changes to this bug.