Bug 23109 - ocrfeeder fails to start due to missing python-gi and python-lxml dependencies
Summary: ocrfeeder fails to start due to missing python-gi and python-lxml dependencies
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA6-32-OK
Keywords: advisory, validated_update
Depends on:
Blocks:
 
Reported: 2018-06-02 21:19 CEST by A Walker
Modified: 2018-06-14 20:15 CEST (History)
7 users (show)

See Also:
Source RPM: ocrfeeder-0.8.1-3.mga6.src.rpm
CVE:
Status comment:


Attachments

Description A Walker 2018-06-02 21:19:41 CEST
Description of problem:
Installed ocrfeeder-0.8.1-3.mga6 using urpmi and accepting all dependencies. The program failed to start. When started from the command line, I got the following:
Traceback (most recent call last): 
 File "/bin/ocrfeeder", line 31, in <module> 
   from ocrfeeder.studio.studioBuilder import Studio 
 File "/usr/lib/python2.7/site-packages/ocrfeeder/studio/studioBuilder.py", line 22, in <module> 
   from ocrfeeder.util import lib 
 File "/usr/lib/python2.7/site-packages/ocrfeeder/util/lib.py", line 26, in <module> 
   from gi.repository import Gtk 
ImportError: No module named gi.repository
 
At this point, I installed python-gi-3.24.1-1.mga6.x86_64 and got the following:
/usr/lib/python2.7/site-packages/ocrfeeder/util/lib.py:26: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded. 
 from gi.repository import Gtk 
Traceback (most recent call last): 
 File "/bin/ocrfeeder", line 31, in <module> 
   from ocrfeeder.studio.studioBuilder import Studio 
 File "/usr/lib/python2.7/site-packages/ocrfeeder/studio/studioBuilder.py", line 22, in <module> 
   from ocrfeeder.util import lib 
 File "/usr/lib/python2.7/site-packages/ocrfeeder/util/lib.py", line 32, in <module> 
   from lxml import etree 
ImportError: No module named lxml

Installed  python-lxml-3.6.0-1.mga6.x86_64 and ocrfeeder started successfully with the following:
/usr/lib/python2.7/site-packages/ocrfeeder/util/lib.py:26: PyGIWarning: Gtk was imported without spe
cifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded. 
 from gi.repository import Gtk 
/usr/lib/python2.7/site-packages/ocrfeeder/studio/widgetPresenter.py:31: PyGIWarning: GooCanvas was 
imported without specifying a version first. Use gi.require_version('GooCanvas', '2.0') before import to ensure that the right version gets loaded.                                                      
 from gi.repository import Gtk, GooCanvas, Gdk, GObject, GLib, GdkPixbuf, GtkSpell                  
/usr/lib/python2.7/site-packages/ocrfeeder/studio/widgetPresenter.py:31: PyGIWarning: GtkSpell was imported without specifying a version first. Use gi.require_version('GtkSpell', '3.0') before import to ensure that the right version gets loaded. 
from gi.repository import Gtk, GooCanvas, Gdk, GObject, GLib, GdkPixbuf, GtkSpell

The problem appears to be missing dependencies: python-gi and python-lxml.

Version-Release number of selected component (if applicable):
ocrfeeder-0.8.1-3.mga6

How reproducible:
Install ocrfeeder then try to start.

Steps to Reproduce:
1. See above.
2.
3.
Comment 1 Marja Van Waes 2018-06-04 20:01:12 CEST
Assigning to the gnome maintainers, because ocrfeeder is a Gnome tool.

Changing version to Cauldron and MGA6TOO, because cauldron has the same ocrfeeder-0.8.1-3.mga6 version & release.

CC'ing kekePower, who recently committed to ocrfeeder in cauldron.

Also CC'ing the python maintainers, because of the 3 PyGIWarnings about Gtk, GooCanvas and GtkSpell being imported without specifying a version first, that are visible when the tool starts successfully once python-gi and python-lxml are installed.

Version: 6 => Cauldron
Whiteboard: (none) => MGA6TOO
Assignee: bugsquad => gnome
Summary: ocrfeeder fails to start due to missing dependencies => ocrfeeder fails to start due to missing python-gi and python-lxml dependencies
CC: (none) => marja11, python, smelror

Comment 2 David GEIGER 2018-06-07 18:54:07 CEST
Should be fixed with ocrfeeder-0.8.1-3.1.mga6!

Please test it if all dependencies are now properly pulled, thanks in advance.

CC: (none) => geiger.david68210

Comment 3 A Walker 2018-06-09 00:19:56 CEST
Uninstalled ocrfeeder-0.8.1-3.mga6, python-lxml-3.6.0-1.mga6, python-gi-3.24.1-1.mga6. Installed 0.8.1-3.1.mga6.noarch.rpm; urpmi pulled in the two python dependencies. Program started successfully, with no PyGIWarnings. Many thanks.
Comment 4 David GEIGER 2018-06-11 11:22:33 CEST
Assigning to QA,


Advisory:
=============================

Some users reported that our current ocrfeeder package doesn't work and launch due to some missing dependencies.


This updates fixes this issue adding python-gi and python-lxml as a required dependencies.


Packages in 6/core/updates_testing:
========================
ocrfeeder-0.8.1-3.1.mga6.noarch.rpm

Source RPM: 
========================
ocrfeeder-0.8.1-3.1.mga6.src.rpm

Assignee: gnome => qa-bugs

Comment 5 Herman Viaene 2018-06-11 15:02:21 CEST
MGA6-32 on IBM Thinkpad R50e MATE
No installation issues
ocrfeeder starts OK from CLI without errors.

CC: (none) => herman.viaene
Whiteboard: MGA6TOO => MGA6TOO MGA6-32-OK

Thomas Backlund 2018-06-11 22:27:05 CEST

Version: Cauldron => 6
CC: (none) => tmb
Whiteboard: MGA6TOO MGA6-32-OK => MGA6-32-OK

Comment 6 claire robinson 2018-06-14 18:51:50 CEST
Validating.

Keywords: (none) => validated_update
CC: (none) => sysadmin-bugs

Comment 7 claire robinson 2018-06-14 19:06:35 CEST
Advisoried.

Keywords: (none) => advisory

Comment 8 Mageia Robot 2018-06-14 20:15:47 CEST
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2018-0114.html

Resolution: (none) => FIXED
Status: NEW => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.