Bug 22965 - [mc] corrupt timestamps on files copied from archives
Summary: [mc] corrupt timestamps on files copied from archives
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA6-32-OK
Keywords: advisory, UPSTREAM, validated_update
Depends on:
Blocks:
 
Reported: 2018-04-29 04:41 CEST by Felix Miata
Modified: 2018-05-19 22:57 CEST (History)
5 users (show)

See Also:
Source RPM: mc-4.8.19-1.mga6
CVE:
Status comment: fixed upstream


Attachments

Description Felix Miata 2018-04-29 04:41:19 CEST
[mc] corrupt timestamps on files copied from archives

According to https://mail.gnome.org/archives/mc/2017-August/msg00003.html this problem was fixed upstream ~2 months before MGA6 release by https://midnight-commander.org/ticket/3821 but I am unable to understand the dev-speak in that bug report to confirm.

Fix needs to be included in 4.8.19 as MGA6 update, or MGA6 package updated to 4.8.20, as attempting to install 4.8.20 from MGA7 using rpm manually is inexplicably blocked by "required" perl-base upgrade.

From the mc mailing list thread:
To reproduce:
1-left pane, enter some tar.gz or .bz2 archive, e.g.
https://archive.mozilla.org/pub/seamonkey/releases/2.48/contrib/seamonkey-2.48.en-US.linux-x86_64.tar.bz2
saved locally
2-select all files with * key and dirs with INS
3-F5 -> ENTER
4-TAB

Actual behavior:
All files from archive show current timestamps

Expected behavior:
Files and directories inherit individual timestamps from archive

Reverting to 4.8.17 solves.
Comment 1 Marja Van Waes 2018-04-29 09:20:11 CEST
Assigning to all packagers collectively, since there is no registered maintainer for this package.

CC'ing daviddavid, who pushed mc most often in the past few years

See Also: (none) => https://midnight-commander.org/ticket/3821
Status comment: (none) => fixed upstream
Assignee: bugsquad => pkg-bugs
CC: (none) => marja11

Comment 2 Stig-Ørjan Smelror 2018-05-11 23:42:17 CEST
Advisory
========

Midnight Commander has been updated to fix an issue with corrupt timestamps when extracting from an archive.

References
==========
https://bugs.mageia.org/show_bug.cgi?id=22965

Files
=====

Uploaded to core/updates_testing:

mc-4.8.20-1.mga6
mc-debuginfo-4.8.20-1.mga6

from mc-4.8.20-1.mga6.src.rpm

CC: (none) => smelror
Assignee: pkg-bugs => qa-bugs

Comment 3 Herman Viaene 2018-05-19 14:26:37 CEST
MGA6-32 on IBM Thinkpad R50e Xfce
No installation issues.
Confirm that file and folder selected from seamonkey archive above preserve the original timestamp 7 July 2017 when copied with mc.
OK for me.

CC: (none) => herman.viaene
Whiteboard: (none) => MGA6-32-OK

Comment 4 Lewis Smith 2018-05-19 21:39:15 CEST
Tried M6 x64, but with: mc-4.8.19-1.mga6 PRE update

I could not reproduce the described problem. Copying with MC as described in comment 0 a .tar.gz or .bz archive to another directory always preserved the file timestamps as in the archive.
So live with Herman's OK result.

Keywords: (none) => advisory, validated_update
CC: (none) => sysadmin-bugs

Comment 5 Mageia Robot 2018-05-19 22:57:48 CEST
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2018-0090.html

Status: NEW => RESOLVED
Resolution: (none) => FIXED


Note You need to log in before you can comment on or make changes to this bug.