Bug 22909 - Update request: kernel-4.14.34-1.mga6
Summary: Update request: kernel-4.14.34-1.mga6
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: Release (media or process) (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: Thomas Backlund
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-14 11:33 CEST by Thomas Backlund
Modified: 2018-04-22 20:26 CEST (History)
8 users (show)

See Also:
Source RPM: kernel
CVE:
Status comment:


Attachments

Description Thomas Backlund 2018-04-14 11:33:00 CEST
New kernel with security fixes, bugfixes, a reversion of rtl8812au update in last kernel update that broke existing systems, and additional fix for KPTI on x32, and so on...


SRPMS:
kernel-4.14.34-1.mga6.src.rpm
kernel-userspace-headers-4.14.34-1.mga6.src.rpm

kmod-vboxadditions-5.2.8-10.mga6.src.rpm
kmod-virtualbox-5.2.8-10.mga6.src.rpm
kmod-xtables-addons-2.13-30.mga6.src.rpm

wireguard-tools-0.0.20180413-1.mga6.src.rpm



i586:
cpupower-4.14.34-1.mga6.i586.rpm
cpupower-devel-4.14.34-1.mga6.i586.rpm
kernel-desktop-4.14.34-1.mga6-1-1.mga6.i586.rpm
kernel-desktop586-4.14.34-1.mga6-1-1.mga6.i586.rpm
kernel-desktop586-devel-4.14.34-1.mga6-1-1.mga6.i586.rpm
kernel-desktop586-devel-latest-4.14.34-1.mga6.i586.rpm
kernel-desktop586-latest-4.14.34-1.mga6.i586.rpm
kernel-desktop-devel-4.14.34-1.mga6-1-1.mga6.i586.rpm
kernel-desktop-devel-latest-4.14.34-1.mga6.i586.rpm
kernel-desktop-latest-4.14.34-1.mga6.i586.rpm
kernel-doc-4.14.34-1.mga6.noarch.rpm
kernel-server-4.14.34-1.mga6-1-1.mga6.i586.rpm
kernel-server-devel-4.14.34-1.mga6-1-1.mga6.i586.rpm
kernel-server-devel-latest-4.14.34-1.mga6.i586.rpm
kernel-server-latest-4.14.34-1.mga6.i586.rpm
kernel-source-4.14.34-1.mga6-1-1.mga6.noarch.rpm
kernel-source-latest-4.14.34-1.mga6.noarch.rpm
kernel-userspace-headers-4.14.34-1.mga6.i586.rpm
perf-4.14.34-1.mga6.i586.rpm

vboxadditions-kernel-4.14.34-desktop-1.mga6-5.2.8-10.mga6.i586.rpm
vboxadditions-kernel-4.14.34-desktop586-1.mga6-5.2.8-10.mga6.i586.rpm
vboxadditions-kernel-4.14.34-server-1.mga6-5.2.8-10.mga6.i586.rpm
vboxadditions-kernel-desktop586-latest-5.2.8-10.mga6.i586.rpm
vboxadditions-kernel-desktop-latest-5.2.8-10.mga6.i586.rpm
vboxadditions-kernel-server-latest-5.2.8-10.mga6.i586.rpm

virtualbox-kernel-4.14.34-desktop-1.mga6-5.2.8-10.mga6.i586.rpm
virtualbox-kernel-4.14.34-desktop586-1.mga6-5.2.8-10.mga6.i586.rpm
virtualbox-kernel-4.14.34-server-1.mga6-5.2.8-10.mga6.i586.rpm
virtualbox-kernel-desktop586-latest-5.2.8-10.mga6.i586.rpm
virtualbox-kernel-desktop-latest-5.2.8-10.mga6.i586.rpm
virtualbox-kernel-server-latest-5.2.8-10.mga6.i586.rpm

xtables-addons-kernel-4.14.34-desktop-1.mga6-2.13-30.mga6.i586.rpm
xtables-addons-kernel-4.14.34-desktop586-1.mga6-2.13-30.mga6.i586.rpm
xtables-addons-kernel-4.14.34-server-1.mga6-2.13-30.mga6.i586.rpm
xtables-addons-kernel-desktop586-latest-2.13-30.mga6.i586.rpm
xtables-addons-kernel-desktop-latest-2.13-30.mga6.i586.rpm
xtables-addons-kernel-server-latest-2.13-30.mga6.i586.rpm

wireguard-tools-0.0.20180413-1.mga6.i586.rpm



x86_64:
cpupower-4.14.34-1.mga6.x86_64.rpm
cpupower-devel-4.14.34-1.mga6.x86_64.rpm
kernel-desktop-4.14.34-1.mga6-1-1.mga6.x86_64.rpm
kernel-desktop-devel-4.14.34-1.mga6-1-1.mga6.x86_64.rpm
kernel-desktop-devel-latest-4.14.34-1.mga6.x86_64.rpm
kernel-desktop-latest-4.14.34-1.mga6.x86_64.rpm
kernel-doc-4.14.34-1.mga6.noarch.rpm
kernel-server-4.14.34-1.mga6-1-1.mga6.x86_64.rpm
kernel-server-devel-4.14.34-1.mga6-1-1.mga6.x86_64.rpm
kernel-server-devel-latest-4.14.34-1.mga6.x86_64.rpm
kernel-server-latest-4.14.34-1.mga6.x86_64.rpm
kernel-source-4.14.34-1.mga6-1-1.mga6.noarch.rpm
kernel-source-latest-4.14.34-1.mga6.noarch.rpm
kernel-userspace-headers-4.14.34-1.mga6.x86_64.rpm
perf-4.14.34-1.mga6.x86_64.rpm

vboxadditions-kernel-4.14.34-desktop-1.mga6-5.2.8-10.mga6.x86_64.rpm
vboxadditions-kernel-4.14.34-server-1.mga6-5.2.8-10.mga6.x86_64.rpm
vboxadditions-kernel-desktop-latest-5.2.8-10.mga6.x86_64.rpm
vboxadditions-kernel-server-latest-5.2.8-10.mga6.x86_64.rpm

virtualbox-kernel-4.14.34-desktop-1.mga6-5.2.8-10.mga6.x86_64.rpm
virtualbox-kernel-4.14.34-server-1.mga6-5.2.8-10.mga6.x86_64.rpm
virtualbox-kernel-desktop-latest-5.2.8-10.mga6.x86_64.rpm
virtualbox-kernel-server-latest-5.2.8-10.mga6.x86_64.rpm

xtables-addons-kernel-4.14.34-desktop-1.mga6-2.13-30.mga6.x86_64.rpm
xtables-addons-kernel-4.14.34-server-1.mga6-2.13-30.mga6.x86_64.rpm
xtables-addons-kernel-desktop-latest-2.13-30.mga6.x86_64.rpm
xtables-addons-kernel-server-latest-2.13-30.mga6.x86_64.rpm

wireguard-tools-0.0.20180413-1.mga6.x86_64.rpm
Comment 1 Thomas Andrews 2018-04-15 02:19:09 CEST
On real hardware, Intel Core 2 Duo, 8GB, Intel graphics, wired Internet.

One install 64-bit Plasma 5.12.2, using the desktop kernel, one install 32-bit Xfce, using the server kernel.

Also updated Firefox and Thunderbird during this test.

Everything looks good - no regressions noted.

CC: (none) => andrewsfarm

Comment 2 Len Lawrence 2018-04-15 10:02:59 CEST
Installed the 4.14.34 desktop and server kernels, ran drakboot and rebooted to Mate desktop.
System:    Host: vega Kernel: 4.14.34-desktop-1.mga6 x86_64
CPU:       Quad core Intel Core i7-4790K (-HT-MCP-) speed/max: 4395/4400 MHz
Machine:   Device: desktop Mobo: Gigabyte model: G1.Sniper Z97 v: x.x
Graphics:  Card-2: NVIDIA GK104 [GeForce GTX 770]
           GLX Version: 4.6.0 NVIDIA 390.42
Network:   Card-1: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller
           driver: alx
RAM:       15.35 GB

No problems noted at any stage.  Desktop running fine.
Ran a quick test of virtualbox - launched a Mageia5 32-bit guest.  All OK.

CC: (none) => tarazed25

Comment 3 Len Lawrence 2018-04-15 10:58:46 CEST
Rebooted with the server kernel on the same system as in comment 2.
nvidia-current driver rebuilt on the way in.
Desktop running fine.
$ uname -r
4.14.34-server-1.mga6
Remote login to another machine using ssh authorized keys.  On that machine managed to access an NFS shared directory which is hosted on this machine.
Bluetooth settings survived both the desktop and server kernel reboots.  Connection to a bluetooth speaker took maybe a second.  HD free-to-air TV still working - viewed with vlc.
Comment 4 James Kerr 2018-04-15 15:07:50 CEST
on mga6-64  plasma-5.12

packages installed cleanly:
- cpupower-4.14.34-1.mga6.x86_64
- kernel-desktop-4.14.34-1.mga6-1-1.mga6.x86_64
- kernel-desktop-latest-4.14.34-1.mga6.x86_64
- virtualbox-kernel-4.14.34-desktop-1.mga6-5.2.8-10.mga6.x86_64
- virtualbox-kernel-desktop-latest-5.2.8-10.mga6.x86_64

system re-booted normally:
$ uname -r
4.14.34-desktop-1.mga6

common applications OK

vbox and clients launched normally

looks OK for mga6-64 on this system:

Machine:   Device: desktop System: Dell product: Precision Tower 3620
           Mobo: Dell model: 09WH54 v: A00 UEFI [Legacy]: 
CPU:       Quad core Intel Core i7-6700 (-HT-MCP-)
Graphics:  Card: Intel HD Graphics 530
Network:   Card: Intel Ethernet Connection (2) I219-LM driver: e1000e

CC: (none) => jim

Comment 5 James Kerr 2018-04-15 15:40:31 CEST
on mga6-32 in a vbox VM  plasma

packages installed cleanly:
- cpupower-4.14.34-1.mga6.i586
- kernel-desktop-4.14.34-1.mga6-1-1.mga6.i586
- kernel-desktop-latest-4.14.34-1.mga6.i586
- vboxadditions-kernel-4.14.34-desktop-1.mga6-5.2.8-10.mga6.i586
- vboxadditions-kernel-desktop-latest-5.2.8-10.mga6.i586

VM re-started normally
$ uname -r
4.14.34-desktop-1.mga6

common applications OK

Ok for mga6-32 in a vbox VM
Comment 6 James Kerr 2018-04-15 16:03:27 CEST
on mga6-64 in a vbox VM  plasma5.12

packages installed cleanly:
- cpupower-4.14.34-1.mga6.x86_64
- kernel-desktop-4.14.34-1.mga6-1-1.mga6.x86_64
- kernel-desktop-latest-4.14.34-1.mga6.x86_64
- vboxadditions-kernel-4.14.34-desktop-1.mga6-5.2.8-10.mga6.x86_64
- vboxadditions-kernel-desktop-latest-5.2.8-10.mga6.x86_64

VM re-started normally:
$ uname -r
4.14.34-desktop-1.mga6

common applications OK

OK for mga6-64 in a vbox VM
Comment 7 Len Lawrence 2018-04-15 16:07:08 CEST
Mageia 6, x86_64
4.14.34-desktop kernel running fine on Quad core Intel Core i7-4790 
Mobo: MSI model: Z97-G43
NVIDIA GM204 [GeForce GTX 970]
32GB RAM

Ran stress tests.  NFS shares working across local network. vlc, sound and vision OK.  Stellarium, LibreOffice writer, thunderbird imail, virtualbox, no problems.
Comment 8 Thomas Backlund 2018-04-15 16:09:55 CEST
Whole Mageia infra is running on the x86_64 server kernel since yesterday.

So is my local server here... and x86_64 desktop kernel is running on a threadripper workstation and a KabyLake laptop since yesterday
Comment 9 James Kerr 2018-04-15 16:28:51 CEST
on mga6-64 plasma-5.12

packages installed cleanly:
- cpupower-4.14.34-1.mga6.x86_64
- kernel-desktop-4.14.34-1.mga6-1-1.mga6.x86_64
- kernel-desktop-latest-4.14.34-1.mga6.x86_64

system re-booted normally:
$ uname -r
4.14.34-desktop-1.mga6

common applications OK

OK for mga6-64 on this system:

Machine:   Device: desktop System: Hewlett-Packard product: CQ2925EA
           Mobo: PEGATRON model: 2AE2 v: 1.02 UEFI: AMI v: 8.08
CPU:       Dual core Intel Pentium G645T (-MCP-) cache: 3072 KB 
Graphics:  Card: Intel 2nd Generation Core Processor Family
Network:   Card: Qualcomm Atheros AR8152 v2.0 Fast Ethernet driver: atl1c
Comment 10 James Kerr 2018-04-15 18:41:27 CEST
on mga6-32 xfce

packages installed cleanly:
- cpupower-4.14.34-1.mga6.i586
- kernel-server-4.14.34-1.mga6-1-1.mga6.i586
- kernel-server-devel-4.14.34-1.mga6-1-1.mga6.i586
- kernel-server-devel-latest-4.14.34-1.mga6.i586
- kernel-server-latest-4.14.34-1.mga6.i586
- kernel-userspace-headers-4.14.34-1.mga6.i586

system re-booted cleanly:
$ uname -r
4.14.34-server-1.mga6
# dkms status -m nvidia-current
nvidia-current, 390.42-1.mga6.nonfree, 4.14.30-server-3.mga6, i586: installed 
nvidia-current, 390.42-1.mga6.nonfree, 4.14.34-server-1.mga6, i586: installed 

common applications OK

OK for mga6-32 on this system:

Machine:   Device: desktop Mobo: ECS model: GeForce7050M-M v: 1.0
CPU:       Quad core AMD Phenom 9500 (-MCP-)
Graphics:  Card: NVIDIA GK208B [GeForce GT 710]
Network:   Card: NVIDIA MCP67 Ethernet driver: forcedeth
Comment 11 Thomas Andrews 2018-04-15 20:46:16 CEST
On real hardware, Athlon X27750, 8GB, nvidia9800gt video, Atheros wifi.

One 64-bit Plasma 5.12.2 install, using the server kernel, with VirtualBox installed. One 32-bit Xfce install, also using the server kernel.

Everything looks good here, including VirtualBox. The Mageia 6 guest on this machine has not yet been updated to Plasma 5.12.2. (I'm holding it as a test of the updates once they are pushed.) I did not test the kernel update there, as when the testing repos are active Mageia Update wants to pull in task-obsolete and its dependencies, even when I did not select them
Comment 12 ben mcmonagle 2018-04-16 08:49:05 CEST
real 32 bit hardware:

AMD Athlon(tm) XP 2400+

flags:fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow cpuid 3dnowprefetch vmmcall

installed:
cpupower-4.14.34-1.mga6.i586
kernel-desktop-4.14.34-1.mga6-1-1.mga6.i586
kernel-desktop-latest-4.14.34-1.mga6.i586

reboot ok.

$ uname -r
4.14.34-desktop-1.mga6

log in to desktop (LXDE) ok.
check usb access -ok
pcmanfm -ok
firefox -ok
sound and video playback - ok

basic tests. no issues noted

CC: (none) => westel

Comment 13 Morgan Leijström 2018-04-16 16:00:26 CEST
On real 64 bit hardware, runs OK

- cpupower-4.14.34-1.mga6.x86_64
- kernel-desktop-4.14.34-1.mga6-1-1.mga6.x86_64
- kernel-desktop-latest-4.14.34-1.mga6.x86_64
- kernel-desktop-devel-4.14.34-1.mga6-1-1.mga6.x86_64.rpm
- kernel-desktop-devel-latest-4.14.34-1.mga6.x86_64.rpm
- virtualbox-kernel-4.14.34-desktop-1.mga6-5.2.8-10.mga6.x86_64.rpm
- virtualbox-kernel-desktop-latest-5.2.8-10.mga6.x86_64.rpm
- kernel-userspace-headers-4.14.34-1.mga6.x86_64.rpm

In my workstation i7 installed and rebooted cleanly, in use from now on.
Nvidia proprietary with CUDA & OpenCL detected OK in BOINC, LVM on LUKS, VirtualBox running MSW7, Plasma5.12 etc, video in Firefox,,, whatever, no hickup seen...

CC: (none) => fri

Comment 14 Len Lawrence 2018-04-16 17:35:13 CEST
System:    Host: belexeuli Kernel: 4.14.34-desktop-1.mga6 x86_64
CPU:       Quad core Intel Core i7-2600 (-HT-MCP-) speed/max: 1628/3800 MHz
Machine:   Device: desktop System: Alienware product: Alienware X51 v: 00
           Mobo: Alienware model: 08PG26 v: A00
Graphics:  Card-2: NVIDIA GF114 [GeForce GTX 555]
           GLX Version: 4.6.0 NVIDIA 390.42
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169
RAM:       7.69 GB

glmark2 and other stress tests behaved normally.
Mate desktop running fine.  Letting this run for a couple of days before switching to the server kernel.
Comment 15 Thomas Andrews 2018-04-16 17:56:06 CEST
Real hardware, HP 6550b, i3, 8GB, Intel graphics, Intel wifi.

One 64-bit Plasma 5.12.2 install, with VirtualBox, using the desktop kernel.
One 32-bit Plasma 5.12.2 install, without VirtualBox, using the server kernel.

Everything looks good here - no regressions noted so far.
Comment 16 Morgan Leijström 2018-04-16 19:17:11 CEST
Real 64 bit hardware: laptop thinkpad T60 runs OK

- cpupower-4.14.34-1.mga6.x86_64
- kernel-desktop-4.14.34-1.mga6-1-1.mga6.x86_64
- kernel-desktop-latest-4.14.34-1.mga6.x86_64
- kernel-userspace-headers-4.14.34-1.mga6.x86_64.rpm

Ati graphics, LVM on LUKS, wireless intel ipw2200, Plasma5.12 etc, video in Firefox, ... OK
suspend-resume: OK
hibernate-resume: OK
Comment 17 William Kenney 2018-04-16 20:10:14 CEST
In a Vbox client, M6, Mate, 32-bit

Testing: kernel-desktop-latest vboxadditions-kernel-desktop-latest cpupower

[root@localhost wilcal]# uname -a
Linux localhost 4.14.30-desktop-3.mga6 #1 SMP Sun Mar 25 23:26:07 UTC 2018 i686 i686 i686 GNU/Linux
[root@localhost wilcal]# urpmi kernel-desktop-latest
Package kernel-desktop-latest-4.14.30-3.mga6.i586 is already installed
[root@localhost wilcal]# urpmi vboxadditions-kernel-desktop-latest
Package vboxadditions-kernel-desktop-latest-5.2.8-6.mga6.i586 is already installed
[root@localhost wilcal]# urpmi cpupower
Package cpupower-4.14.30-3.mga6.i586 is already installed

Boots to a working desktop. Screen resolution is correct. Common apps work.

Installed kernel-desktop-latest vboxadditions-kernel-desktop-latest cpupower from updates testing

[root@localhost wilcal]# uname -a
Linux localhost 4.14.34-desktop-1.mga6 #1 SMP Sat Apr 14 00:44:24 UTC 2018 i686 i686 i686 GNU/Linux
[root@localhost wilcal]# urpmi kernel-desktop-latest
Package kernel-desktop-latest-4.14.34-1.mga6.i586 is already installed
[root@localhost wilcal]# urpmi vboxadditions-kernel-desktop-latest
Package vboxadditions-kernel-desktop-latest-5.2.8-10.mga6.i586 is already installed
[root@localhost wilcal]# urpmi cpupower
Package cpupower-4.14.34-1.mga6.i586 is already installed

Boots to a working desktop. Screen resolution is correct. Common apps work.

CC: (none) => wilcal.int

Comment 18 William Kenney 2018-04-16 20:25:30 CEST
In a Vbox client, M6, Mate, 64-bit

Testing: kernel-desktop-latest vboxadditions-kernel-desktop-latest cpupower

[root@localhost wilcal]# uname -a
Linux localhost 4.14.30-desktop-3.mga6 #1 SMP Sun Mar 25 22:17:31 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
[root@localhost wilcal]# urpmi kernel-desktop-latest
Package kernel-desktop-latest-4.14.30-3.mga6.x86_64 is already installed
[root@localhost wilcal]# urpmi vboxadditions-kernel-desktop-latest
Package vboxadditions-kernel-desktop-latest-5.2.8-6.mga6.x86_64 is already installed
[root@localhost wilcal]# urpmi cpupower
Package cpupower-4.14.30-3.mga6.x86_64 is already installed

Boots to a working desktop. Screen resolution is correct. Common apps work.

Installed kernel-desktop-latest vboxadditions-kernel-desktop-latest cpupower from updates testing

[root@localhost wilcal]# uname -a
Linux localhost 4.14.34-desktop-1.mga6 #1 SMP Sat Apr 14 00:23:23 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
[root@localhost wilcal]# urpmi kernel-desktop-latest
Package kernel-desktop-latest-4.14.34-1.mga6.x86_64 is already installed
[root@localhost wilcal]# urpmi vboxadditions-kernel-desktop-latest
Package vboxadditions-kernel-desktop-latest-5.2.8-10.mga6.x86_64 is already installed
[root@localhost wilcal]# urpmi cpupower
Package cpupower-4.14.34-1.mga6.x86_64 is already installed

Boots to a working desktop. Screen resolution is correct. Common apps work.
Comment 19 William Kenney 2018-04-16 23:56:59 CEST
On real hardware, M6, Plasma, 64-bit

initial install:
kernel-desktop-latest
virtualbox vboxadditions-kernel-desktop-latest dkms-virtualbox
virtualbox-guest-additions virtualbox-kernel-desktop-latest x11-driver-video-vboxvideo
kernel-desktop-devel-latest dkms-nvidia-current

kernel-userspace-headers

[root@localhost wilcal]# uname -a
Linux localhost 4.14.30-desktop-3.mga6 #1 SMP Sun Mar 25 22:17:31 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
[root@localhost wilcal]# urpmi kernel-desktop-latest
Package kernel-desktop-latest-4.14.30-3.mga6.x86_64 is already installed
[root@localhost wilcal]# urpmi virtualbox
Package virtualbox-5.2.8-1.mga6.x86_64 is already installed
[root@localhost wilcal]# urpmi vboxadditions-kernel-desktop-latest
Package vboxadditions-kernel-desktop-latest-5.2.8-6.mga6.x86_64 is already installed
[root@localhost wilcal]# urpmi dkms-virtualbox
Package dkms-virtualbox-5.2.8-1.mga6.noarch is already installed
[root@localhost wilcal]# urpmi virtualbox-guest-additions
Package virtualbox-guest-additions-5.2.8-1.mga6.x86_64 is already installed
[root@localhost wilcal]# urpmi virtualbox-kernel-desktop-latest
Package virtualbox-kernel-desktop-latest-5.2.8-6.mga6.x86_64 is already installed
[root@localhost wilcal]# urpmi x11-driver-video-vboxvideo
Package x11-driver-video-vboxvideo-5.2.8-1.mga6.x86_64 is already installed
[root@localhost wilcal]# urpmi kernel-desktop-devel-latest
Package kernel-desktop-devel-latest-4.14.30-3.mga6.x86_64 is already installed
[root@localhost wilcal]# urpmi dkms-nvidia-current
Package dkms-nvidia-current-390.42-1.mga6.nonfree.x86_64 is already installed
[root@localhost wilcal]# urpmi cpupower
Package cpupower-4.14.30-3.mga6.x86_64 is already installed
[wilcal@localhost ~]$ lspci -k
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 440] (rev a1)
        Subsystem: Gigabyte Technology Co., Ltd Device 3518
        Kernel driver in use: nvidia
        Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia_current
        
Using:
Mageia-6-LiveDVD-Xfce-i586-DVD.iso
Create a Vbox client. Works just fine. Boots to a working desktop.

install from update_testing:
kernel-desktop-latest
virtualbox vboxadditions-kernel-desktop-latest dkms-virtualbox
virtualbox-guest-additions virtualbox-kernel-desktop-latest x11-driver-video-vboxvideo
kernel-desktop-devel-latest dkms-nvidia-current

[root@localhost wilcal]# uname -a
Linux localhost 4.14.34-desktop-1.mga6 #1 SMP Sat Apr 14 00:23:23 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
[root@localhost wilcal]# urpmi kernel-desktop-latest
Package kernel-desktop-latest-4.14.34-1.mga6.x86_64 is already installed
[root@localhost wilcal]# urpmi virtualbox
Package virtualbox-5.2.8-1.mga6.x86_64 is already installed
[root@localhost wilcal]# urpmi vboxadditions-kernel-desktop-latest
Package vboxadditions-kernel-desktop-latest-5.2.8-10.mga6.x86_64 is already installed
[root@localhost wilcal]# urpmi dkms-virtualbox
Package dkms-virtualbox-5.2.8-1.mga6.noarch is already installed
[root@localhost wilcal]# urpmi virtualbox-guest-additions
Package virtualbox-guest-additions-5.2.8-1.mga6.x86_64 is already installed
[root@localhost wilcal]# urpmi virtualbox-kernel-desktop-latest
Package virtualbox-kernel-desktop-latest-5.2.8-10.mga6.x86_64 is already installed
[root@localhost wilcal]# urpmi x11-driver-video-vboxvideo
Package x11-driver-video-vboxvideo-5.2.8-1.mga6.x86_64 is already installed
[root@localhost wilcal]# urpmi kernel-desktop-devel-latest
Package kernel-desktop-devel-latest-4.14.34-1.mga6.x86_64 is already installed
[root@localhost wilcal]# urpmi dkms-nvidia-current
Package dkms-nvidia-current-390.48-1.mga6.nonfree.x86_64 is already installed
[root@localhost wilcal]# urpmi cpupower
Package cpupower-4.14.34-1.mga6.x86_64 is already installed
[root@localhost wilcal]# lspci -k
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 440] (rev a1)
        Subsystem: Gigabyte Technology Co., Ltd Device 3518
        Kernel driver in use: nvidia
        Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia_current
        
Mageia-6-LiveDVD-Xfce-i586-DVD.iso
Still works as a Vbox client. Boots to a working desktop.

Mageia-6-LiveDVD-GNOME-x86_64-DVD.iso
Create a Vbox client. Works just fine. Boots to a working desktop.

Mageia-6-LiveDVD-Plasma-x86_64-DVD.iso
Installs as a Vbox client. Boots to a working desktop.
Updates then reboots back to a working desktop.

Test platform:
Intel Core i7-2600K Sandy Bridge 3.4GHz
GIGABYTE GA-Z68X-UD3-B3 LGA 1155 MoBo
GIGABYTE GV-N440D3-1GI Nvidia GeForce GT 440 (Fermi) 1GB
RTL8111/8168B PCI Express 1Gbit Ethernet
DRAM 16GB (4 x 4GB)
Comment 20 Len Lawrence 2018-04-17 12:24:12 CEST
Upgraded smoothly from the 4.4.30-server/desktop kernels.
Rebooted to Mate using the desktop kernel.

System:    Host: markab Kernel: 4.14.34-desktop-1.mga6 x86_64
CPU:       Quad core Intel Core i7-5700HQ (-HT-MCP-) speed/max: 2724/3500 MHz
Machine:   Device: laptop System: GIGABYTE product: X5
Graphics:  Card-1: NVIDIA GM204M [GeForce GTX 965M]
           Card-2: NVIDIA GM204M [GeForce GTX 965M]
           GLX Version: 4.6.0 NVIDIA 390.42
Network:   Card-2: Intel Wireless 7265 driver: iwlwifi
RAM:       15.62 GB

Ran stress tests, scheduled updates, vlc, stellarium, .....  Bluetooth sound working, network shares as well.  The session resumed after closing and opening the laptop lid.

Working OK.
Comment 21 Morgan Leijström 2018-04-17 22:30:26 CEST
Test i586 on Thinkpad T42p - ** note: Cauldron **
Like 4.14.30 all is OK except on resume from hibernation screen blacks and freeze after image is read.
(Tested again that 4.14.25 still works in this regard)
Comment 22 Herman Viaene 2018-04-21 19:52:41 CEST
MGA6-32 On Dell Latitude D600 MATE RTL8191S Wifi
No installation issues.
After reboot, at first all seems OK (txt, video, music, spreadsheet). But after some 15 min. networking drop off, and neither network manager, nor network center can restart it.
In netwerk center, there appears a (dummy?) device virbr0, never seen before and marked as a cable connection.
But in network manager, the same appears as a network device .....
Will do some mor tests tomorrow.

CC: (none) => herman.viaene

Comment 23 Herman Viaene 2018-04-22 10:09:38 CEST
Cold reboot, all seems OK, but this dummy device virbr0 is shown in Network Manager and Network Center as above.When I mount the remote nfs-shares I can access those for a while, and again after a few minutes, the network drops out.
Try pinging my router returns "Network not reachable".
Note: nothing vbox-like is installed in this laptop.
Comment 24 Thomas Backlund 2018-04-22 20:26:06 CEST
Taking this back because of some missed security fixes

Assignee: qa-bugs => tmb


Note You need to log in before you can comment on or make changes to this bug.