Bug 22891 - ksysguard should require libksysguard ( maybe renamed to lib{64}ksysguard )
Summary: ksysguard should require libksysguard ( maybe renamed to lib{64}ksysguard )
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA6-32-OK MGA6-64-OK
Keywords: advisory, validated_update
Depends on:
Blocks:
 
Reported: 2018-04-10 21:07 CEST by Morgan Leijström
Modified: 2018-12-27 00:09 CET (History)
6 users (show)

See Also:
Source RPM: ksysguard-5.13.4-2.mga7.src.rpm
CVE:
Status comment:


Attachments

Description Morgan Leijström 2018-04-10 21:07:49 CEST
Description of problem:
Without libksysguard, ksysguard fail to ask for root privilegies when needed (i.e when user wants to rise priority of a task)

Version-Release number of selected component (if applicable):
5.12.2-1.mga6

This can be fixed after we release the current version.

Thanks Dave H for tracking this.
Morgan Leijström 2018-04-10 21:11:01 CEST

Assignee: bugsquad => kde

Comment 1 Dave Hodgins 2018-04-12 00:24:35 CEST
Changing the srpm.

ksysguard should require libksysguard, though it should be renamed
to lib{64}ksysguard, as the package does contain at least one executable ...
$ file /usr/libexec/kauth/ksysguardprocesslist_helper    
/usr/libexec/kauth/ksysguardprocesslist_helper: ELF 64-bit LSB executable, x86-64

A 32 bit version is needed too for i586 installs.

CC: (none) => davidwhodgins
Source RPM: task-plasma5-minimal => ksysguard-5.12.2-1.mga6.src.rpm

Comment 2 Morgan Leijström 2018-10-17 00:11:50 CEST
I noticed it is the same in cauldron.

Source RPM: ksysguard-5.12.2-1.mga6.src.rpm => ksysguard-5.13.4-2.mga7.src.rpm
Version: 6 => Cauldron
Whiteboard: (none) => MGA6TOO

Morgan Leijström 2018-10-17 00:13:41 CEST

Summary: task-plasma5-minimal should require libksysguard => ksysguard should require libksysguard ( maybe renamed to lib{64}ksysguard )

Comment 3 David GEIGER 2018-10-17 23:17:22 CEST
Should be fixed on Cauldron and also on mga6 in Core/Updates_testing repo!

with ksysguard-5.12.2-1.1.mga6

CC: (none) => geiger.david68210

Comment 4 José Jorge 2018-12-22 18:21:34 CET
Tested in 32 bits, libksysguard was installed as a dependency. Looks good to push as update!

Assignee: kde => qa-bugs
Status: NEW => ASSIGNED
Version: Cauldron => 6
Whiteboard: MGA6TOO => MGA6-32-OK
CC: (none) => lists.jjorge

Comment 5 Thomas Andrews 2018-12-23 15:32:28 CET
In 64-bit mga6 plasma, I get the following dependency message when I select ksysguard:

To satisfy dependencies, the following package(s) also need to be installed:

- libksysguard-5.12.2-1.mga6.x86_64

Going by Comment 1, shouldn't that have been named "lib64ksysguard?"

I await the answer before going ahead with testing.

CC: (none) => andrewsfarm

Comment 6 David GEIGER 2018-12-23 16:16:16 CET
Nop there isn't any lib64ksysguard! and also no need to renamed it to lib64ksysguard!
Comment 7 Thomas Andrews 2018-12-23 18:12:50 CET
Thank you.

Just checking...
Comment 8 Lewis Smith 2018-12-26 22:06:33 CET
Quick M6/x64 cross check.

BEFORE update: ksysguard-5.12.2-1.mga6
 $ urpmq --requires ksysguard | grep libksysguard
 $       This may be a red herring. See below.

The UPDATE required also, to satisfy dependencies:
 - libksysguard-5.12.2-1.mga6.x86_64
Curiously, also with the update: ksysguard-5.12.2-1.1.mga6
 $ urpmq --requires ksysguard | grep libksysguard
 $       Same as before.
but what *is* present in the requires list is: libkdeinit5_ksysguard.so()(64bit)
Same thing?
 $ urpmq --whatrequires libksysguard
lib64ksysguard-devel
libksysguard
libksysguard-devel
All a mystery.

OKing with the others on the basis of the update dependency.
Advisory done from comments 0 and 3.

Keywords: (none) => advisory, validated_update
Whiteboard: MGA6-32-OK => MGA6-32-OK MGA6-64-OK
CC: (none) => lewyssmith, sysadmin-bugs

Comment 9 Mageia Robot 2018-12-27 00:09:39 CET
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2018-0186.html

Status: ASSIGNED => RESOLVED
Resolution: (none) => FIXED


Note You need to log in before you can comment on or make changes to this bug.