Bug 21697 - Qarte versions before 3.11.0 fail to download more than one video
Summary: Qarte versions before 3.11.0 fail to download more than one video
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal major
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA5TOO, has_procedure MGA6-64-OK MGA...
Keywords: advisory, validated_update
Depends on:
Blocks:
 
Reported: 2017-09-12 18:58 CEST by José Jorge
Modified: 2017-09-21 15:44 CEST (History)
5 users (show)

See Also:
Source RPM: qarte
CVE:
Status comment:


Attachments
Qarte window not showing information. (32.12 KB, image/png)
2017-09-14 14:45 CEST, PC LX
Details

Description José Jorge 2017-09-12 18:58:55 CEST
There was a bug introduced in the last Qarte update, it was fixed upstream :

https://bugs.launchpad.net/qarte/+bug/1716020

To test the bug was fixed, only select 2 videos and try to download them.
José Jorge 2017-09-12 19:01:58 CEST

Status: NEW => ASSIGNED
Whiteboard: (none) => MGA5TOO, has_procedure
CC: (none) => lists.jjorge

Comment 1 José Jorge 2017-09-12 19:05:04 CEST
Suggested advisory :

qarte versions before 3.10.0 are no longer compatible with the arte.tv website.
The version 3.11.0 is an upstream fix of a regression introduced in 3.10.

This update provides version 3.11.0 which restores functionality.

Reference : https://bugs.launchpad.net/qarte/+bug/1716020
Comment 2 José Jorge 2017-09-12 19:09:41 CEST
I submitted to backports testing instead of updates testing. I asked sysadmins to move it, it should be done soon, sorry.
Comment 3 PC LX 2017-09-14 14:44:48 CEST
Installed without issues but it is NOT working.

It is not loading the JSON data from the site and it is segment faulting on exit.
The GUI starts but is non functional. No information is displayed. Please see attached screen shot.

$ LANGUAGE=C /usr/bin/qarte
13:38:07: INFO - core Set workspace
13:38:07: INFO - core Load config from: /home/pclx/.Qarte/user_config
13:38:07: INFO - core Build main window
13:38:07: INFO - artetv Read indexes
13:38:07: INFO - artetv Read video's data
13:38:07: INFO - artetv Fetch page: http://www.arte.tv/fr/guide/
13:38:08: WARNING - artetv Read json error: list index out of range
13:38:08: INFO - artetv Fetch page: http://www.arte.tv/fr/guide/20170913
13:38:08: WARNING - artetv Read json error: list index out of range
13:38:08: INFO - artetv Fetch page: http://www.arte.tv/fr/guide/20170912
13:38:09: WARNING - artetv Read json error: list index out of range
13:38:09: INFO - artetv Fetch page: http://www.arte.tv/fr/guide/20170911
13:38:09: WARNING - artetv Read json error: list index out of range
13:38:09: INFO - artetv Fetch page: http://www.arte.tv/fr/guide/20170910
13:38:10: WARNING - artetv Read json error: list index out of range
13:38:10: INFO - artetv Fetch page: http://www.arte.tv/fr/guide/20170909
13:38:10: WARNING - artetv Read json error: list index out of range
13:38:10: INFO - artetv Fetch page: http://www.arte.tv/fr/guide/20170908
13:38:11: WARNING - artetv Read json error: list index out of range
13:38:11: INFO - artetv Fetch page: http://www.arte.tv/fr/guide/20170907
13:38:12: WARNING - artetv Read json error: list index out of range
13:38:12: INFO - artetv Fetch page: http://www.arte.tv/fr/guide/20170906
13:38:12: WARNING - artetv Read json error: list index out of range
13:38:12: INFO - artetv Fetch page: http://www.arte.tv/fr/guide/20170905
13:38:13: WARNING - artetv Read json error: list index out of range
13:38:13: INFO - artetv Fetch page: http://www.arte.tv/fr/guide/20170904
13:38:13: WARNING - artetv Read json error: list index out of range
13:38:13: INFO - artetv Sorting videos, last index: 0
13:38:13: INFO - artetv Remove expired videos
13:38:13: INFO - artetv Check thumbnails
13:38:13: INFO - artetv Thumbnails completed
13:38:13: INFO - artetv Found 0 videos in 5.425029039382935 sec.
13:38:13: INFO - artetv Clean thumbnail folder
13:38:13: INFO - artetv Save tv guide data
13:38:13: INFO - arteconcert Get update ...
13:38:14: INFO - arteconcert Concert list updated
13:38:22: INFO - core Prepare to exit
13:38:22: INFO - core Save user config
13:38:22: INFO - core Configuration saved
Falha de segmentação

CC: (none) => mageia

Comment 4 PC LX 2017-09-14 14:45:25 CEST
Created attachment 9674 [details]
Qarte window not showing information.
Comment 5 Len Lawrence 2017-09-14 15:17:19 CEST
Confirmed this for mga6:x86_64

The ArteTV list came up but aborted immediately with a core dump.
TypeError: stat: can't specify None for path argument
Aborted (core dumped)

CC: (none) => tarazed25

Comment 6 José Jorge 2017-09-14 18:18:06 CEST
(In reply to Len Lawrence from comment #5)
> Confirmed this for mga6:x86_64
> 
> The ArteTV list came up but aborted immediately with a core dump.
> TypeError: stat: can't specify None for path argument
> Aborted (core dumped)

Did you try with version 3.11.0 ? I still do not see it in the repos...
Comment 7 José Jorge 2017-09-14 18:33:40 CEST
(In reply to José Jorge from comment #6)
> (In reply to Len Lawrence from comment #5)
> > Confirmed this for mga6:x86_64
> > 
> > The ArteTV list came up but aborted immediately with a core dump.
> > TypeError: stat: can't specify None for path argument
> > Aborted (core dumped)
> 
> Did you try with version 3.11.0 ? I still do not see it in the repos...

Also I forgot to mention that Arte.tv website is a public channel, only offered to French/Belgian/Deutsch IPs. So the test will fail when done from USA as example.
Comment 8 Len Lawrence 2017-09-14 18:38:07 CEST
My apologies José.  Tried this again - installing from Backports Testing - and found that it worked.  Earlier I had dismissed the Download directory dialogue panel, thinking that I had already set those up (it was another machine).  Downloaded Caprice and two episodes of Sous les étoiles without any problem.  Caprice played fine in vlc with French subtitles.

Holding on to this until it reappears in Updates Testing.
Comment 9 Len Lawrence 2017-09-14 18:41:19 CEST
By the way, Arte seems to be OK for the UK, at least via qarte.  My IP is VirginMedia.
Len Lawrence 2017-09-15 09:32:55 CEST

Whiteboard: MGA5TOO, has_procedure => MGA5TOO, has_procedure MGA6-64-OK

Comment 10 José Jorge 2017-09-17 18:05:37 CEST
Tested in MGA5 32, with two files downloaded .

Whiteboard: MGA5TOO, has_procedure MGA6-64-OK => MGA5TOO, has_procedure MGA6-64-OK MGA5-32-OK

Len Lawrence 2017-09-17 19:59:51 CEST

Whiteboard: MGA5TOO, has_procedure MGA6-64-OK MGA5-32-OK => MGA5TOO, has_procedure MGA6-64-OK MGA5-32-OK MGA5-64-OK

Comment 11 Len Lawrence 2017-09-17 20:02:54 CEST
As soon as the advisory is pushed this can be validated - three of the four boxes have been ticked.
Comment 12 Lewis Smith 2017-09-17 20:29:12 CEST
(In reply to Len Lawrence from comment #11)
> As soon as the advisory is pushed this can be validated - three of the four
> boxes have been ticked.
Updates can be validated (if deemed worthy, as here) *without* the advisory. That can be added later; and the update is not pushed until it is in place.

Advisory from comment 1, but I was not too sure exactly what version had been tested. Opted for qarte-3.11.0-1.

Keywords: (none) => advisory, validated_update
CC: (none) => lewyssmith, sysadmin-bugs

Comment 13 Len Lawrence 2017-09-18 10:30:32 CEST
Correct Lewis.  It was 3.11.0-1.
Comment 14 Mageia Robot 2017-09-21 15:44:19 CEST
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2017-0083.html

Status: ASSIGNED => RESOLVED
Resolution: (none) => FIXED


Note You need to log in before you can comment on or make changes to this bug.