Bug 21226 - Desktop icons don't always stay locked in place when "Lock Icons" is selected
Summary: Desktop icons don't always stay locked in place when "Lock Icons" is selected
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: KDE maintainers
QA Contact:
URL:
Whiteboard: MGA6TOO
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-11 21:27 CEST by Lloyd Osten
Modified: 2019-03-12 18:24 CET (History)
3 users (show)

See Also:
Source RPM: Not sure - latest version of Plasma desktop
CVE:
Status comment:


Attachments

Description Lloyd Osten 2017-07-11 21:27:07 CEST
I'm using Mageia 6rc with all the latest updates. The problem is with my Plasma desktop. Even though I have selected "Lock Icons in Place" when configuring the Desktop, they don't always remain locked in place where I put them (one of them does) This has happened several times. They just go back to being in columns. Sometimes it's OK and sometimes it just seems to change.
Lloyd Osten 2017-07-11 21:27:44 CEST

CC: (none) => lloyd.osten

Marja Van Waes 2017-07-12 00:26:54 CEST

CC: (none) => marja11
Assignee: bugsquad => kde

Comment 1 Maurice Batey 2018-03-03 14:09:15 CET
Same problem here on 64-bit Plasma Mageia-6 Official, fully updated, in 'Folders' desktop.

Tried with & without 'Icons locked' and 'Lock/unlock widgets'.

Tried logging out/ logging back in - no change.

Seems random: Mostly in place after boot up, but often icons moved - most of them in rows across the top of screen. If hen re-arranged back to 'normal' they stay there for the ret of the session.

CC: (none) => maurice

Comment 2 Maurice Batey 2018-04-24 17:31:43 CEST
Ditto on new UEFI 64-bit Plasma Mageia-6 installation on desktop, fully updated.
Comment 3 Maurice Batey 2018-04-24 18:21:57 CEST
Same problem reported here:

   http://www.pclinuxos.com/forum/index.php?topic=143405.0
Comment 4 Maurice Batey 2018-05-08 12:10:42 CEST
SOLVED here:

  Just started using the desktop's nVidia GT730 card, and now the desktop icons remain undisturbed after reboot!!!

N.B. To use the proprietary nVidia driver (390.42),I had to add "NOKMSBOOT" to the boot commands in the Mageia-6 /boot/refind_linux.conf file in this UEFI install.
Comment 5 Maurice Batey 2018-05-08 21:02:45 CEST
> ,I had to add "NOKMSBOOT" to the boot commands in the Mageia-6 
> /boot/refind_linux.conf file in this UEFI install.

 Question: Was that needed just for the one-off occasion of changing over to nVidia proprietary driver, or does it need to stay in there?

(It has been suggested to me elsewhere that the initramfs should be rebuilt but excluding the nouveau driver module from it, so that it doesn't get loaded at boot time, and so that the invidia proprietary driver can use KMS, but that's not the sort of change I would feel comfortable about attempting.)
Comment 6 Maurice Batey 2018-05-10 12:34:14 CEST
> Just started using the desktop's nVidia GT730 card, and now the desktop icons 
> remain undisturbed after reboot!!!

Sadly, shortlived. :-(

Without any further change, system has reverted to booting with jumbled 
desktop icons...

Fervent hope:  Mageia-6.1 will restore sanity.
Comment 7 Maurice Batey 2018-07-04 13:39:14 CEST
Seems Linux isn't the only system with this problem!

E.g. Recent extract from a 'Windows 7' forum:

"I must be brain dead or something. I could swear that at one time I
could right click on the desktop and choose to lock the icons in
place.

No more if I ever could.

Now Win7 wants to move my icons around every now and then

How do I make them stay as I want them to."

!!!

Still hoping Mageia-6.1 will have sorted this out...
Comment 8 Maurice Batey 2018-08-01 13:19:54 CEST
I have finally done the 64-bit UEFI Mageia-6 Plasma5 Grand Update, in the hope that the result will have solved this problem.

The first few boots suggested it had but yesterday & today after reboot most of the desktop icons have been moved to rows across the top of the (nVidia) screen, even though icons and widgets are 'locked'.

As before, sometimes they have, and at other times not, been shuffled.
  

Any cure in sight for this irritating problem?!
Comment 9 Maurice Batey 2018-08-20 14:19:21 CEST
Is there anything I can do to help get this sorted out?!

(For me it's the only remaining 'fly in the ointment' in Mageia6.1.)
Comment 10 Maurice Batey 2018-09-13 18:20:19 CEST
P.S. I had been suspecting it was an nVidia problem, but have found that the same problem occurs on my HP Probook (vanilla Intel graphics) with Plasma5 Mageia-6.1.
Comment 11 Maurice Batey 2019-01-11 12:08:17 CET
This is still occurring - seemingly randomly, and is the only persistent problem I have with fully-updated Mageia-6.1...
Comment 12 Maurice Batey 2019-03-01 17:56:59 CET
Still a problem and confounded nuisance!

Not confined to nVidia machines, either - i.e. also with bog-standard Intel graphics...
Comment 13 Maurice Batey 2019-03-01 19:56:08 CET
Lloyd, as this bug is also present in Mageia-7 could you please change the version to Cauldron and put MGA6TOO on the whiteboard?

Many thanks!
Maurice Batey 2019-03-01 21:44:25 CET

Whiteboard: (none) => MGA6TOO
Version: 6 => Cauldron

Comment 14 Maurice Batey 2019-03-12 18:24:15 CET
(In reply to Maurice Batey from comment #12)
> Still a problem and confounded nuisance!
> 
> Not confined to nVidia machines, either - i.e. also with bog-standard Intel
> graphics...

  Well, for the last week or so I've noticed that desktop icons on Mga6.1 & Mga7 on desktop m/c and on laptop have truly remained locked, so presumably some s/w update recently on both systems has provided a fix!

  Fingers crossed it will stay fixed...

Note You need to log in before you can comment on or make changes to this bug.