Bug 2101 - KDE Help Center documentation is missing
Summary: KDE Help Center documentation is missing
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: Release (media or process) (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal major
Target Milestone: ---
Assignee: John Balcaen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-10 03:24 CEST by Rob V
Modified: 2011-12-10 16:38 CET (History)
5 users (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments

Description Rob V 2011-07-10 03:24:21 CEST
Description of problem:

Documentation in KDE Help Center is missing.

Steps to reproduce:

1. Install Mageia 1
2. go to "configure your desktop"
3. hit F1
4. Try viewing documentation for anything besides manpages.

Expected Result:

I expected to see documentation.

Result:

documentation was missing.


How reproducible:

Always.

Thought: if documentation is going to be trimmed, there should be a special package to easily install it again; perhaps this should be part of the standard install/upgrade process.
Comment 1 Rob V 2011-07-10 03:26:18 CEST
Edit: for this to work, I think you have to install from CD; I have a feeling DVDs supply the full documentation (I know this is the case with Mandriva).
Comment 2 John Balcaen 2011-07-10 04:34:19 CEST
What did you expect as documentation ? (aka which part is missing)
Comment 3 James Kerr 2011-07-10 08:37:37 CEST
In mdv the application Handbooks (the files that go in /usr/share/doc/HTML) were stripped out for the live CD's, to save space. I assume that the same has been done in mga.
Comment 4 Rob V 2011-07-10 23:46:33 CEST
As James says, I was referring to the application handbooks.
Comment 5 Ahmad Samir 2011-07-11 06:23:49 CEST
The workaround is reinstalling the package(s) in question, this time the packages, with all the docs, will be downloaded from the online repositories, e.g. to get the handbook of kopete:
su
urpmi --replacepkgs kopete
Comment 6 John Balcaen 2011-07-11 12:18:51 CEST
Should we split the handbooks from all packages ?
(aka having a kopete package & a kopete-handbooks as suggested ) ?
I did not know that thoses files where removed from the live-cd.
Comment 7 Ahmad Samir 2011-07-11 12:46:52 CEST
IINM, in the Live image the rpms are installed with --excludedocs, or something like that.

There is a bug report in mdv bugzilla about the same topic, it didn't go any where though https://qa.mandriva.com/show_bug.cgi?id=31639
Comment 8 Rob V 2011-07-12 02:28:35 CEST
I'm pretty sure you are correct; --excludedocs would do exactly what is done here. Thanks for the nice workaround.

Of course, not everyone needs the handbooks, but that decision should be the user's. Documentation is pretty important; without it, people can't "RTFM."

splitting the handbooks is certainly an interesting idea.
Comment 9 Ahmad Samir 2011-07-12 08:30:19 CEST
Splitting the handbooks from every kde package would cause a lot of clutter, too many sub-packages, and since they can't be on the live CD due to space constraints, users will have to install them manually...

Maybe all the handbooks from each KDE .src.rpm can be in one single sub-package, e.g. kdebase4-handbooks, kdebase4-workspace-handbooks... etc; however this being a viable option depends on how big that -handbooks package will be, if it's too big, then a user who just wants the handbook of konsole, wouldn't want to download a big package when the konsole handbook is a small portion of it. (My initial guess is that they would be small in size, since ultimately they're just text files..).

Of course this doesn't fix the issue distro-wide, just for kde packages (which is still an improvement IMHO).
Comment 10 Marek Laane 2011-07-12 10:16:32 CEST
WRT size: some handbooks are quite heavily illustrated. Anyway, besides text files there are pictures, too.
Comment 11 John Balcaen 2011-07-12 19:51:29 CEST
@ennael ? what should we do ?
Comment 12 John Balcaen 2011-09-05 16:47:07 CEST
Ennael is agree with this change, however i'll do it only for the next mageia release (so we should be ok for at least KDE SC 4.7.1 in cauldron )
Comment 13 Samuel Verschelde 2011-10-01 14:09:28 CEST
Moving
Comment 14 Dick Gevers 2011-12-09 18:10:07 CET
Changing as per discussion (best chance to get a fix in '2')
Comment 15 John Balcaen 2011-12-10 16:38:10 CET
well it's already fixed for mageia 2 :)

Note You need to log in before you can comment on or make changes to this bug.