Bug 21009 - Plasma freeze on some copied application icons on desktop
Summary: Plasma freeze on some copied application icons on desktop
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
: High major
Target Milestone: ---
Assignee: KDE maintainers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-02 00:04 CEST by William Kenney
Modified: 2017-06-16 16:36 CEST (History)
2 users (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments
journalctl log of frozen plasma desktop (264.76 KB, text/plain)
2017-06-02 00:06 CEST, William Kenney
Details
journalctl log of frozen plasma desktop (29.29 KB, text/plain)
2017-06-02 00:07 CEST, William Kenney
Details
journalctl output test03 (694.71 KB, text/plain)
2017-06-03 20:43 CEST, William Kenney
Details
plasma freeze journalctl log (13.97 KB, text/plain)
2017-06-11 22:49 CEST, William Kenney
Details

Description William Kenney 2017-06-02 00:04:02 CEST
Description of problem:

This issue is described as best I can. Start with a clean
HDD or new Vbox client. I use netinstall as it insures I am
using all the updates. First boot to a Plasma, x86_64 desktop.
Click on the launch menu and drag one of the launch icons to
the desktop, lets use Filezilla. The icon will display a
little red dot on it. If you left button click on the icon
you would expect a Plasma notification that goes something
like this:

This will start the program:

Filezilla

If you do not trust this program, click

Continue Cancel

What happens is there is a notification of the message on
the task bar but the window does not appear and the desktop
is frozen. A ctrl-alt-backspace will get you out of the
situation. Restarting Plasma will bring you back to where
you are and the same thing will happen. If you open a
terminal and type in filezilla the notice window will
appear normally and you can "continue" to the application.
From then on clicking on the filezilla desktop icon will
operate as expected. Most of the time.

This issue is not specific to filezilla as many apps
respond the same way when you first set them up. Once you
launch them from a terminal they are fine. Many/most apps
will operate correctly and not freeze the desktop. Or will
show the error a couple times then operate correctly.

I've captured two journalctl logs and attached them to this
bug. The newest listings on these logs are when the error
occurred as I ran the log as soon as I could get back to a
working desktop.
Comment 1 William Kenney 2017-06-02 00:06:16 CEST
Created attachment 9373 [details]
journalctl log of frozen plasma desktop
Comment 2 William Kenney 2017-06-02 00:07:01 CEST
Created attachment 9374 [details]
journalctl log of frozen plasma desktop
Comment 3 William Kenney 2017-06-03 20:42:38 CEST
On real hardware, M6, KDE, 64-bit

Tried this again today with a repo updated at around 18:00 UTC

Same issue occurs. Drag icons from launch menu to desktop then
click on them for first launch. Plasma desktop freezes.
Red Dot "!" on top of icon does not go away and "This will start the program"
warning appears on the task bar but not on the desktop. Icons doing this
are Volume, Filezilla and Firefox. I've attached the plasma_freeze_test03.txt
journalctl.txt to this bug. Note the multiple times it complains about:

Could not locate service type file kservicetypes5

Test platform:
Intel Core i7-2600K Sandy Bridge 3.4GHz
GIGABYTE GA-Z68X-UD3-B3 LGA 1155 MoBo
GIGABYTE GV-N440D3-1GI Nvidia GeForce GT 440 (Fermi) 1GB
RTL8111/8168B PCI Express 1Gbit Ethernet
DRAM 16GB (4 x 4GB)
Samsung 250GB SSD
Comment 4 William Kenney 2017-06-03 20:43:27 CEST
Created attachment 9388 [details]
journalctl output test03
Comment 5 William Kenney 2017-06-04 20:04:52 CEST
After many different install processes, netinstall, CI, LiveDVD I've
come to the conclusion that what works 100% of the time is that after
first boot to a working Plasma desktop and before you set up anything
simply delete directory:

/home/user/.config

then rename directory:

/home/user/.local to /home/user/.local.old

ctrl-alt-backspace to get out of the user space then log back in

This will force Plasma to rebuild both directorys and the problem
never occurs even in the first place. After your back going again
delete directory:

/home/user/.local.old
Comment 6 William Kenney 2017-06-05 21:13:45 CEST
I've moved the importance of this to "Release Blocker". Tell me where I'm wrong or what I can do to better document it. Thanks
Comment 7 Morgan Leijström 2017-06-06 09:47:34 CEST
I also saw such messages in the log of bug 21010 (which is about sound not working, and also about a non-popping up error message) I remember i also had some quirk like this bug but the hard disk broke before getting to that issue...

jun 02 18:35:33 localhost ksplashqml[3884]: kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/, tried ("/home/nopass/.local/share", "/usr/local/share", "/usr/share")

@William: if you create a new user, do that user see this bug?
Comment 8 William Kenney 2017-06-06 18:33:58 CEST
(In reply to Morgan Leijström from comment #7)

> @William: if you create a new user, do that user see this bug?

Gracious, this is all so very elusive. So first thing today on real
hardware using netinstall I got to the Plasma desktop that seemed
to go without a problem until I attempted to unlock the task bar. That
locked up the desktop. Ctrl-Alt-Backspace got me out, I logged back
in and attempted to unlock the task bar again and the desktop froze
again. So I created another user and went through the same process
and immediately attempting to launch Filezilla the desktop locked up.
Comment 9 William Kenney 2017-06-06 18:43:05 CEST
And as before deleting directory:

/home/user/.config

then rename directory:

/home/user/.local to /home/user/.local.old

relogging in as user fixes the problem.
Comment 10 William Kenney 2017-06-06 20:53:35 CEST
One more test today. A Vbox client netinstall. It was going swimmingly
well. No issues during the install everything seemed to be launching
from desktop icons without issue. Then I launched Firefox and the
desktop froze. Restart the client, launch Firefox from a terminal,
and from there on no problems. Even launching Firefox from the desktop
icon was successful.
Comment 11 William Kenney 2017-06-07 20:09:04 CEST
Repo has settled out considerably. A Vbox netinstall today resulted
in a completely clean install and setting up the Plasma desktop was
trouble free. I've give it a go again on real hardware tomorrow.
Comment 12 William Kenney 2017-06-08 20:22:15 CEST
Netinstall today from an up-to-date repo on real hardware. Dragging
Firefox and Filezilla to the Plasma desktop then clicking on that icon
locks up the Plasma desktop every time. No matter what I do I cannot
get past this bug to fix the problem. Raising Importance to critical.
Comment 13 William Kenney 2017-06-08 23:10:43 CEST
Grrrr....so I went all the way back to:

Mageia-6-rc-LiveDVD-Plasma-x86_64-DVD.iso  05/25/17

Booted that up and dragged my icons to the desktop and changed the
targeted repo. All the desktop icons worked without error. I then
clicked the install icon on the desktop and rebooted back. That
went all just fine. I then updated the install ( 350 updates ),
that went fine and the install booted back to a working desktop.
None of the icons exhibited this problem.

So

A netinstall will definitely create this problem.

Install from a LiveDVD and there will be no problem even after
you update it.

The netinstall is forgetting something?
Comment 14 William Kenney 2017-06-11 22:49:25 CEST
Created attachment 9401 [details]
plasma freeze journalctl log

New install today to a blank drive I encountered two Plasma
work space freezes and was able to isolate the exact second
or so in the journalctl log. I have attached a text file to
this bug that contains 50 of the last entry's into that log
just as the freeze occurred.
Comment 15 William Kenney 2017-06-12 18:00:51 CEST
Ok this time I created a x86_64 Vbox client barebones install.
Nothing on the desktop. Dragged and copied the Firefox icon
from the Panel Launch menu to the desktop and clicked on that
icon. Plasma froze three times in a row. In order to get back
to a working desktop you have to force the Client to turn off
then turn it back on again. I then dragged and linked the
desktop icon and sure enough it worked just fine. I then went
back to the copied icon and yup the Plasma desktop froze.
Then back to the linked desktop icon and it worked every time.
Comment 16 William Kenney 2017-06-12 18:04:07 CEST
Changing the Description of this bug to:

"Plasma freeze on some copied application icons on desktop"

Using a linked icon appears to mitigate the problem.

Reducing importance level to major
Comment 17 William Kenney 2017-06-16 16:36:42 CEST
Per a decision of the QA team this is not a release blocker.
It's still a Major shortcoming but should no block the
release of M6.

Note You need to log in before you can comment on or make changes to this bug.