Bug 20455 - Vbox upgrade from 5 to 6 breaks due to changing driver from vboxvideo to modesetting but keeping nomodeset argument
Summary: Vbox upgrade from 5 to 6 breaks due to changing driver from vboxvideo to mode...
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: Installer (show other bugs)
Version: Cauldron
Hardware: All Linux
: release_blocker normal
Target Milestone: ---
Assignee: Mageia tools maintainers
QA Contact:
URL:
Whiteboard:
Keywords: 6RC, 6sta2, PATCH
Depends on:
Blocks:
 
Reported: 2017-03-12 02:37 CET by Brian Rockwell
Modified: 2017-05-06 18:02 CEST (History)
7 users (show)

See Also:
Source RPM: drakx-kbd-mouse-x11, drakxtools
CVE:
Status comment: The 'nomodeset' option should be removed when changing to the modesetting driver


Attachments
truncated journal of execution (837.84 KB, application/gzip)
2017-03-12 02:38 CET, Brian Rockwell
Details
dmesg of the reboot and execution after the upgrade from mga5 to 6 (32.08 KB, text/plain)
2017-03-12 02:39 CET, Brian Rockwell
Details
report.bug (350.17 KB, application/zip)
2017-03-29 04:18 CEST, Brian Rockwell
Details
ddebug.log (281.24 KB, application/zip)
2017-03-29 04:19 CEST, Brian Rockwell
Details
Stage1.log (997 bytes, application/zip)
2017-03-29 04:20 CEST, Brian Rockwell
Details
Proposed fix part1 (1.23 KB, text/plain)
2017-05-06 14:52 CEST, Martin Whitaker
Details
Proposed fix part2 (1.04 KB, text/plain)
2017-05-06 14:53 CEST, Martin Whitaker
Details

Description Brian Rockwell 2017-03-12 02:37:40 CET
Description of problem:  Appears upgrade from MGA5 to MGA6 is causing an infinite look in the upgrade.  This is a KDE to Plasma 64-bit upgrade


Version-Release number of selected component (if applicable): 6


How reproducible:  VM instance, MGA5 fully patched up to 20170311 perform install/upgrade from classic ISO


Steps to Reproduce:
1.  Run install/upgrade
2.  reboot
3.  I will attach journal and dmesg
Comment 1 Brian Rockwell 2017-03-12 02:38:51 CET
Created attachment 9071 [details]
truncated journal of execution

This should contain some information from patching I did right before the upgrade and then execution after upgrade.  I'll add dmesg as well.
Comment 2 Brian Rockwell 2017-03-12 02:39:29 CET
Created attachment 9072 [details]
dmesg of the reboot and execution after the upgrade from mga5 to 6
Comment 3 Marja van Waes 2017-03-12 08:59:57 CET
SDDM is looping, but I'm not sure SDDM is the culprit.

CC'ing KDE team and kernel&drivers maintainers
Comment 4 Brian Rockwell 2017-03-19 00:40:00 CET
Happened with i586 and GNOME MGA5 to MGA6 upgrade as well - the 20170314 version of the classic code.

I think the system is still trying to run grub instead of grub2, could that be part of the issue?.


Anything you want me to try and get for this?
Comment 5 Marja van Waes 2017-03-28 09:53:47 CEST
(In reply to Brian Rockwell from comment #4)
> Happened with i586 and GNOME MGA5 to MGA6 upgrade as well - the 20170314
> version of the classic code.
> 
> I think the system is still trying to run grub instead of grub2, could that
> be part of the issue?.

CC'ing barjac and the isobuilders, keeping grub during an upgrade is intended and should not cause any problems on reboot.

> 
> 
> Anything you want me to try and get for this?

Yeah, please fetch /root/drakx/report.bug with the _time_stamp_ that matches the upgrade. (/root/drakx/report.bug.xz is very likely from the original Mga5 install)

Copy it to your home directory and then compress it with xz:

   xz report.bug

and then attach report.bug.xz to this report.
Comment 6 Brian Rockwell 2017-03-29 04:18:46 CEST
Created attachment 9162 [details]
report.bug

First of the three files I collected off of the upgrade from MGA5.1 KDE to 6 Plasma using Virtual Box.  After reboot the system hangs and loops.  

This one was done on an Intel.
Comment 7 Brian Rockwell 2017-03-29 04:19:48 CEST
Created attachment 9163 [details]
ddebug.log

From Intel VirtualBox upgrade of MGA 5 to 6
Comment 8 Brian Rockwell 2017-03-29 04:20:57 CEST
Created attachment 9164 [details]
Stage1.log
Comment 9 Nicolas Lécureuil 2017-03-29 09:05:31 CEST
i don't pass to reproduce.

Did you tried an other update to see if this is still valid?

you update isfrom Sta2 isos or update by the internet ?
Comment 10 Brian Rockwell 2017-03-29 14:55:50 CEST
MGA 5 was current.

MGA 6 was built from mageia_6_rc_x86_64-DVD classic.
Comment 11 Martin Whitaker 2017-03-29 21:13:33 CEST
In the first attachment (the journal) I see

Mar 11 18:32:13 localhost service_harddrake[706]: switch X.org driver from 'vboxvideo' to 'modesetting' (The graphics card 'InnoTek Systemberatung GmbH|VirtualBox Graphics Adapter' is no longer supported by driver 'vboxvideo')

which is correct. But going back to the point where you rebooted, I see

Mar 11 18:32:06 localhost kernel: Command line: BOOT_IMAGE=linux root=UUID=4d95d47d-4d08-4069-827d-d8ce3dab4323 nomodeset splash quiet noiswmd resume=UUID=12f65877-1ad2-4a8f-97cd-1d8720e0aabf audit=0 vga=788

Testing this locally, the 'nomodeset' option does stop the 'modesetting' driver working (which isn't too surprising!).

Ideally harddrake would remove the 'nomodeset' option and force a reboot in this case.

@Brian, please try removing 'nomodeset' from the boot command line in the grub menu, to see if that fixes the problem.
Comment 12 Brian Rockwell 2017-03-29 22:49:09 CEST
@Martin - removing nomodeset from the kernel options did bring me to a working desktop
Comment 13 Rémi Verschelde 2017-04-26 13:00:29 CEST
(In reply to Martin Whitaker from comment #11) 
> Mar 11 18:32:13 localhost service_harddrake[706]: switch X.org driver from
> 'vboxvideo' to 'modesetting' (The graphics card 'InnoTek Systemberatung
> GmbH|VirtualBox Graphics Adapter' is no longer supported by driver
> 'vboxvideo')

[...]
 
> Ideally harddrake would remove the 'nomodeset' option and force a reboot in
> this case.

Thierry, what do you think about this?
Comment 15 Martin Whitaker 2017-05-06 14:52:06 CEST
Created attachment 9265 [details]
Proposed fix part1
Comment 16 Martin Whitaker 2017-05-06 14:53:57 CEST
Created attachment 9266 [details]
Proposed fix part2

Try these. I've tested a mga5 to mga6 upgrade in Vbox, and they fix the bug for me.
Comment 17 Thierry Vignaud 2017-05-06 15:54:03 CEST
Looks good to me
Comment 18 Rémi Verschelde 2017-05-06 15:56:48 CEST
Great :) Feel free to commit and make new releases Martin, I'll push the packages.
Comment 19 Mageia Robot 2017-05-06 16:20:26 CEST
commit fec3227faa8605b86db734aa4826fdf07e5d2eec
Author: Martin Whitaker <mageia@...>
Date:   Sat May 6 13:12:28 2017 +0100

    service_harddrake: require reboot if nokmsboot option changed (mga#20455).
---
 Commit Link:
   http://gitweb.mageia.org/software/drakx/commit/?id=fec3227faa8605b86db734aa4826fdf07e5d2eec
Comment 20 Mageia Robot 2017-05-06 16:30:40 CEST
commit 2c6bc491f08d12cf5056a9d3d9777aefc110f1ab
Author: Martin Whitaker <martin@...>
Date:   Sat May 6 12:21:47 2017 +0100

    Remove 'nomodeset' boot option when switching to a modesetting driver (mga#20455).
---
 Commit Link:
   http://gitweb.mageia.org/software/drakx-kbd-mouse-x11/commit/?id=2c6bc491f08d12cf5056a9d3d9777aefc110f1ab
Comment 21 Martin Whitaker 2017-05-06 16:54:22 CEST
(In reply to Rémi Verschelde from comment #18)
> Great :) Feel free to commit and make new releases Martin, I'll push the
> packages.

I think that's all done now.
Comment 22 Rémi Verschelde 2017-05-06 18:02:57 CEST
Fixes pushed in drakxtools-17.82-1.mga6 and drakx-kbd-mouse-x11-1.22-1.mga6.

Note You need to log in before you can comment on or make changes to this bug.