Bug 20431 - [Update Request] Supported stable version dokuwiki-20160626-1.mga5
Summary: [Update Request] Supported stable version dokuwiki-20160626-1.mga5
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 5
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL: https://www.dokuwiki.org/changes
Whiteboard: MGA5-64-OK advisory
Keywords: validated_update
Depends on:
Reported: 2017-03-09 15:15 CET by Atilla ÖNTAŞ
Modified: 2017-03-17 12:13 CET (History)
3 users (show)

See Also:
Source RPM: dokuwiki-20160626-1.mga5.src.rpm
Status comment:


Description Atilla ÖNTAŞ 2017-03-09 15:15:26 CET
I have updated dokuwiki to a upstream supported stable version.

See Changes betwwen versions here: https://www.dokuwiki.org/changes

Suggested advisory:
-Update to supported stable version: 20160626
Our current dokuwiki package is pretty outdated and unsupported by upstream which unable to receive security fixes. Updated stable 20160626 version brings exciting new features and include bugfix/security fixes. Note that this package built from latest hotfix release 20160626b

See Changes between versions here: https://www.dokuwiki.org/changes


Updated packages in core/updates_testing:

Comment 1 Len Lawrence 2017-03-13 17:31:18 CET
I would test this if I had the slightest idea how to start it up.  Pointed the web browser at localhost/dokuwiki and got a 404 error.  All the information about using it on the web seems to assume that it is already running.

Googling brought up a forum with this comment:
"On Ubuntu you probably don't need to do anything after installing the package. Just point your browser to http://localhost/dokuwiki/"

CC: (none) => tarazed25

Comment 2 Atilla ÖNTAŞ 2017-03-13 18:49:33 CET
Len, thank you. All requirements should be installed along with dokuwiki. To setup and activate an apache web server pointing to dokuwiki installation:

* Please backup your /etc/httpd/conf/httpd.conf file first.
* Edit /etc/httpd/conf/httpd.conf file with your favorite editor as root and find these lines:

DocumentRoot "/var/www/html"

# Relax access to content within /var/www.
<Directory "/var/www">
    AllowOverride None
    # Allow open access:
    Require all granted

# Further relax access to the default document root:
<Directory "/var/www/html">

Replace /var/www/html directory entry with /usr/share/dokuwiki

* Start httpd service: systemctl start httpd.service

* Fire up a web browser and enter to your adressbar.

You should welcomed with dokuwiki start page. That's all.
Comment 3 Len Lawrence 2017-03-13 20:06:35 CET
Thanks Atilla (and glad you have survived the troubles).  I discovered that Apache was not running but could not restart it - in fact no webservers will start.  I shall move to another machine and try dokuwiki.
Comment 4 Len Lawrence 2017-03-13 21:32:02 CET
Webserver issue resolved.
OK, edited the httpd.conf file as indicated, restarted the webserver and tried http://localhost/ and received the response "It works!" which is a hangover from some earlier QA test.  I probably need to delete something (/var/www/html/index.html)

Using http:/localhost/dokuwiki brings up a list of suggestions from my IP, all polite.
Comment 5 Len Lawrence 2017-03-13 23:27:59 CET
It works now.  /usr/share/dokuwiki did not exist so the package had to be reinstalled.  No idea why it did not install properly before.  Maybe I installed it on another machine.  ???

It now shows the start [DokuWiki] page.
Comment 6 Len Lawrence 2017-03-14 00:20:49 CET
Testing the update on x86_64 real hardware, Mate desktop.

After the update the config file remained unchanged.
Restarted Apache webserver and
$ firefox http://localhost
has reverted to "It works!".
$ firefox http://localhost/dokuwiki
now brings up a blank page.
$ rpm -qa | grep dokuwiki
Comment 7 Len Lawrence 2017-03-14 16:38:19 CET
Trying again on another machine.
Before updating, edited the configuration file, pointed the browser at http://localhost/ and saw the "It works!" message.  At this stage typing dokuwiki after localhost/ brings up the DokuWiki start page.
Installing the update produces some information:
The setup used here differs from default one, to achieve better FHS compliance, and
follow upstream security recommandations detailed at
- the non-variable files are in /usr/share/dokuwiki
- the variable files are in /var/lib/dokuwiki
- the configuration files are in /etc/dokuwiki

Addressing localhost after restarting the web server elicits "It works!" and adding dokuwiki to the addressbar gives a blank page.

Just wondering if the change in the setup from the default one causes a problem here.
Comment 8 Atilla ÖNTAŞ 2017-03-14 18:12:04 CET
Len, are you sure that /etc/httpd/conf/httpd.conf file still points to /usr/share/dokuwiki ?
Comment 9 Len Lawrence 2017-03-14 20:32:05 CET
Yes, I just checked.
<Directory "/var/www">
    AllowOverride None
    # Allow open access:
    Require all granted

# Further relax access to the default document root:
<Directory "/usr/share/dokuwiki">
Comment 10 Len Lawrence 2017-03-14 20:34:53 CET
$ ls -l
total 64
drwxr-xr-x 2 root root  4096 Mar 13 19:22 conf.d
-rw-r--r-- 1 root root 11667 Mar 14 15:13 httpd.conf
-rw-r--r-- 1 root root 11661 Jul 19  2016 httpd.conf~
-rw-r--r-- 1 root root 11661 Mar 14 15:11 httpd.conf.original
-rw-r--r-- 1 root root 13077 Jul 19  2016 magic
drwxr-xr-x 2 root root  4096 Mar 14 11:07 modules.d
drwxr-xr-x 2 root root  4096 Mar 14 15:21 sites.d
lrwxrwxrwx 1 root root     7 Jul 19  2016 vhosts.d -> sites.d
lrwxrwxrwx 1 root root     7 Jul 19  2016 webapps.d -> sites.d
Comment 11 Len Lawrence 2017-03-14 20:52:55 CET
I tried to disable the "It works!" greeting, in case /var/www/html/ was somehow getting priority over the /usr/share/dokuwiki path.  Tried hiding the html directory then removing index.html altogether but the message keeps appearing so it must originate somewhere else.
Comment 12 Atilla ÖNTAŞ 2017-03-14 22:20:25 CET
(In reply to Len Lawrence from comment #11)
> I tried to disable the "It works!" greeting, in case /var/www/html/ was
> somehow getting priority over the /usr/share/dokuwiki path.  Tried hiding
> the html directory then removing index.html altogether but the message keeps
> appearing so it must originate somewhere else.

Please revert all changes to your /etc/httpd/conf/httpd.conf file and restart httpd.service http://localhost/dokuwiki/ or should ok. My previous suggestion seems to be unnecessary. Otherwise you have some misconfiguration regarding to apache.
Comment 13 Len Lawrence 2017-03-14 23:08:33 CET
And still no result.  If apache is misconfigured it is unlikely to be because of anything I may have done because I do not know enough to tinker with httpd settings.  What we have to remember is that the start page came up before the update.  I gather that the system works for you Atilla.  About the only thing I can do is a reboot.  This installation is pretty clean, only two days old, fully updated and probably running with default settings everywhere.
Comment 14 Len Lawrence 2017-03-14 23:24:24 CET
Resurrecting a 32-bit vbox on this same machine to test dokuwiki on i586.
Before updating the start page came up right away.
Comment 15 Len Lawrence 2017-03-14 23:31:44 CET
Updated from Core Updates Testing and restarted httpd.
$ systemctl status httpd.service
â httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled)
   Active: active (running) since Tue 2017-03-14 22:27:33 GMT; 4s ago
  Process: 24649 ExecReload=/usr/sbin/httpd $OPTIONS -k graceful (code=exited, status=0/SUCCESS)
 Main PID: 24766 (/usr/sbin/httpd)
   Status: "Processing requests..."
   CGroup: /system.slice/httpd.service
           ââ24766 /usr/sbin/httpd -DFOREGROUND
           ââ24769 /usr/sbin/httpd -DFOREGROUND
           ââ24770 /usr/sbin/httpd -DFOREGROUND
           ââ24771 /usr/sbin/httpd -DFOREGROUND
           ââ24772 /usr/sbin/httpd -DFOREGROUND
           ââ24773 /usr/sbin/httpd -DFOREGROUND

Pointed firefox at localhost/dokuwiki and nothing; blank page.
This is baffling.
Comment 16 Atilla ÖNTAŞ 2017-03-16 15:37:53 CET
I think i've fixed the issue, please try with dokuwiki-20160626-2.mga5.noarch.rpm
Comment 17 Dave Hodgins 2017-03-17 02:32:28 CET
Installed dokuwiki-20140929-6.mga5.noarch, and confirmed the page loaded at
http://localhost/dokuwiki/ in firefox.

Installed dokuwiki-20160626-2.1.mga5.noarch
To be sure the update will be used, ran "systemctl restart httpd.service"

Note: No config files modified.

In firefox, reloaded the main page, selected Sitemap in upper right, then
wiki, then welcome, then the red Start.

Then clicked on the pencil icon on the right to create this page, entered
some text, then saved the page, and it displays correctly.

In yellow, above the page, it's still displaying update available ...
Hotfix release available fixing security token and media manager: 2017-02-19b "Frusterick Manners". upgrade now! [49.2] (what's this?)
Hotfix release available fixing install and media manager issues: 2017-02-19a "Frusterick Manners". upgrade now! [49.1] (what's this?)
New release available: 2017-02-19 "Frusterick Manners". upgrade now! [49] (what's this?)

so looks like there will be another updated needed after this one.

As it's a noarch package, it only need to be tested on one arch.

Advisory added to svn. Validating the update.

Keywords: (none) => validated_update
Whiteboard: (none) => MGA5-64-OK advisory
CC: (none) => davidwhodgins, sysadmin-bugs

Comment 18 Mageia Robot 2017-03-17 12:13:34 CET
An update for this issue has been pushed to the Mageia Updates repository.


Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.