Bug 20192 - update nvidia-current-375.26-1.mga5.nonfree not working
Summary: update nvidia-current-375.26-1.mga5.nonfree not working
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 5
Hardware: All Linux
: Normal critical
Target Milestone: ---
Assignee: Kernel and Drivers maintainers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-28 14:50 CET by Didier Le Gloanic
Modified: 2017-04-20 05:59 CEST (History)
6 users (show)

See Also:
Source RPM: nvidia-current-375.26-1.mga5.nonfree, nvidia-current-375.39-5.mga6.nonfree.src.rpm
CVE:
Status comment:


Attachments
Journal.txt (99.96 KB, text/plain)
2017-01-31 05:43 CET, Didier Le Gloanic
Details
Xorg.0.log (4.97 KB, text/x-log)
2017-02-02 19:53 CET, Martin Volf
Details
journalctl -ba (1.42 KB, text/plain)
2017-02-02 19:54 CET, Martin Volf
Details
dkms build log (10.88 KB, text/plain)
2017-04-03 14:29 CEST, Martin Whitaker
Details

Description Didier Le Gloanic 2017-01-28 14:50:47 CET
Description of problem:

That update to nvidia-current-375.26-1 result in a lack of graphical interface on my computer.
The booting list of services note nvidia OK but then hang when it should go graphic.
When downgrading to previous version, at the end urpmi notify that version 375.26
was inactive for that kernel (4.4.39).

Version-Release number of selected component (if applicable):
dkms-nvidia-current-375.26-1.mga5.nonfree, x11-driver-video-nvidia-current-375.26-1.mga5.nonfree

How reproducible:
boot lead to failure

Tried twice with same result.
I'm running mga 5 server 32 bit and have a gts450.
Comment 1 Marja van Waes 2017-01-28 18:34:39 CET
Please reproduce the problem and switch to a VT with e.g. Ctrl+Alt+F3, log in, become root and run

    journalctl -ab > journal.txt


and attach journal.txt to this bug report.
Comment 2 Didier Le Gloanic 2017-01-31 05:43:36 CET
Created attachment 8911 [details]
Journal.txt

result of journalctl -ab on a failing system
Comment 3 Didier Le Gloanic 2017-01-31 05:51:41 CET
Ok, I've posted the journal. 
I want to tell than a friend suffer from the same bug. He run 32bit server as well but his hardware is different.
Only common things are intel cpu and nvidia gpu, both being different models than mines.
Comment 4 Didier Le Gloanic 2017-01-31 06:01:56 CET
I've forgot to say that there it's possible that the bug is from Nvidia itself, since someone, who reported the same bug on the support forum of mageia, tried to use the nvidia installer whithout success.
Here is the link : https://forums.mageia.org/en/viewtopic.php?f=7&t=11586
Comment 5 Didier Le Gloanic 2017-01-31 06:06:18 CET
And sorry for the broken english, i tend to reformulate things and forget some words behind before posting... an edit function would be nice.
Comment 6 Martin Volf 2017-02-02 19:52:17 CET
Next user reports X does not start after driver update to x11-driver-video-nvidia-current-375.26-1.mga5.nonfree with nVidia GTX 750 Ti.

Errors from journalctl:
(EE) No devices detected.
(EE) Fatal server error:
(EE) no screens found(EE)

Temporary solution:
- to install a driver GeForce 8100 to GeForce 415 (packages of nvidia340, not nvidia-current)

OS:
===
$ cat /etc/issue
Mageia release 5 (Official) for i586
Kernel 4.4.39-desktop-1.mga5 on a Dual-processor i686 / \l

Graphic card:
=============
$ lspci -nn|grep -i vga
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] [10de:1380] (rev a2)

Sources:
========
$ urpmq --list-media active --list-url
Core Release (distrib1) http://mageia.supp.name/distrib/5/i586/media/core/release
Core Updates (distrib3) http://mageia.supp.name/distrib/5/i586/media/core/updates
Nonfree Release (distrib11) http://mageia.supp.name/distrib/5/i586/media/nonfree/release
Nonfree Updates (distrib13) http://mageia.supp.name/distrib/5/i586/media/nonfree/updates
Tainted Release (distrib21) http://mageia.supp.name/distrib/5/i586/media/tainted/release
Tainted Updates (distrib23) http://mageia.supp.name/distrib/5/i586/media/tainted/updates

Installed packages:
===================
$rpm -qa | grep -i -e kernel -e nvidia | sort
dkms-nvidia-current-375.26-1.mga5.nonfree
dkms-nvidia340-340.101-1.mga5.nonfree
kernel-desktop-devel-latest-4.4.39-1.mga5
kernel-desktop-devel-4.4.36-2.mga5-1-1.mga5
kernel-desktop-devel-4.4.39-1.mga5-1-1.mga5
kernel-desktop-latest-4.4.39-1.mga5
kernel-desktop-4.4.36-2.mga5-1-1.mga5
kernel-desktop-4.4.39-1.mga5-1-1.mga5
kernel-firmware-nonfree-20160914-1.mga5.nonfree
kernel-firmware-20160409-1.mga5
kernel-userspace-headers-4.4.39-1.mga5
nvidia-current-doc-html-375.26-1.mga5.nonfree
nvidia340-doc-html-340.101-1.mga5.nonfree
x11-driver-video-nvidia-current-375.26-1.mga5.nonfree
x11-driver-video-nvidia340-340.101-1.mga5.nonfree
Comment 7 Martin Volf 2017-02-02 19:53:21 CET
Created attachment 8922 [details]
Xorg.0.log
Comment 8 Martin Volf 2017-02-02 19:54:12 CET
Created attachment 8923 [details]
journalctl -ba
Comment 9 Martin Whitaker 2017-04-03 14:28:23 CEST
Also valid in cauldron with latest dkms-nvidia-current (375.39-5.mga6.nonfree). The driver builds and loads OK on a 64-bit system, but not on a 32-bit system. The important line from attachment 8911 [details] is:

janv. 31 05:27:02 localhost kernel: nvidia: Unknown symbol phys_to_dma (err 0)

which prevents the kernel module being loaded. This same error is seen in the dkms build log.
Comment 10 Martin Whitaker 2017-04-03 14:29:56 CEST
Created attachment 9181 [details]
dkms build log
Comment 11 Thomas Backlund 2017-04-03 16:50:21 CEST
Crap, the phys_to_dma detection was supposed to be fixed in new nvidia-current drivers, but now it seems only 304 and 340 series were fixed :/

It means I have to build a new kernel set to restore that phys_to_dma export to get this working again...
Comment 12 Thomas Backlund 2017-04-03 17:13:41 CEST
(In reply to Martin Whitaker from comment #10)
> Created attachment 9181 [details]
> dkms build log

Looking on this I see:

 CONFTEST: phys_to_dma

but it apparently fails
Comment 13 Thomas Backlund 2017-04-03 20:36:32 CEST
Actually I see nvidia is trying to use a kernel internal symbol :/
Comment 14 Thomas Backlund 2017-04-03 21:11:45 CEST

Ah, I see it's https://bugs.mageia.org/show_bug.cgi?id=17604 that strikes again :/

I wond dupe it as it an advisory bug, but I'll fix the driver the same way as before

And as http://advisories.mageia.org/MGASA-2017-0025.html pushed the broken driver to mga5, I will update that one too..
Comment 15 Thomas Backlund 2017-04-03 22:43:23 CEST

Ok, I've pushed a fixed nvidia-current-375.39-6.mga6 to cauldron, 

and a nvidia-current-375.39-1.mga5 to mga5 nonfree updates_testing

Please try them out...
Comment 16 Martin Whitaker 2017-04-05 00:52:54 CEST
The mga6 version builds and loads correctly. I don't have the necessary H/W to check it actually works...
Comment 17 Marja van Waes 2017-04-10 08:03:15 CEST
(In reply to Thomas Backlund from comment #15)
> 
> Ok, I've pushed a fixed nvidia-current-375.39-6.mga6 to cauldron, 
> 
> and a nvidia-current-375.39-1.mga5 to mga5 nonfree updates_testing
> 
> Please try them out...

(In reply to Martin Whitaker from comment #16)
> The mga6 version builds and loads correctly. I don't have the necessary H/W
> to check it actually works...

CC'ing QA team and all packagers collectively, because I can't test it either.
Comment 18 Didier Le Gloanic 2017-04-20 05:59:58 CEST
I haven't checked this in a while but thanks for your work !

The 375.39-1 package from mga5 nonfree updates_testing load and work !

I haven't much tested for regressions but it seem fine.

Note You need to log in before you can comment on or make changes to this bug.