Bug 19593 - Installer fails when Workstation LSB package is asked/selected.
Summary: Installer fails when Workstation LSB package is asked/selected.
Alias: None
Product: Mageia
Classification: Unclassified
Component: Installer (show other bugs)
Version: Cauldron
Hardware: i586 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: Mageia tools maintainers
QA Contact:
Keywords: 6sta1, NEEDINFO
Depends on:
Reported: 2016-10-15 22:10 CEST by Renato Dali
Modified: 2016-10-17 10:57 CEST (History)
4 users (show)

See Also:
Source RPM:
Status comment:


Description Renato Dali 2016-10-15 22:10:12 CEST
Description of problem:

I tried to install Mga6sta1 with Xfce and wanted the LSB package for my Epson printer.

Version-Release number of selected component (if applicable):

How reproducible:

Always, I suppose, though I tried only once.

Steps to Reproduce:
1.Start installation with Mageia 6 sta1 image.
2.Proceed until the choice between KDE, Gnome and Custom: choose custom.
3.Select Xfce on this screen:


4.Open the Workstation category and select the LSB box.
5.Proceed with installation without "Individual Package Selection" by clicking on next.
6.After some time, the installer fails, complaining about missing files:

It then asked "Try to continue anyway?". I don't remember what I answered but in the end it returned to disk partition.

On a second time, without asking for the Workstation/LSB option, everything went fine.

Post installation, I added the lsb-noarch RPM.

As it occurs at installation, there can be no loss of data, but I consider it to be a Major one (major feature broken). With the workaround shown, it might be considered minor, so I rated it as Normal on average :-P

Please have in mind that my printer software requires LSB. No lsb package means no printing. I consider this _very_ major. But... here I am using Mga6 sta1 and being able to print without any problems...
Renato Dali 2016-10-15 22:10:40 CEST

Summary: Installer quits when Workstation LSB package is asked/selected. => Installer fails when Workstation LSB package is asked/selected.

Comment 1 Marja Van Waes 2016-10-16 12:43:03 CEST
@ Renato,

There is not much we can do with this report, without the installer logs.

_If_ the following:
> On a second time, without asking for the Workstation/LSB option, everything
> went fine.

means that you had to start installation from the _beginning_, then it would be great if you'd be willing to 
* re-do the installation
* reproduce the problem and 
* after that switch to tty2 (by pressing "Ctrl-Alt-F2")
* plug in a USB key/stick
* type:
* press Enter. 

That will put report.bug on key. Please then attach report.bug here.

_However_, _if_, after being returned to the partitioning step, your second attempt consisted in continuing from there without first rebooting, then you can just grab 


from that install and attach that instead.

I didn't check all the "missing" packages, but the ones I checked seem to be available on the iso in the correct version (albeit maybe a different release)

Keywords: (none) => 6sta1, NEEDINFO
CC: (none) => isobuild, marja11
Assignee: bugsquad => mageiatools

Comment 2 Thierry Vignaud 2016-10-16 14:04:50 CEST
Looks like a bad physical medium to me (aka bad DVD burning)

CC: (none) => thierry.vignaud

Comment 3 Martin Whitaker 2016-10-16 14:58:33 CEST
I can't reproduce this, installing from

% md5sum Mageia-6-sta1-i586-DVD.iso 
bbffcbb44580c2041f34153f0043514e  Mageia-6-sta1-i586-DVD.iso

in VirtualBox.

CC: (none) => mageia

Comment 4 Renato Dali 2016-10-17 03:55:07 CEST
@ Martin & @ Thierry:

I always check the md5sum, too; and K3B has a useful "Verify the recorded data" (at the end) option. Very rarely such verification fails; should that happen, the newly burnt disk goes directly to recycling.

Typically Mageia DVDs burn without any problem; most distros work as intended, too. Of course, the worse problems happen when everything seems alright.

@ Marja:

I'll probably install it again... thanks for the well-written instructions.

[some time passes...]

Hi, everyone.

I tried to reinstall some 4~5 times and could not reproduce the bug. Including one without internet. (BTW, sorry for the delay, it took some time...)

It's embarrassing but I'll have to mark this one as UNCONFIRMED. Should anyone want more details, I saved the report.bug.xz file from the previous installation, but I'm not sure it is the same from the time that the error came up. I also have a (camera) photo of the "missing" files.

The computer on which I'm trying to reproduce the current "bug" is so old it has no DVD (IIRC it had, but it broke and I installed a CD-reader I had at hand). So I must use Plop to boot from an external usb DVD R/W unit.

It's unexpected but it might have failed. I don't know. All successful installations were with the same DVD which originally was being used when the error happened. I did download Mga6sta1 64-bit, too, but didn't burn it yet -- that's how I know it was the very same disk.

Thus, sorry everyone, must be some mistake I made, or cosmic ray, or hardware malfunction... I don't know.

Thanks for the attention and checking (and patience).
I do apologize for any inconveniences caused.

Ever confirmed: 1 => 0

Comment 5 Marja Van Waes 2016-10-17 09:14:48 CEST
Don't worry, Renato.

Even if it would be nice if all bug reporters  would first reproduce the issues they hit, before filing them: especially with installer issues that's rather time consuming. Trying that could easily lead to real bugs _not_ being reported.

Thanks for the feedback!
Comment 6 Thierry Vignaud 2016-10-17 10:57:55 CEST
(In reply to Renato Dali from comment #4)
No problem.
And a Marja said, better safe than sorry :-)
So thanks for reporting it anyway

Resolution: (none) => INVALID

Note You need to log in before you can comment on or make changes to this bug.