Bug 19224 - Fish shell (/usr/bin/fish) should be added to /etc/shells
Summary: Fish shell (/usr/bin/fish) should be added to /etc/shells
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 5
Hardware: All Linux
: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL: https://github.com/fish-shell/fish-sh...
Whiteboard: MGA5-64-OK advisory
Keywords: validated_update
Depends on:
Blocks:
 
Reported: 2016-08-20 23:01 CEST by Hook
Modified: 2016-08-31 17:33 CEST (History)
4 users (show)

See Also:
Source RPM: fish-2.1.1-2.mga5.src.rpm
CVE:
Status comment:


Attachments

Description Hook 2016-08-20 23:01:15 CEST
Description of problem:

Fish shell currently cannot be selected as a default shell in either the Mageia Setting GUI nor `chsh`, because it does not exist in the "/etc/shells" file. This is a very annoying bug for a shell.

Upstream considers (rightfully so, I think) this as a downstream/packaging bug.


How reproducible:

Always


Steps to Reproduce:

1. urpmi fish
2. chsh -s `which fish`


Error output:

chsh: "/usr/bin/fish" is not listed in /etc/shells.
Use chsh -l to see list.


Desired outcome:

Be able to select the Fish as a default shell.


Steps to fix:

1. make sure the package adds "/usr/bin/fish" to "/etc/shells" when itâs installed (and removes it when itâs deleted)
2. thatâs it really
Comment 1 Jani Välimaa 2016-08-21 10:44:02 CEST
Pushed fixed fish-2.1.1-2.1.mga5 to core/updates_testing. Please test it.

Test case is very simple:
1. chsh -l and no fish in output
2. update fish
3. chsh -l and fish exists in output
4. remove fish
5. chsh -l and again no fish
Comment 2 Len Lawrence 2016-08-22 08:19:35 CEST
Tested this on x86_64.  Can confirm that the update makes fish available.
Comment 3 Mageia Robot 2016-08-31 17:33:25 CEST
An update for this issue has been pushed to the Mageia Updates repository.

http://advisories.mageia.org/MGAA-2016-0111.html

Note You need to log in before you can comment on or make changes to this bug.