Bug 18976 - 6RC Live 64-bit isos fail to boot on NVidia machines because of graphics problems
Summary: 6RC Live 64-bit isos fail to boot on NVidia machines because of graphics prob...
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: Release (media or process) (show other bugs)
Version: Cauldron
Hardware: x86_64 Linux
Priority: High major
Target Milestone: ---
Assignee: Kernel and Drivers maintainers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-18 15:35 CEST by Len Lawrence
Modified: 2017-03-05 14:27 CET (History)
5 users (show)

See Also:
Source RPM:
CVE:
Status comment: Waiting for the next set of Live ISOs to confirm again - needs testers with nvidia GPU


Attachments
Journal from boot to graphics failure (249.05 KB, text/plain)
2016-07-18 16:06 CEST, Len Lawrence
Details
dmesg output after attaching USB drive (79.08 KB, text/plain)
2016-07-18 16:07 CEST, Len Lawrence
Details
lsmod at point of failure (7.49 KB, text/plain)
2016-07-18 16:08 CEST, Len Lawrence
Details

Description Len Lawrence 2016-07-18 15:35:41 CEST
Description of problem:
On a variety of machines (3) with nvidia graphics, the 64bit isos fail to boot.  This is an example for a computer with GTX970 graphics and a 4k monitor on the display port:
Problem with graphics driver: "Good luck" message -> root login -> drakx11.
Could not load install the x11-driver-video-nvidia-current package!, defaulting to free software driver.  OK'd that then tried modprobe nouveau and monitor went dead.  Had to switch off machine and unplug the
monitor cable (DP) then plug it in again and restart the computer.  Rebooted and tried
vesa but could get no further than "you need to reboot".  Through the loop again and
tried the graphics test - "Fatal server error.  Try to change some parameters".  The
summary indicated that nouveau was being used.  Dropped back to the command line and saw:
"chroot: cannot change root directory to '/mnt/install': no such file or directory.
Xauth: file /root/.Xauthority does not exist."

# ls /run/initramfs => log/
# ls /run/initramfs/log => <empty>.

Mounted a USB pendrive and copied dmesg and boot journal to it.  Attaching these.  Tried this on a BIOS boot laptop with older nvidia graphics and hit the same problems.  Dead monitor.  The same with a UEFI twin-nvidia laptop.

VirtualBox handles these isos fine.

Version-Release number of selected component (if applicable):
Mageia-6-RC-LiveDVD-PLASMA5-x86_64-DVD

How reproducible:
Consistent across three machines and repeatable.

Steps to Reproduce:
1. Attempt to boot Plasma Live iso from USB stick
2. Install proprietary driver if you can get that far
3.
Comment 1 Len Lawrence 2016-07-18 16:06:09 CEST
Created attachment 8201 [details]
Journal from boot to graphics failure
Comment 2 Len Lawrence 2016-07-18 16:07:13 CEST
Created attachment 8202 [details]
dmesg output after attaching USB drive
Comment 3 Len Lawrence 2016-07-18 16:08:02 CEST
Created attachment 8203 [details]
lsmod at point of failure
Comment 4 Len Lawrence 2016-09-13 13:20:09 CEST
Checking this again since it is a release blocker.  The Plasma LIVE gets to the "Good luck" message even with nomodeset.  Installing the vesa driver sort of worked in that it booted to the desktop with a very low resolution.

Still valid as a release blocker.
Comment 5 Thomas Backlund 2016-10-18 21:56:23 CEST
well, nomodeset will also block nouveau loading...

one thing to test instead it to add:

xdriver=modesetting 

to kernel command line
Comment 6 Len Lawrence 2017-01-16 18:21:06 CET
The experiment with xdriver=modesetting failed but nokmsboot succeeded, which is the second option in the grub2 menu.

Hence, in view of the option to boot the Lives using proprietary drivers this is no longer a release blocker IMHO.
Comment 7 Samuel Verschelde 2017-03-05 14:27:47 CET
Lowering priority per comment #6

Note You need to log in before you can comment on or make changes to this bug.