Bug 1831 - IVTV cards not found by mythtv. (2.6.28 kernel v4l support drop)
Summary: IVTV cards not found by mythtv. (2.6.28 kernel v4l support drop)
Alias: None
Product: Mageia
Classification: Unclassified
Component: New RPM package request (show other bugs)
Version: 1
Hardware: All Linux
Priority: Normal major
Target Milestone: ---
Assignee: Colin Guthrie
QA Contact:
Keywords: validated_update
Depends on:
Reported: 2011-06-17 06:47 CEST by Greg McGee
Modified: 2014-05-08 18:06 CEST (History)
11 users (show)

See Also:
Source RPM:
Status comment:


Description Greg McGee 2011-06-17 06:47:47 CEST
Mythtv needs to be patched to "see" ivtv cards fo video recordings... it needs patched to use the v4L2 api for the ivtv cards. Kernel 2.6.38+ no longer has v4L1 support, apparently.

Other apps and cards/cameras are likely to have similar issues...

The Arch Linux bug (including patch for mythtv) is here:
Greg McGee 2011-06-17 06:50:55 CEST

Version: Cauldron => 1

Greg McGee 2011-06-17 06:51:33 CEST

Summary: IVTV cards (not found by mythtv. 2.6.28 kernel v4l support drop) => IVTV cards not found by mythtv. (2.6.28 kernel v4l support drop)

Ahmad Samir 2011-06-18 23:03:00 CEST

Assignee: bugsquad => mageia

Comment 1 Colin Guthrie 2011-07-10 20:27:35 CEST
Hi there.

I'm just looking at updating to the latest fixes.

The patch included above no longer applies but am I right in saying that this upstream patch:

commit a163dc82268d418939a7bd5fe782b82d7b55b7c7
Author: Michael T. Dean <mdean@mythtv.org>
Date:   Sun May 29 21:20:33 2011 -0400

    Enable building 0.24-fixes without system V4L1 support.
    This patch retrieves videodev_myth.h from revision 6ff252dfe3da25c39378
    (the revision before it was removed in bf7225c7dbaa28ac21a3 ), and
    modifies the MythTV code to use it, instead of the system
    linux/videodev.h header, so that MythTV will compile and work properly,
    even on systems based on the Linux 2.6.38+ kernel headers.

Should do the same job?

I'm not sure of any IVTV specific issues however.

I'll push out cauldron packages without any additional patches shortly and then look at getting them into /testing for MGA 1.
Comment 2 Wim Coulier 2011-09-09 09:29:31 CEST
I was planning to upgrade my backend from Mandriva 2010.2 to Mageia 1. However without Mythtv being able to use my PVR150 card, that is definitely a no-go.

Has this issue been resolved in the mean time and can I get fixed packages somewhere? If not, is there anything I can do to help things getting solved?

CC: (none) => wim

Wim Coulier 2011-09-09 09:31:32 CEST

Severity: normal => major

Comment 3 Greg McGee 2011-09-09 11:19:33 CEST
There is a way to build SRPM packages... although it has been years since I used it.

I'm pretty sure one could just snarf 2011.0 Mythtv srpm packages and rebuild/install on Mageia as the deps are ~identical, although I am not sure if that would be politically correct, it would work fine.

You'd have to make your "version" more recent, but that's set in the spec file.

Hopefully the maintainer on Mageia will have the time to do it RSN...
Comment 4 Greg McGee 2011-09-09 11:22:12 CEST
BTW, I ran into some tuner trouble (not tuning) on 2011, but IIRC I had the same issue initially on 2010.1/2, I have simply forgotten the fix ;-)

There's also the whole mythbackend-needs-to-be-setuid-root thing that hopefully can be fixed with proper packaging.
Comment 5 Colin Guthrie 2011-09-09 11:32:27 CEST
Sorry I kinda dropped the ball a bit here.

I will push packages to updates_testing for the latest fixes branches of MythTV over the weekend.

I didn't get any feedback as to whether the above mentioned patch will fix things, but I guess it should.

Has someone updated mythtv in Mandriva since I stopped? .... checks... nope, they are 6months old, so will likely have the same problem. Mageia package should be slightly newer IIRC.

Anyway, I'll update them this weekend and include the patch I mentioned in comment 1.

Comment 6 Greg McGee 2011-09-09 11:50:11 CEST
The VL1/2 issue is the same issue, good they fixed it in upstream.

it IS working in 2011 (probably pulled from PLF)

Thank you for fixing this, it's the showstopper for my migration.
(And probably others)
Comment 7 Colin Guthrie 2011-09-09 12:31:59 CEST
Hmm, PLF package build from the same sources as MDV so I don't think that is it. Didn't mdv stick with a sufficiently old kernel for 2011? Perhaps that's why it works?
Comment 8 Greg McGee 2011-09-10 05:42:23 CEST
Couldn't say anymore, I just nuked it from orbit and am currently hard at installing all needed pkgs for Mageia 1 ;-)

Looks like mythtv-* is still pulling from core... 
Old version still no workee, of course.

They really should make perl-dbd-mysql (or related) a dep for mysql, mysql_setpermission won't run without it. (probably other stuff too)
Comment 9 Colin Guthrie 2011-09-10 12:29:49 CEST
I've got mythtv now in core/updates_testing, so just enable that media and you should get new mythtv and mythplugins builds from the 0.24 fixes branch as of yesterday. Let me know if they work for you and I'll take the steps to make the update official.
Comment 10 Greg McGee 2011-09-10 13:36:25 CEST
Confirm configurable * ,Confirm tuning and recording successfully using ivtv cards ((m179s)

Video display is wonky but that's due to the 1680x1050 display, it requires some further tweaking but BTDT (since <v.13 or something around there)

Stick a fork in it, it's done.... Maybe.

*Worked once IVTV modules and firmware loaded...Had to use FW copied from 2010.2, couldn't locate it but didn't try very long... Might want to see what package v4l-cx2341x-enc.fw and v4l-cx2341x-dec.fw live in... ivtv and tuner modules are built into the kernel. Maybe I missed them... Maybe not.
Comment 11 Greg McGee 2011-09-10 13:38:34 CEST
Profuse thanks, BTW.

Comment 12 Wim Coulier 2011-09-17 11:11:03 CEST
Works without any problem. Great! Thanks to this my server could be migrated to Mageia.
Comment 13 Manuel Hiebel 2011-09-17 23:23:41 CEST
Greg, Vim, on what architecture are you working ?

for QA:

CC: (none) => mageia
Assignee: mageia => qa-bugs

Comment 14 Derek Jennings 2011-09-18 10:55:53 CEST
Confirmed validated on x86_64.
Nice to see the plugins are present and working which were absent in Mageia 1.

There is just one issue I can see. Shouldn't there be a version of Mythtv in the tainted repository with mp3 support? Rather than delay this update perhaps I should raise a new bug report for mp3 support.

CC: (none) => derekjenn

Comment 15 Wim Coulier 2011-09-18 11:48:08 CEST
@ Manuel Hiebel:
I'm using x86_64
Comment 16 Greg McGee 2011-09-18 13:06:11 CEST
I installed from the Mageia1 CD (ONE style) so it's 32 bit.
(on a quad core AMD rig, 64bitness just didn't matter AFAICT, and it makes life easier)

The only "issue" is the firmware for most ivtv cards is missing from the repos and has to be copied over into the /lib/firmware dir..

IIRC it lives in "kernel-firmware-extra" or ivtv-firmware on MDV.

The specific files missing are v4l-cx2341x-enc.fw and v4l-cx2341x-dec.fw
Comment 17 Greg McGee 2011-09-18 13:07:55 CEST
The video resolution issues was just needing to set the display to 16:10, I wish they'd put that stuff all in one menu instead of all over the place. (//end RANDOM GRIPE)
Comment 18 claire robinson 2011-09-18 14:17:18 CEST
Thanks guys for testing that for us, it's difficult to test things like this sometimes that require specific hardware.

Can we call on you again in future updates, would you mind?

You might like to join us in the QA team and test other packages as they are added/updated?

As it's been tested on both architectures this update can now be validated. I've also checked there are no issues with updating.



This update corrects an issue with IVTV cards and newer kernels. V4L1 support has been dropped from the kernel and cards requiring it were not recognised. This was effectively breaking the upgrade from Mandriva 2010.

MythTV has been updated to provide V4L2 support for IVTV cards.




Could somebody from sysadmin please push from core/updates_testing to core/updates.


CC: (none) => eeeemail

Comment 19 claire robinson 2011-09-18 14:18:04 CEST
Ready for pushing, forgot the keywords and CC!

Keywords: (none) => validated_update
CC: (none) => sysadmin-bugs

Comment 20 Greg McGee 2011-09-18 14:27:29 CEST
Minor clarification:
ivtv has supported v4l2 for ages.. as well as v4l.

Mythtv simply was still coded to use the v4l ivtv interfaces...which are obsolete.

I'll happily help any way I can.
Comment 21 claire robinson 2011-09-18 14:51:35 CEST
Thanks for the clarification Greg. How would you write the advisory?

I'll try again..



This update corrects an issue with IVTV cards and newer kernels. V4L1 support
has been dropped from the kernel and cards requiring it were not recognised by MythTV. This was effectively breaking the upgrade from Mandriva 2010.

MythTV was still coded to use V4L1 IVTV interfaces which are now obsolete.


If you'd like to help out with QA Greg, simply add your name to the list at http://www.mageia.org/wiki/doku.php?id=qateam

You should also join the QA mailing lists at https://ml.mageia.org/wwsympa-wrapper.fcgi/lists/qa

There is a slowly growing wiki page at http://www.mageia.org/wiki/doku.php?id=qa_updates

We're also on IRC at irc.freenode.net in #mageia-qa 

Anything you can do or want to do is very welcome :)
Comment 22 Colin Guthrie 2011-09-18 17:44:18 CEST
FWIW, I'll try and have a look at the tainted build very soon :)
Comment 23 D Morgan 2011-09-18 17:59:25 CEST
(In reply to comment #22)
> FWIW, I'll try and have a look at the tainted build very soon :)

so we don't push on updates yet ?

CC: (none) => dmorganec

Comment 24 Colin Guthrie 2011-09-18 19:46:36 CEST
Should be ready soon. It's exactly the same build as the current one in testing, but with the tainted stuff turned on. It was a straight update of the previous PLF stuff, so nothing crazy.

With this in mind, I'd just hold of until the packages are there (any major issue notwithstanding, it should be a couple hours) then do the update including the tainted pkgs. Seem sensible?
Comment 25 claire robinson 2011-09-18 19:50:14 CEST
Does this add any requires from release media? If so it will probably be affected by bug 2317. Any added requires will need to be linked from release to updates.
Comment 26 Colin Guthrie 2011-09-18 20:02:09 CEST
No additional requires from release media. faac is a new dep needed which I had to push to tainted/updates_testing so it'll need to be included too. Other than that it's the same as the non-tainted stuff. Main package has built on one arch now, just wait for that to complete and then I'll submit the mythplugins tainted build too. Will ping here when all is uploaded (should be in an hour max)
Comment 27 Colin Guthrie 2011-09-18 20:20:02 CEST
OK, all is ready.

As said above, I had to upload "faac" (src rpm name) to tainted/updates_testing to satisfy build requirements. It was already in the system, but had just never been submitted (probably from before tainted was properly setup.

I've not touched the versions that have been tested but they wouldn't have changed anyway, so no biggie IMO - But I can bump subrel and submit them if needed.

/me is off for the night :)
Comment 28 Manuel Hiebel 2011-09-18 21:04:38 CEST
for faac we have a bug report: bug 1730
Comment 29 claire robinson 2011-09-20 13:25:27 CEST
Greg are you able to test this Tainted version too please?

It is in Tainted Updates Testing this time and should also download libfaac. If possible could you check it with an faac file too, that way we can validate it aswell.

CC: (none) => gjmcgee

Comment 30 Derek Jennings 2011-09-21 14:26:36 CEST
Tainted Validated on x86_64
verified faac operation with transcode to mpeg-4
Comment 31 Nicolas Vigier 2011-09-23 21:46:44 CEST
As faac had to be removed from the repository, I think mythtv needs to be rebuilt without faac.

Keywords: validated_update => (none)
CC: (none) => boklm
Assignee: qa-bugs => mageia

Samuel Verschelde 2011-10-07 23:57:37 CEST

CC: (none) => qa-bugs, stormi

Comment 32 claire robinson 2011-10-15 12:06:11 CEST
What is the status of this update please?
Comment 33 Greg McGee 2011-10-15 23:52:17 CEST
There is still come issue concerning the build re: faac, and the firmware is missing still last I checked... might need pushed to "updates".

I consider it "fixed" and it should be closed, the firmware has its own bug report and the faac/build/push issue are really unrelated.

The push to updates is still needed, so it cannot be closed.
Comment 34 Samuel Verschelde 2011-10-18 17:25:58 CEST
Colin, if the update is ready to be tested by QA team (including a tainted version that doesn't use faac, following the decision about this package), please assign to qa-bugs@ml.mageia.org and will pass it through the update validation process.
Comment 35 Colin Guthrie 2011-10-19 23:24:13 CEST
Ahhhrg!!! Sorry, I suck. Pushed new builds just now to core+tainted/updates_testing for your viewing pleasure! Last couple pkgs just winding their way through the BS now but there shouldn't be any problems.
Comment 36 Dave Hodgins 2011-10-25 21:47:13 CEST
I can't help with the testing for this one.

Just a ping to remind everyone the non-faac version
is ready for testing in both core and tainted updates

CC: (none) => davidwhodgins

Comment 37 Derek Jennings 2011-10-26 21:33:44 CEST
mythtv-0.24.1-20111019.0.1.mga1.tainted.src.rpm  checks out OK on x86_64
Comment 38 Colin Guthrie 2011-10-29 14:01:26 CEST
Also tested tainted on i586.
Comment 39 Greg McGee 2011-10-30 07:50:21 CET
Still working for me in i586 as well.
Comment 40 Dave Hodgins 2011-11-21 02:26:42 CET
Validating the update

Could someone from the sysadmin team push the srpms


from Core Updates Testing to Core Updates and the srpms


from Tainted Updates Testing to Tainted Updates

This update corrects an issue with IVTV cards and newer kernels. V4L1 support
has been dropped from the kernel and cards requiring it were not recognised by
MythTV. This was effectively breaking the upgrade from Mandriva 2010.

MythTV was still coded to use V4L1 IVTV interfaces which are now obsolete.


Keywords: (none) => validated_update

Comment 41 Thomas Backlund 2011-11-22 10:19:11 CET
Update pushed.

CC: (none) => tmb
Resolution: (none) => FIXED

Nicolas Vigier 2014-05-08 18:06:22 CEST

CC: boklm => (none)

Note You need to log in before you can comment on or make changes to this bug.