Bug 18024 - Plasma 5 Telepathy - Impossible to configure any accounts
Summary: Plasma 5 Telepathy - Impossible to configure any accounts
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal major
Target Milestone: Mageia 8
Assignee: KDE maintainers
QA Contact:
Depends on:
Blocks: 17523
  Show dependency treegraph
Reported: 2016-03-17 08:40 CET by Jüri Ivask
Modified: 2020-10-29 12:20 CET (History)
6 users (show)

See Also:
Source RPM: telepathy
Status comment: Multiples SRPM for telepathy

ktp-contctlist run backtrace from konsole (9.84 KB, text/x-log)
2016-03-21 13:40 CET, Jüri Ivask
result running "strace -o strace_ktp-contactlist ktp-contactlist" (253.95 KB, application/zip)
2016-05-06 09:46 CEST, Jüri Ivask
result running "gdb ktp-contactlist %u" (2.54 KB, application/zip)
2016-05-06 09:54 CEST, Jüri Ivask

Description Jüri Ivask 2016-03-17 08:40:58 CET
Description of problem: Currently it is impossible to configure Jabber or IRC accounts in Plasma 5 desktop Telepathy

Version-Release number of selected component (if applicable):15.12.3

Steps to Reproduce:
1. Want to start using instant messeging in Plasma 5 desktop using Telepathy framework, especially jabber and irc protocols. These are provided by telepathy-gabble and telepathy-idle packages:
urpmi --no-recommends telepathy-gabble telepathy-idle
2. Hmm, probably some other package is needed to start configuring accounts - kcm package could be a good candidate:
urpmi --no-recommends telepathy-kde-accounts-kcm
2. Still nothing in Plasma applications menu and in Systemsettings -> Network, maybe installing the Plasma applets package does the trick:
urpmi --no-recommends telepathy-kde-desktop-applets
3. Now, there is Instant Messageing Contacts and according Logviewer items in Plasma applications menu and also Instant messageing widgets for desktop and System Tray -> System Dock (still nothing in Systemsettings).
4. Now, when trying to add an account - error message, that kaccounts-integration package is missing:
urpmi --no-recommends kaccounts-integration
5. Now also corresponding item appeared in Systemsettings -> Network. But when trying to add/configure an existing Jabber account and filling according fields - just nothing happens, the configuration window just disappears without any outcome.
6. The possibility to add/configure IRC account is missing altogether.
Comment 1 Jüri Ivask 2016-03-17 10:40:11 CET
Sorry, version-release number is 15.12.2, no 15.12.3 yet...
David Walser 2016-03-17 21:19:49 CET

Assignee: bugsquad => mageia

Comment 2 Jüri Ivask 2016-03-21 11:35:13 CET
The same situation in fresh 15.12.3...
Comment 3 Jüri Ivask 2016-03-21 13:40:37 CET
Created attachment 7588 [details]
ktp-contctlist run backtrace from konsole

Backtrace when starting the IM Contacts application from the konsole, trying to associate with two existing jabber accounts and finally closing the window followed by the segfault.
Comment 4 Jüri Ivask 2016-03-23 09:31:44 CET
I guess, this is something specific to Mageia, as when tested in KaOS live session (qt5.6; kf5.20; Plasma5.6; applications 15.12.3) I was able to configure my jabber account and connect to it successfully.
Tried to find some possibly missing dependency packages in Mageia, but no success so far...
Comment 5 Jüri Ivask 2016-05-05 15:54:02 CEST
The situation seems to be the same with fresh upgrade to kde apps 16.04
Comment 6 Jüri Ivask 2016-05-06 09:46:37 CEST
Created attachment 7752 [details]
result running "strace -o strace_ktp-contactlist ktp-contactlist"
Comment 7 Jüri Ivask 2016-05-06 09:54:39 CEST
Created attachment 7753 [details]
result running "gdb ktp-contactlist %u"
Nicolas Lécureuil 2016-05-06 10:36:50 CEST

Blocks: (none) => 17523

Comment 8 Jüri Ivask 2016-05-06 11:27:16 CEST
Thanks to sander85 for debugging help:)
It seems that both signon and signond packages should be installed to get telepathy to create at least jabber accounts.
So I guess they should be a dependency for some telepathy package...
Comment 9 Nicolas Lécureuil 2016-07-17 00:40:34 CEST
should be fixed, can you confirm ?
Comment 10 Jüri Ivask 2016-07-19 21:54:42 CEST
Unfortunately not. Package signond is still not insatalled as a require and without that no connection will be made with a xmpp server...
Comment 11 Otto Leipälä 2016-07-21 15:13:12 CEST
What telepathy-kde packages have you installed. ?
urpmq --whatrequires lib64signon-extension1
So kaccounts-integration need lib64keyring-kwallet15 requires signond,you are missing some packages what should be installed.

@neoclust should those telepathy-kde packages be recommend by task-plasma5,would cause less problems to install them. ?

CC: (none) => ozkyster

Comment 12 Nicolas Lécureuil 2016-07-21 16:06:57 CEST
i just added it. If it helps :)
Comment 13 Nicolas Lécureuil 2016-07-26 15:42:46 CEST
is this bug fixed ?
Comment 14 Jüri Ivask 2016-07-29 06:13:24 CEST
Unfortunately not. Signond can be removed by "urpme signond", it not required by any installed telepathy package.

There is still no possibility to create a IRC account when telepathy-idle package is installed.
Comment 15 Nicolas Lécureuil 2016-07-29 12:17:29 CEST
Requires added in telepathy-kde-common-internals

Resolution: (none) => FIXED

Comment 16 Sander Lepik 2016-07-29 14:39:09 CEST
telepathy-kde-common-internals contains no files, so there is no such package and those requires don't quite work :)

Hardware: i586 => All
CC: (none) => mageia
Resolution: FIXED => (none)

Comment 17 Nicolas Lécureuil 2016-07-29 14:52:46 CEST
thanks; i think i need to sleep more ;) 

I added them in the core package.

Resolution: (none) => FIXED

Comment 18 Jüri Ivask 2016-08-01 14:17:30 CEST
Sorry for the mess about telepathy-idle & IRC.

It seems that as there are many quality kde/qt IRC clients, then the development of telepathy-idle has stopped about 2 years ago.

So I guess that it is a good idea to remove telepathy-idle as a dependency from the telepathy-kde-common-internals-core package as it does not add the ability to configure IRC account anyway and giving users a possibility not to install it at all...

Resolution: FIXED => (none)

Samuel Verschelde 2016-08-25 16:24:46 CEST

Assignee: mageia => kde

Comment 19 Sébastien B. 2016-12-30 11:56:08 CET

I reproduce under Cauldron, the bug.

No Jabber connection possible, despite a correct configuration of the account, and server.



CC: (none) => vigenmailbox

Christoph Holz 2017-03-31 23:08:10 CEST

CC: (none) => christoph.holz

Comment 20 Jüri Ivask 2017-05-02 13:56:05 CEST
The Jabber (XMPP) part of telepathy (telepathy-gabble) has not seen updates for years (except the wocky part) and probably is currently unable to connect to recent xmpp servers any more due to recent security needs. Not to speak supporting nowadays basic xep's like message carbons or message archive management...
Comment 21 Aurelien Oudelet 2020-10-29 12:02:37 CET
I would like to say that telepathy is a total mess.
Default Cauldron installation with Plasma.

$ rpm -qa | grep telepathy

Under telepathy-kde-accounts-kcm-20.08.2, I really can't configure several proposed account-types:
- IBM Sametime
- Gadu-Gadu
- Yahoo! Messenger
- Generic ?? IRC?
- OpenDesktop
- Bonjour/Salut
- Skype
- Office 365/Lync libpurple
- Office 365/lync
- Telegram

Clicking on these proposals results of GUI returning to "Add new account" dialog.
See these errors for each time to selecting one in journalctl -f :
systemsettings5[7491]: file:///usr/lib64/qt5/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:65:9: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "maximumWidth"

- jabber
- KDE Talk
These two propose a dialog to enter credentials I don't have. I can't go further.

This barely unusable. Also, telepathy-kde-desktop-applets appears by default on Plasma Panel. Shipping unusable software is not a good idea.
Side note: the Accounts KCM is not translated in French. I don't tested other language.

Is there missing dependencies?

Also, links to website/git or online upstream repos in above packages point to unavailable resources.
[aurelien@mageia ~]$ urpmq -i telepathy-kde-accounts-kcm
Name        : telepathy-kde-accounts-kcm
Version     : 20.08.2
Release     : 1.mga8
Group       : Networking/Instant messaging
Size        : 1861572                      Architecture: x86_64
Source RPM  : telepathy-kde-accounts-kcm-20.08.2-1.mga8.src.rpm
URL         : https://cgit.kde.org/ktp-accounts-kcm.git  <=== unavailable online
Summary     : KControl Module which handles Telepathy Accounts

Workaround for IRC:
For IRC Communications, I can use Konversation.

So, Raising this bug.
Changing targeted milestone.
Added recent commiter for Plasma related packages.

CC: (none) => geiger.david68210, ouaurelien
Target Milestone: --- => Mageia 8
Status comment: (none) => Multiples SRPM for telepathy
Severity: normal => major
Summary: Plasma 5 Telepathy - impossible to configure jabber or irc accounts => Plasma 5 Telepathy - Impossible to configure any accounts
Source RPM: (none) => telepathy

Comment 22 Aurelien Oudelet 2020-10-29 12:20:25 CET
Note also that multiprotocols tools Kopete is also provided upstream under Plasma Applications umbrella and that we ship it but it is not installed by default.

$ sudo urpmi kopete
[sudo] Mot de passe de aurelien : 
Pour satisfaire les dépendances, les paquetages suivants vont être installés :
  Paquetage                      Version      Révision      Arch    
(média « Core Release (distrib1) »)
  jasper                         2.0.22       1.mga8        x86_64  
  kopete                         20.08.2      2.mga8        x86_64  
  kopete-handbook                20.08.2      2.mga8        noarch  (recommandé)
  lib64bcg729_0                  1.0.4        3.mga8        x86_64  
  lib64bcmatroska2_0             0.23         3.mga8        x86_64  
  lib64bctoolbox1                4.4.6        1.mga8        x86_64  
  lib64bzrtp0                    4.4.6        1.mga8        x86_64  
  lib64gadu3                     1.12.2       3.mga8        x86_64  
  lib64glew2.1                   2.1.0        5.mga8        x86_64  
  lib64kopete1                   20.08.2      2.mga8        x86_64  
  lib64kopete_oscar1             20.08.2      2.mga8        x86_64  
  lib64kopete_otr_shared1        20.08.2      2.mga8        x86_64  
  lib64kopete_videodevice1       20.08.2      2.mga8        x86_64  
  lib64kopeteaddaccountwizard1   20.08.2      2.mga8        x86_64  
  lib64kopetechatwindow_shared1  20.08.2      2.mga8        x86_64  
  lib64kopetecontactlist1        20.08.2      2.mga8        x86_64  
  lib64kopeteidentity1           20.08.2      2.mga8        x86_64  
  lib64kopeteprivacy1            20.08.2      2.mga8        x86_64  
  lib64kopetestatusmenu1         20.08.2      2.mga8        x86_64  
  lib64mbedcrypto3               2.16.8       1.mga8        x86_64  
  lib64mbedtls12                 2.16.8       1.mga8        x86_64  
  lib64mbedx509_0                2.16.8       1.mga8        x86_64  
  lib64mediastreamer11           4.4.6        2.mga8        x86_64  
  lib64opengl0                   1.3.2        14.mga8       x86_64  
  lib64ortp15                    4.4.6        1.mga8        x86_64  
  lib64oscar1                    20.08.2      2.mga8        x86_64  
  lib64protobuf-c1               1.3.3        3.mga8        x86_64  
  lib64srtp2_1                   2.3.0        1.mga8        x86_64

Is there any missing libs for telepathy-plasma?

No. This does not function at all. Only for Kopete, which seems it has no further development upstream.

Note You need to log in before you can comment on or make changes to this bug.