Bug 17398 - Update request: virtualbox-5.0.12-1.mga5
Summary: Update request: virtualbox-5.0.12-1.mga5
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 5
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
Whiteboard: MGA5-32-OK MGA5-64-OK advisory
Keywords: validated_update
Depends on: 17397
  Show dependency treegraph
Reported: 2015-12-25 13:41 CET by Thomas Backlund
Modified: 2016-01-11 11:50 CET (History)
3 users (show)

See Also:
Source RPM: virtualbox
Status comment:


Description Thomas Backlund 2015-12-25 13:41:00 CET
New virtualbox to test




Advisory will follow....


Steps to Reproduce:
Thomas Backlund 2015-12-25 13:42:17 CET

Depends on: (none) => 17397

Comment 1 James Kerr 2015-12-30 18:18:47 CET
Testing on mga5-64

Already installed (Bug 17397 comment 7):
- virtualbox-kernel-4.1.15-desktop-1.mga5-5.0.12-1.mga5
- virtualbox-kernel-desktop-latest-5.0.12-1.mga5
Installed from testing:
- virtualbox-5.0.12-1.mga5.x86_64

Virtualbox launched normally and XP VM runs normally

OK for MGA5-64 as tested
Comment 2 Len Lawrence 2015-12-30 18:33:26 CET
mga5  x86_64  Mate

Installed most of the updates after ecupdt and mageiaUpdate.  Installed a couple of them manually and launched virtualbox manager.  Booted mga5::i386 and installed virtualbox-guest-additions from Updates Testing.

Had to drag the screen to the preferred size ( vbox always complains that it cannot reset the CRTC or some such).

It appears to be fully functional apart from not recognizing USB3.0 (not supported yet AFAIK).  Logged in to another machine on the network.  Cannot check bluetooth on this vm because the adapter is plugged into a USB3.0 port.

CC: (none) => tarazed25

Comment 3 Thomas Backlund 2015-12-30 23:28:39 CET
For the display issue, did you install the x11-driver-video-vboxvideo-5.0.12-1.mga5 on the client ?

For usb2/3 support, you must install the matching extension pack:

Comment 4 Len Lawrence 2015-12-31 12:07:21 CET
Thanks Thomas; shall check those points later.
Comment 5 Len Lawrence 2015-12-31 12:37:55 CET
Yes, I do have the correct vboxvideo driver installed.  However, there is an error when trying to install the Oracle extension pack via virtualbox.  From what I remember that always happens.

Result Code: 
NS_ERROR_FAILURE (0x80004005)
IExtPackManager {edba9d10-45d8-b440-1712-46ac0c9bc4c5}
Comment 6 Len Lawrence 2015-12-31 14:57:31 CET
I also tried downloading the extension pack inside the guest; this gives one option - save the file.
Comment 7 Thomas Andrews 2016-01-07 02:12:31 CET
Testing on mga5 64-bit

Packages installed: See Bug 17397 Comment 14
Also downloaded and installed extension pack using VirtualBox/File/Check For updates and updated guest additions and X11 driver in Mageia 5 32-bit guest.

Mageia guest seems to be functioning as expected. Still need to get guest additions for a Windows XP guest, but no problems anticipated.


ASRock AM2+ motherboard, Athlon X2 7750 processor, nVidia 9800GT video card.

CC: (none) => andrewsfarm

Comment 8 Thomas Andrews 2016-01-07 22:06:07 CET
Windows XP guest with new guest additions also working OK.

Whiteboard: (none) => 64-bit OK Mageia5 32-bit guest OK

Comment 9 Len Lawrence 2016-01-08 01:39:36 CET
mga5  x86_64  Mate

Been running my i586 mga5 guest on this for a while now, testing 32-bit updates as well.  However, as before, when I try to install the Oracle extension pack it fails.  This is in the guest system - still confused about where these components belong.  The downloader asks about saving or installing via virtualbox.  I chose the virtualbox install.  What is the correct procedure?
Comment 10 Len Lawrence 2016-01-08 01:43:42 CET
Sorry, I am still confused.  It was downloaded on the host and installed (or not) by virtualbox.  In the guest it is saved as a bin file; how to install that?
Comment 11 James Kerr 2016-01-08 03:24:10 CET
The proprietary Extension pack should be installed only on the host system.


(The appropriate Guest Additions should be installed in each guest system.)
Comment 12 Thomas Andrews 2016-01-08 03:34:02 CET
(In reply to Len Lawrence from comment #9)
> mga5  x86_64  Mate
> Been running my i586 mga5 guest on this for a while now, testing 32-bit
> updates as well.  However, as before, when I try to install the Oracle
> extension pack it fails.  This is in the guest system - still confused about
> where these components belong.  The downloader asks about saving or
> installing via virtualbox.  I chose the virtualbox install.  What is the
> correct procedure?

The extension pack is installed into VirtualBox from the host. If there is an old one already installed, it needs to be removed before the new one will install. The simplest way to do this, in my limited experience, is this:

1. Download the extension pack tarball.
2. As root, use the command 

VBoxManage extpack install --replace <tarball>

 where "<tarball>" is the path to wherever you downloaded it. The "replace" option is supposed to remove the old pack before attempting to install the new one.
Comment 13 Thomas Andrews 2016-01-08 03:40:44 CET
MGA5 32-bit, server kernel

I created a virtual Mageia 5 machine on my 32-bit install, then updated to this version. All seems OK.

ASRock motherboard, Athlon X2 7750 processor, 8GB RAM.

Whiteboard: 64-bit OK Mageia5 32-bit guest OK => 64-bit OK Mageia5 32-bit guest OK 32-bit virtualbox OK

Comment 14 Len Lawrence 2016-01-09 01:31:07 CET
@Thomas Andrews - comment #12
Thanks Thomas for "as root".

[lcl@vega ~/Downloads]$ VBoxManage list extpacks
Extension Packs: 1
Pack no. 0:   Oracle VBoxDTrace Extension Pack
Version:      5.0.12_OSE
Revision:     104815
Description:  Experimental and unsupported extension pack providing DTrace features to VirtualBox.
VRDE Module:  
Usable:       true 
Why unusable: 

Tried a couple of approaches but always failure.

It turned out that "as root" was essential.  I had been fooled by starting as a user and supplying the root credentials on demand.  I guess it has something to do with the root & bash environment.

[root@vega Downloads]# VBoxManage extpack install --replace Oracle_VM_VirtualBox_Extension_Pack-5.0.12-104815.vbox-extpack
Successfully installed "Oracle VM VirtualBox Extension Pack".
Comment 15 Len Lawrence 2016-01-09 02:56:55 CET
However the VM still cannot see any USB devices on the host.  I closed down the machine and used virtualbox settings manager to enable xhci emulation and define a profile for an attached USB drive, right down to the serial number.  No sign of it.  Rebooted the VM - no USB devices.
Comment 16 claire robinson 2016-01-09 13:25:00 CET
You possibly haven't added your user on the host to the vboxusers group yet Len. After adding, log out and back in again.
Comment 17 James Kerr 2016-01-09 15:03:40 CET
FWIW, the only VM that I have is Windows XP pro 32bit running on a mga5-64 host. I don't really need USB support, but as a test, I installed the Extension pack, using the Vbox Manager GUI. (I had previously added my user to the vboxusers group and updated the guest additions.)

I enabled USB2 support in the VM's Settings and when I launched the VM, Windows announced that it had found new hardware, a USB hub, and installed the required software.

In the Vbox Manager toolbar, Devices - USB, all of the USB devices on the host were listed. I selected the printer and Windows immediately began the driver installation process.

The printer is fully operational in the VM.

So for me it all works on mga5-64.

In the past, when I've had problems with the Extension pack, I've deleted /usr/lib64/virtualbox/ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/
 and then installed the Extension Pack. I don't necessarily recommend that approach, but IIRC it did work for me.
Comment 18 Rémi Verschelde 2016-01-09 16:11:18 CET
Testing on Mageia 5 64-bit host with a Cauldron 32-bit VM, seems to work fine.
Comment 19 James Kerr 2016-01-09 17:03:49 CET
I've also set up a mga5-32 guest (XFCE). I installed the following packages from testing:

- kernel-desktop-4.1.15-1.mga5-1-1.mga5.i586
- vboxadditions-kernel-4.1.15-desktop-1.mga5-5.0.12-1.mga5.i586
- vboxadditions-kernel-desktop-latest-5.0.12-1.mga5.i586
- virtualbox-guest-additions-5.0.12-1.mga5.i586
- x11-driver-video-vboxvideo-5.0.12-1.mga5.i586

All of the USB devices on the host are listed in Devices - USB. 
I selected my printer from the list, installed the driver using scp and printed a test page.

So it works for me with a mga5-32 guest on a mga5-64 host.
Comment 20 Len Lawrence 2016-01-09 17:21:17 CET
@claire #16
Yes, I had added myself to the vboxusers group.  Checked it with id.  But, probably did not logout and login.  Thanks Claire.

@James #17
It does look like I might have to clear everything out and try again.  The system does seem to be sensitive to clutter.
Comment 21 Len Lawrence 2016-01-10 15:56:26 CET
Solved.  There was a mismatch between the host and guest kernels, both 4.1.15, but one desktop and the other tmb.  Brought them into line and USB3.0 appeared.
This update is good for me.
Comment 22 Thomas Backlund 2016-01-10 21:07:37 CET
Fixed whiteboard tags

Advisory (also added to svn):

  This update provides the virtualbox 5.0.12 maintenance release.
 - https://bugs.mageia.org/show_bug.cgi?id=17398
 - https://www.virtualbox.org/wiki/Changelog

Whiteboard: 64-bit OK Mageia5 32-bit guest OK 32-bit virtualbox OK => MGA5-32-OK MGA5-64-OK advisory

Comment 23 David Walser 2016-01-11 02:42:05 CET
Tested Mageia host and guest and Mageia host with just about every OS known to man as a guest, Mageia 5 i586, all OK.  Validating now.

CC: (none) => sysadmin-bugs
Keywords: (none) => validated_update

Comment 24 Mageia Robot 2016-01-11 11:50:13 CET
An update for this issue has been pushed to Mageia Updates repository.


Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.