Bug 17343 - Plasma5 gives nothing but a black screen on a system with old SiS video chip
Summary: Plasma5 gives nothing but a black screen on a system with old SiS video chip
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: KDE maintainers
QA Contact:
Keywords: UPSTREAM
Depends on:
Blocks: 17523
  Show dependency treegraph
Reported: 2015-12-16 21:14 CET by Marja Van Waes
Modified: 2017-03-14 16:40 CET (History)
2 users (show)

See Also:
Source RPM:
Status comment:

journalctl of trying to start Plasma5 from sddm (30.79 KB, text/plain)
2015-12-16 21:14 CET, Marja Van Waes
xsession-errors of newly created user (25.14 KB, text/plain)
2015-12-16 21:37 CET, Marja Van Waes

Description Marja Van Waes 2015-12-16 21:14:12 CET
Created attachment 7283 [details]
journalctl of trying to start Plasma5 from sddm

on this system:

Plasma5 seems to start fine with the Mageia boot screen and bubbles, but by the time it should reach the Desktop the screen turns black.

When I do alt+del+backspace I do very shortly see a fragment of the Plasma5 desktop with its very bright colors (so not of the Mga background).

/var/log/Xorg.0.log showed the same error as when I boot into a working XFCE, only:
   [   956.831] (EE) AIGLX: reverting to software rendering

In the attached log, there is:

   kscreen.xcb.helper: Event Error:  147

(don't know what that means)
and many repeated:

org.kde.KScreen[4346]: kscreen: Primary output changed from KScreen::Output(Id: 635 , Name: "default" ) ( "default" ) to KScreen::Output(Id: 635 , Name: "default" ) ( "default" )

(looks like no change to me ;-) )

later, there is: 

Dec 16 19:48:05 localhost org.a11y.atspi.Registry[4412]: XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
Dec 16 19:48:05 localhost org.a11y.atspi.Registry[4412]: after 41 requests (41 known processed) with 0 events remaining.


Dec 16 19:48:05 localhost kernel: kactivitymanage[4498]: segfault at 7fdb5cc31cd0 ip 00007fdb405f1e61 sp 00007ffe92acee28 error 4 in libQt5Sql.so.5.5.1[7fdb405de000+3e000]


Dec 16 19:48:05 localhost org.kde.kglobalaccel[4346]: The X11 connection broke (error 1). Did the X11 server die?

I should have filed this report ages ago, when KDE4 was dropped in cauldron, sorry for being so late.

And before filing this report, I should again have tried with a fresh user... with a different user two months ago, I did get to the Plasma5 desktop, but then it turned black on the first action (clicking anywhere).

I'll create a new user and try again within an hour (so not assign this bug, yet)
Comment 1 Marja Van Waes 2015-12-16 21:28:30 CET
with a brand new user, Plasma5 comes up nicely, but, like two months ago, clicking on anything immediately results in a black screen.

I tried to attach xsession-errors, but somehow that didn't work, will try again later.

Assignee: bugsquad => mageia

Comment 2 Marja Van Waes 2015-12-16 21:37:23 CET
Created attachment 7284 [details]
xsession-errors of newly created user

Oops, I should have changed the permissions on that file, no wonder I couldn't attach it
Rémi Verschelde 2016-01-19 10:23:00 CET

Blocks: (none) => 17523

Comment 3 Ben McMonagle 2016-02-10 23:14:48 CET
black screen valid for Mageia-6-dev1-x86_64-DVD.iso
DATE.txt: Tue Feb  2 22:58:36 CET 2016.

scroll mouse works fine tho

now, Mageia Welcome launches as expected, alt + F2 invokes run dialogue

CC: (none) => westel

Comment 4 Ben McMonagle 2016-02-10 23:17:43 CET
oops, meant to add:

intel core i5 processor
Card:Intel 810 and later
Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller
Nicolas Lécureuil 2016-04-23 09:07:33 CEST

Keywords: (none) => UPSTREAM

Comment 5 Nicolas Lécureuil 2016-07-17 00:35:29 CEST
is this bug still valid under Plasma 5.7.1 ?
Samuel Verschelde 2016-08-25 16:22:59 CEST

Assignee: mageia => kde

Comment 6 Nicolas Lécureuil 2017-03-14 16:40:58 CET
No answers, please reopen if still valid.

CC: (none) => mageia
Resolution: (none) => OLD

Note You need to log in before you can comment on or make changes to this bug.