Bug 17123 - KDE sessions sometimes do not start properly, causing logout and other things to not work
Summary: KDE sessions sometimes do not start properly, causing logout and other things...
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 5
Hardware: i586 Linux
Priority: Normal major
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA5-64-OK MGA5-32-OK advisory
Keywords: validated_update
Depends on:
Blocks: 19064 16847 19533
  Show dependency treegraph
 
Reported: 2015-11-10 20:50 CET by David Walser
Modified: 2017-09-20 09:15 CEST (History)
11 users (show)

See Also:
Source RPM: kdelibs4-4.14.5-1.1.mga5.src.rpm
CVE:
Status comment:


Attachments
kdelibs-4.14.5-klauncher-no-glib.patch (814 bytes, patch)
2015-11-10 20:51 CET, David Walser
Details | Diff
List of packages for mga5-64 (12.30 KB, text/plain)
2017-08-21 17:47 CEST, James Kerr
Details
List of packages for mga5-32 (12.27 KB, text/plain)
2017-08-21 18:11 CEST, James Kerr
Details

Description David Walser 2015-11-10 20:50:41 CET
Seemingly randomly, some KDE sessions in Mageia 5 have some quirks where some things don't work.  The most obvious visual indicator of this is Klipper not running.  Trying to log out of KDE does nothing, and the easiest way out at this point is Ctrl-Alt-Backspace to kill X.

Giuseppe Ghibo located a patch that he says appears to fix this issue, which I'll attach.  He included the following bug URLs as references:
https://bugs.kde.org/328571
https://bugzilla.redhat.com/show_bug.cgi?id=983110

Reproducible: 

Steps to Reproduce:
David Walser 2015-11-10 20:51:02 CET

CC: (none) => ghibomgx, lmenut

Comment 1 David Walser 2015-11-10 20:51:45 CET
Created attachment 7195 [details]
kdelibs-4.14.5-klauncher-no-glib.patch
Comment 2 David Walser 2015-11-10 20:57:55 CET
It might also be good to pull the latest KDE4 bugfixes from upstream (hopefully including a fix for Bug 16847 somewhere), such as:
kde-workspace 4.11.22 (from KDE Applications 15.8.0)
kdepim, kdepimlibs, kdepim-runtime 4.14.10 (from KDE Applications 15.04.3)
kdelibs 4.14.14 (from KDE Applications 15.08.3)
Comment 3 David Walser 2015-11-10 20:58:47 CET
I doubt it's related to either of these issues, but the patch kdelibs-fix-containment.patch in kdelibs4 looks bogus.
Florian Hubold 2015-11-10 21:22:31 CET

CC: (none) => doktor5000

Comment 4 Florian Hubold 2015-11-10 21:33:53 CET
FWIW, if one of you can reliably reproduce, could you try if something like

killall kded4; sleep 2; kded4 & disown

run as normal user works as a workaround, to obtain a normal session?
Comment 5 Giuseppe Ghibò 2015-11-10 23:03:28 CET
FYI, killall kded4; sleep 2; kded4 & disown doesn't give a working normal session. Note that under that conditions the command:

qdbus org.kde.ksmserver /KSMServer logout 0 0 0

hasn't any effect, as well as the shortcut keys "Ctrl+Alt+Del" which under normal session do a logout. The kmix process is also running.
David Walser 2015-12-30 19:04:06 CET

CC: (none) => luigiwalser

Comment 6 David Walser 2016-01-23 02:05:10 CET
With much help from Giuseppe, I have made commits to update kdelibs4 to 4.14.16 and kdebase4-workspace to 4.11.22.

Nicolas, can you:
- review my commit to updates/5/kdelibs4
- review my 2 commits to updates/5/kdebase4-workspace
- check kdelibs4/SOURCES/kdelibs-fix-containment.patch which looks bogus

We can update both of those in this bug and update the kdepim ones in another bug.
Comment 7 David Walser 2016-02-17 02:04:40 CET
FYI, kdelibs 4.14.17 is now available upstream.

CC: (none) => rverschelde

Comment 8 David Walser 2016-03-18 19:46:17 CET
kdelibs4 4.14.18 is now checked into SVN.  I was still hoping to get some feedback here, especially from Nicolas about kdelibs-fix-containment.patch, but I'll push these soon if I don't hear anything.
Comment 9 Florian Hubold 2016-03-19 10:42:45 CET
FWIW, running 4.14.17 and kdebase4-workspace-4.11.22 since over a month now and didn't see any issues, but somehow forgot about this, sorry. I've added a patch locally resulting from https://bugs.kde.org/show_bug.cgi?id=340915 and would like to add another one to prevent delays like reported via https://bugs.kde.org/show_bug.cgi?id=328772.

Please ping me on irc before pushing :)
Comment 10 David Walser 2016-03-19 14:27:35 CET
Florian, please add your patches in SVN.  I plan to push on Monday.
Comment 11 Rolf Pedersen 2016-05-31 16:20:27 CEST
(In reply to David Walser from comment #0)
> Seemingly randomly, some KDE sessions in Mageia 5 have some quirks where
> some things don't work.  The most obvious visual indicator of this is
> Klipper not running.  Trying to log out of KDE does nothing, and the easiest
> way out at this point is Ctrl-Alt-Backspace to kill X.
> 
> Giuseppe Ghibo located a patch that he says appears to fix this issue, which
> I'll attach.  He included the following bug URLs as references:
> https://bugs.kde.org/328571
> https://bugzilla.redhat.com/show_bug.cgi?id=983110
> 
> Reproducible: 
> 
> Steps to Reproduce:

This type of issue comes and goes for me, just recently it's come again.

Visible problems are that kmix doesn't start and none of the methods for KDE "Leave" menu do anything:  Lock/Logout applet, right-click desktop -> Leave, or K launcher menu -> Leave.

Ctrl-Alt-Backspace ZAP reliably restores this functionality upon the new login.

Over time, I've come to create desktop icons to deal with this:

Name:  killall ksmserver  Command:  killall ksmserver
Name:  Halt  Command:  halt -p

which is not ideal and I've come here after searching bugzilla.  On the way, I've encountered the referenced kde bug 328571, where I noticed another MGA5 user participating and some hopeful report of a patch in KDE 5.15, as I understand it:  https://bugs.kde.org/show_bug.cgi?id=328571#c61

I see KDE Version 4.14.5 on my up-to-date MGA5 stable installation.  Has the patch from 328571 been incorporated/can I install something to test?

Thanks.

CC: (none) => rolfpedersen

Comment 12 David Walser 2016-05-31 17:13:04 CEST
Rolf, I see the exact same symptoms as you.  We have something in SVN, but it hasn't been pushed to the build system.  I believe Florian wanted to add a patch first.  We are way overdue to get this built.
Comment 13 Giuseppe Ghibò 2016-05-31 18:31:28 CEST
Dear David, indeed the package in http://svnweb.mageia.org/packages/updates/5/ for kdebase4-workspace-4.11.22-1 doesn't build properly (there ware a couple of glitches in the order of patches plus one patch Patch322 that need to be reworked, I did that too, and one patch that need to be removed). I've fixed and to me seems working fine. I've just to find the time to merge in the svn, as I'm just back (probably hope during this weekend). Impatient people can download kdebase4-workspace from here:

http://www.joeghi.com/joeghi_backports_mga5/SRPMS/kdebase4-workspace-4.11.22-0.3.mga5.src.rpm

which contains already the fixed patches.

and build in the following order:

1) download from here:

http://svnweb.mageia.org/packages/updates/5/

and build in the following order (I found that not following these order even if BuildRequires is satisfied with older libraries at some point build fails):

1a) kdepimlibs4-4.14.10-1.mga5.src.rpm, then build and install devel binaries of it

1b) kdepim4-runtime-4.14.10-1.mga5.src.rpm, then build and install devel binaries of it, to build the next package.

1c) kdelibs4-4.14.19-1.mga5.src.rpm, then install the development libraries.

and finally build the kdebase4-workspace-4.11.22-0.3.mga5.src.rpm's packages. (I've bumped to 4.1.22-0.3, so that the official package will have 4.1.22-1.mga5 and could overlap).

This result should be like this (*beware* these are unsigned packages, so better to get the patched src.rpm and compile yourself):

http://www.joeghi.com/joeghi_backports_mga5/kdepkgs.tar.gz
Comment 14 Rolf Pedersen 2016-06-11 14:45:28 CEST
I made a local repository from http://www.joeghi.com/joeghi_backports_mga5/kdepkgs.tar.gz, generated an hdlist and did

# urpmi.addmedia ghibo /download/mageia/5/201605-ghibo-kde-build/kdepkgs/RPMS/x86_64
# urpmi  --no-verify-rpm --media ghibo --auto-select

That was on June 2, about 9 days ago.  With a typical 2 boots every day, there has been no problem with kmix or Leave and no other new problem that I can see, FWIW.

Thanks!
Morgan Leijström 2016-06-11 21:16:56 CEST

CC: (none) => fri

Comment 15 David Walser 2016-06-16 19:58:50 CEST
Giuseppe, looking at the patches you swapped in/out (322-3,414-5), it doesn't look right.  It should get the min UID from login.defs, but even if that's set to 1000, we need the heuristics to make it show valid normal users in the 500-999 range.  It doesn't appear that will work with your changes.

I guess you must have also made some adjustments in those patches to make patch 301/416 apply, since you didn't change the actual patch.  Probably the better thing to do here would be to not make any of the changes you made, but to just rediff patch 301.
Comment 16 James Kerr 2016-06-19 10:50:45 CEST
I experienced this bug frequently (on more than 50% of startups) on an older system using the nvidia proprietary driver. (Much less frequently on another installation on the same hardware using the nouveau driver.)

Last weekend, I installed the packages linked to in comment#13, using a procedure similar to that described in comment#14.

I have booted/restarted this installation 2 or 3 times each day this week. There has been no recurrence of the bug and everything else seems to be working normally. So at least on this installation these packages seem to fix the bug.

Normal user UID's start at 1000 on this system and so I have not experienced the problem described in comment#15.

CC: (none) => jim

Samuel Verschelde 2016-08-25 16:22:40 CEST

Assignee: mageia => kde

Luc Menut 2016-08-25 16:42:25 CEST

CC: lmenut => (none)

Comment 17 Giuseppe Ghibò 2016-11-16 16:17:13 CET
The updated version is in updates/testing repository for mga5.
Comment 18 David Walser 2016-11-16 16:49:29 CET
(In reply to Giuseppe Ghibò from comment #17)
> The updated version is in updates/testing repository for mga5.

Now we need a list of the RPMs and SRPMs associated with this update.
Comment 19 Giuseppe Ghibò 2016-11-16 19:46:14 CET
For the SRPMs, here is:

kdebase4-workspace-4.11.22-1.mga5.src.rpm
kdepim4-runtime-4.14.10-1.mga5.src.rpm
kdepimlibs4-4.14.10-1.mga5.src.rpm
kdelibs4-4.14.26-1.mga5.src.rpm
Comment 20 youpburden 2016-12-17 09:47:11 CET
Testing on MGA5-32 & MGA5-64 real hardware and VM

Packages updated :

kdebase4-workspace-4.11.22-1.mga5.src.rpm
kdepim4-runtime-4.14.10-1.mga5.src.rpm
kdepimlibs4-4.14.10-1.mga5.src.rpm
kdelibs4-4.14.26-1.mga5.src.rpm

I've tried about 20 times to login/logout, reboot the system.

I never got the problem, I'm using AMD hardware though.

It's OK for 32 & 64 bits but I haven't Nidvidia hardware to OK the update.

CC: (none) => youpburden

Comment 21 youpburden 2016-12-17 09:58:21 CET
(In reply to youpburden from comment #20)
> Testing on MGA5-32 & MGA5-64 real hardware and VM
> 
> Packages updated :
> 
> kdebase4-workspace-4.11.22-1.mga5.src.rpm
> kdepim4-runtime-4.14.10-1.mga5.src.rpm
> kdepimlibs4-4.14.10-1.mga5.src.rpm
> kdelibs4-4.14.26-1.mga5.src.rpm
> 
> I've tried about 20 times to login/logout, reboot the system.
> 
> I never got the problem, I'm using AMD hardware though.
> 
> It's OK for 32 & 64 bits but I haven't Nidvidia hardware to OK the update.

EDIT : 

The Bug ID is about a lot of packages, I'm gonna post results package by package :

Kinfocenter : same results as before the update, no problem so far, I can see informations about hardware, system ...

For the applets, I used all of them, according to the upstream procedure, I don't find any bugs since the fixes.

For Krandr, I'm using redshift with ranrdr and it's working well, Don't know if it's enough to validate it.

For Akonadi, I installed Kmail and Korganiser to check if there's a regression, it's.

In a general way, I can't get old bugs announced as fixed in the upstream changelog.
I think it should be OK for 32 & 64 bits and pushed to updates.

I'd need someone's answe to be sure I tested it well so we can OK the whole update pack please.
Comment 22 Giuseppe Ghibò 2016-12-17 10:11:14 CET
Can you check also cups printing from okular? I'm actually having problems with it, but I've actually some interference with samsung (proprietary?) drivers, which refuses to continue to print when the toner is low or exausted (though it could apparently be forced to do some extra copy), and also with other USB ports, which needs to be plugged/unplugged a few times to get working properly (also for scanners with xsane, which is not kde related), so probably other problems with newer kernels or hardware in general (cables, hub usb, etc.), and thus I couldn't test properly.
Comment 23 youpburden 2016-12-17 15:03:01 CET
Okular's printing is going fine with my HP printer.

I don't know if it's a printer problem, but xsane is working fine too so it's ok for me...

I give you detail, I'm using an ethernet plug to connect my printer to machines, I tested the update with USB and it was ok.
Comment 24 Giuseppe Ghibò 2016-12-17 15:04:26 CET
OK, good. that's was an hardware problem probably.
Comment 25 Rolf Pedersen 2016-12-17 16:48:14 CET
$ rpm -q kdebase4-workspace
kdebase4-workspace-4.11.22-0.3.mga5

Since https://bugs.mageia.org/show_bug.cgi?id=17123#c14 I don't have the issues of this bug, FWIW.  I did remove the "ghibo" source at that time.

WRT printing, I'm using a usb-connected Brother MFCJ5620DW multifunction for printing and scanning with xsane.  I use the Brother script to install the drivers.  This is working fine except that I do have an occasional issue with printing from gwenview or okular in that printing a second instance without restarting the application, first, can result in the app being unresponsive and printing not happening.  If I kill the app and start over, it works.  If I am patient, I have had experiences that app becomes responsive and printing completes if I wait long enough.  I couldn't say when this glitch started happening.  User reviews of this machine include reports of it being slow to initiate printing.
Comment 26 Giuseppe Ghibò 2016-12-18 20:25:27 CET
Probably is not related to kde, but seems some printing problem is around. Maybe due to some cups upgrade? IMHO worthwhile to open also a new bug report about this printing problems. Downgrading to pre-kde upgrade stuff would still have those problems?
Comment 27 David Walser 2016-12-18 20:30:07 CET
I haven't installed these packages and I have the problem with okular freezing when printing sometimes.
Comment 28 Giuseppe Ghibò 2016-12-18 20:32:11 CET
Ok, so it's definitevely another bug.
David Walser 2016-12-30 23:40:33 CET

Blocks: (none) => 16847, 19064, 19488, 19533

Comment 29 Morgan Leijström 2017-01-02 20:06:04 CET
Sometimes (for months) on my laptop i can not log out the normal way - like described above.

And sometimes i after resume from suspend see a message "ksmserver krashed" but it seem not related, just now i saw that message but could still logout using the menu.

Current cauldron, Plasma5.8.5-2, nvidia340-340.101-2, kernel4.9.0-3

BTW, could Bug 20029 be the same as this bug?
Comment 30 Giuseppe Ghibò 2017-01-02 20:45:12 CET
No, I think Plasma5 login/logout problems is unrelated to this as the code basis (apart kdelibs 4.14.26 of KDE4, and 4.14.27 of Plasma5) is pretty different.

BTW, could we also clean the mga5_testing repository? Many packages of this bug are built there, using also other libraries in the same media source (printing, etc.) which are not part of updates, so when moving to updates IMHO could result a mess (or better to build using the upgrade repository only) because of different built libraries.
Comment 31 David Walser 2017-03-01 02:58:39 CET
We still have gotten nowhere on this, and now have a security issue to fix (kdelibs4 4.14.30):
https://www.kde.org/info/security/advisory-20170228-1.txt
Comment 32 Rolf Pedersen 2017-03-01 03:35:27 CET
I've not had this bug since last June, when I upgraded packages from Ghibo's tarball, https://bugs.mageia.org/show_bug.cgi?id=17123#c14

However, there might have been a side effect as a result that I'm not smart enough to determine.

When I build Sachesi:  https://github.com/xsacha/Sachesi I have to use the qt4 version of qmake:

$ sudo update-alternatives --config qmake

There are 2 programs which provide `qmake'.

  Selection    Command
-----------------------------------------------
 +    1        /usr/lib64/qt4/bin/qmake
*     2        /usr/lib64/qt5/bin/qmake

Enter to keep the default[*], or type selection number: ^C

When I run it, I get an error that I have had no luck solving:

$ ./Sachesi 
Cannot mix incompatible Qt library (version 0x50201) with this library (version 0x50402)
Aborted

The Sachesi executable does run without such an error on ROSA Desktop Fresh R8 release 2014.1 for x86_64, in case there is some relation.
Comment 33 Giuseppe Ghibò 2017-05-15 22:56:38 CEST
To me it's working flawlessly with the fixes in updates/testing since a long time. I've a user with kdm with UID < 1000 (in particular 501), coming from a previous mageia release and it's shown correctly in KDM and I can login with it. The only "side effect" I got was that KDM lists "nobody|nobody" in the userlist icons (but you can't login it of course).

IMHO we could upgrade this, before MGA5 EOL, but better to recompile the packages as the kdelibs was already upgraded in main in the meanwhile was was newer than the version used by kdebase4-workspace to build.
Comment 34 David Walser 2017-05-16 00:19:47 CEST
We don't need to rebuild anything just because of a kdelibs4 update (but it should be updated again to the latest), but I would really like this to be released before Mageia 5 EOL.  I'm disappointed it has taken this long already.  We just need a full list of SRPMS and RPMS and an advisory for QA.
Comment 35 Giuseppe Ghibò 2017-05-22 23:15:00 CEST
Here is the list (kdelibs not included because already upgraded to a newer version).


Sources:
========
kdebase4-workspace-4.11.22-1.mga5.src.rpm
kdepim4-runtime-4.14.10-1.mga5.src.rpm
kdepimlibs4-4.14.10-1.mga5.src.rpm

i586 binaries:
==============
akonadi-kde-4.14.10-1.mga5.i586.rpm				        \
kde4-style-oxygen-4.11.22-1.mga5.i586.rpm			        \
kdebase4-workspace-4.11.22-1.mga5.i586.rpm			        \
kdebase4-workspace-devel-4.11.22-1.mga5.i586.rpm		        \
kdebase4-workspace-handbooks-4.11.22-1.mga5.noarch.rpm  	        \
kdebase4-workspace-plasma-config-4.11.22-1.mga5.noarch.rpm	        \
kdepim4-runtime-devel-4.14.10-1.mga5.i586.rpm			        \
kdepimlibs4-core-4.14.10-1.mga5.i586.rpm			        \
kdepimlibs4-devel-4.14.10-1.mga5.i586.rpm			        \
kdepimlibs4-handbooks-4.14.10-1.mga5.noarch.rpm 		        \
kdm-4.11.22-1.mga5.i586.rpm					        \
kdm-handbook-4.11.22-1.mga5.noarch.rpm  			        \
kinfocenter-4.11.22-1.mga5.i586.rpm				        \
kinfocenter-handbook-4.11.22-1.mga5.noarch.rpm  		        \
kio4-imap-4.14.10-1.mga5.i586.rpm				        \
kio4-ldap-4.14.10-1.mga5.i586.rpm				        \
kio4-mbox-4.14.10-1.mga5.i586.rpm				        \
kio4-nntp-4.14.10-1.mga5.i586.rpm				        \
kio4-pop3-4.14.10-1.mga5.i586.rpm				        \
kio4-sieve-4.14.10-1.mga5.i586.rpm				        \
kio4-smtp-4.14.10-1.mga5.i586.rpm				        \
krandr-4.11.22-1.mga5.i586.rpm  				        \
libakonadi-calendar4-4.14.10-1.mga5.i586.rpm			        \
libakonadi-contact4-4.14.10-1.mga5.i586.rpm			        \
libakonadi-filestore4-4.14.10-1.mga5.i586.rpm			        \
libakonadi-kabc4-4.14.10-1.mga5.i586.rpm			        \
libakonadi-kcal4-4.14.10-1.mga5.i586.rpm			        \
libakonadi-kde4-4.14.10-1.mga5.i586.rpm 			        \
libakonadi-kmime4-4.14.10-1.mga5.i586.rpm			        \
libakonadi-notes4-4.14.10-1.mga5.i586.rpm			        \
libakonadi_socialutils4-4.14.10-1.mga5.i586.rpm 		        \
libakonadi-xml4-4.14.10-1.mga5.i586.rpm 			        \
libfolderarchivesettings4-4.14.10-1.mga5.i586.rpm		        \
libgpgme++2-4.14.10-1.mga5.i586.rpm				        \
libkabc4-4.14.10-1.mga5.i586.rpm				        \
libkabc_file_core4-4.14.10-1.mga5.i586.rpm			        \
libkalarmcal2-4.14.10-1.mga5.i586.rpm				        \
libkblog4-4.14.10-1.mga5.i586.rpm				        \
libkcal4-4.14.10-1.mga5.i586.rpm				        \
libkcalcore4-4.14.10-1.mga5.i586.rpm				        \
libkcalutils4-4.14.10-1.mga5.i586.rpm				        \
libkdecorations4-4.11.22-1.mga5.i586.rpm			        \
libkdepim-copy4-4.14.10-1.mga5.i586.rpm 			        \
libkephal4-4.11.22-1.mga5.i586.rpm				        \
libkfontinst4-4.11.22-1.mga5.i586.rpm				        \
libkfontinstui4-4.11.22-1.mga5.i586.rpm 			        \
libkholidays4-4.14.10-1.mga5.i586.rpm				        \
libkhotkeysprivate4-4.11.22-1.mga5.i586.rpm			        \
libkimap4-4.14.10-1.mga5.i586.rpm				        \
libkldap4-4.14.10-1.mga5.i586.rpm				        \
libkmbox4-4.14.10-1.mga5.i586.rpm				        \
libkmime4-4.14.10-1.mga5.i586.rpm				        \
libkmindexreader4-4.14.10-1.mga5.i586.rpm			        \
libkontactinterface4-4.14.10-1.mga5.i586.rpm			        \
libkpimidentities4-4.14.10-1.mga5.i586.rpm			        \
libkpimtextedit4-4.14.10-1.mga5.i586.rpm			        \
libkpimutils4-4.14.10-1.mga5.i586.rpm				        \
libkresources4-4.14.10-1.mga5.i586.rpm  			        \
libkscreensaver5-4.11.22-1.mga5.i586.rpm			        \
libksgrd4-4.11.22-1.mga5.i586.rpm				        \
libksignalplotter4-4.11.22-1.mga5.i586.rpm			        \
libktnef4-4.14.10-1.mga5.i586.rpm				        \
libkwineffects1-4.11.22-1.mga5.i586.rpm 			        \
libkwinglesutils1-4.11.22-1.mga5.i586.rpm			        \
libkwinglutils1-4.11.22-1.mga5.i586.rpm 			        \
libkworkspace4-4.11.22-1.mga5.i586.rpm  			        \
libkxmlrpcclient4-4.14.10-1.mga5.i586.rpm			        \
liblsofui4-4.11.22-1.mga5.i586.rpm				        \
libmaildir4-4.14.10-1.mga5.i586.rpm				        \
libmailtransport4-4.14.10-1.mga5.i586.rpm			        \
libmicroblog4-4.14.10-1.mga5.i586.rpm				        \
liboxygenstyle4-4.11.22-1.mga5.i586.rpm 			        \
liboxygenstyleconfig4-4.11.22-1.mga5.i586.rpm			        \
libplasma_applet_system_monitor4-4.11.22-1.mga5.i586.rpm	        \
libplasmaclock4-4.11.22-1.mga5.i586.rpm 			        \
libplasmagenericshell4-4.11.22-1.mga5.i586.rpm  		        \
libplasma-geolocation-interface4-4.11.22-1.mga5.i586.rpm	        \
libpowerdevilconfigcommonprivate4-4.11.22-1.mga5.i586.rpm	        \
libpowerdevilcore0-4.11.22-1.mga5.i586.rpm			        \
libpowerdevilui4-4.11.22-1.mga5.i586.rpm			        \
libprocesscore4-4.11.22-1.mga5.i586.rpm 			        \
libprocessui4-4.11.22-1.mga5.i586.rpm				        \
libqgpgme1-4.14.10-1.mga5.i586.rpm				        \
libsyndication4-4.14.10-1.mga5.i586.rpm 			        \
libsystemsettingsview2-4.11.22-1.mga5.i586.rpm  		        \
libtaskmanager4-4.11.22-1.mga5.i586.rpm 			        \
libweather_ion6-4.11.22-1.mga5.i586.rpm 			        \
plasma-applet-battery-4.11.22-1.mga5.i586.rpm			        \
plasma-applet-calendar-4.11.22-1.mga5.i586.rpm  		        \
plasma-applet-quicklaunch-4.11.22-1.mga5.i586.rpm		        \
plasma-applet-system-monitor-cpu-4.11.22-1.mga5.i586.rpm	        \
plasma-applet-system-monitor-hdd-4.11.22-1.mga5.i586.rpm	        \
plasma-applet-system-monitor-hwinfo-4.11.22-1.mga5.i586.rpm	        \
plasma-applet-system-monitor-net-4.11.22-1.mga5.i586.rpm	        \
plasma-applet-system-monitor-temperature-4.11.22-1.mga5.i586.rpm        \
plasma-applet-webbrowser-4.11.22-1.mga5.i586.rpm		        \
plasma-krunner-powerdevil-4.11.22-1.mga5.i586.rpm		        \
plasma-runner-places-4.11.22-1.mga5.i586.rpm			        \
plasma-scriptengine-python-4.11.22-1.mga5.i586.rpm		        \
plasma-scriptengine-ruby-4.11.22-1.mga5.noarch.rpm		        \

x86_64 binaries:
================
akonadi-kde-4.14.10-1.mga5.x86_64.rpm				     \
kdepim4-runtime-devel-4.14.10-1.mga5.x86_64.rpm 		     \
kdepimlibs4-core-4.14.10-1.mga5.x86_64.rpm			     \
kdepimlibs4-devel-4.14.10-1.mga5.x86_64.rpm			     \
kdepimlibs4-handbooks-4.14.10-1.mga5.noarch.rpm 		     \
kio4-imap-4.14.10-1.mga5.x86_64.rpm				     \
kio4-ldap-4.14.10-1.mga5.x86_64.rpm				     \
kio4-mbox-4.14.10-1.mga5.x86_64.rpm				     \
kio4-nntp-4.14.10-1.mga5.x86_64.rpm				     \
kio4-pop3-4.14.10-1.mga5.x86_64.rpm				     \
kio4-sieve-4.14.10-1.mga5.x86_64.rpm				     \
kio4-smtp-4.14.10-1.mga5.x86_64.rpm				     \
lib64akonadi-calendar4-4.14.10-1.mga5.x86_64.rpm		     \
lib64akonadi-contact4-4.14.10-1.mga5.x86_64.rpm 		     \
lib64akonadi-filestore4-4.14.10-1.mga5.x86_64.rpm		     \
lib64akonadi-kabc4-4.14.10-1.mga5.x86_64.rpm			     \
lib64akonadi-kcal4-4.14.10-1.mga5.x86_64.rpm			     \
lib64akonadi-kde4-4.14.10-1.mga5.x86_64.rpm			     \
lib64akonadi-kmime4-4.14.10-1.mga5.x86_64.rpm			     \
lib64akonadi-notes4-4.14.10-1.mga5.x86_64.rpm			     \
lib64akonadi-xml4-4.14.10-1.mga5.x86_64.rpm			     \
lib64akonadi_socialutils4-4.14.10-1.mga5.x86_64.rpm		     \
lib64folderarchivesettings4-4.14.10-1.mga5.x86_64.rpm		     \
lib64gpgme++2-4.14.10-1.mga5.x86_64.rpm 			     \
lib64kabc4-4.14.10-1.mga5.x86_64.rpm				     \
lib64kabc_file_core4-4.14.10-1.mga5.x86_64.rpm  		     \
lib64kalarmcal2-4.14.10-1.mga5.x86_64.rpm			     \
lib64kblog4-4.14.10-1.mga5.x86_64.rpm				     \
lib64kcal4-4.14.10-1.mga5.x86_64.rpm				     \
lib64kcalcore4-4.14.10-1.mga5.x86_64.rpm			     \
lib64kcalutils4-4.14.10-1.mga5.x86_64.rpm			     \
lib64kdepim-copy4-4.14.10-1.mga5.x86_64.rpm			     \
lib64kholidays4-4.14.10-1.mga5.x86_64.rpm			     \
lib64kimap4-4.14.10-1.mga5.x86_64.rpm				     \
lib64kldap4-4.14.10-1.mga5.x86_64.rpm				     \
lib64kmbox4-4.14.10-1.mga5.x86_64.rpm				     \
lib64kmime4-4.14.10-1.mga5.x86_64.rpm				     \
lib64kmindexreader4-4.14.10-1.mga5.x86_64.rpm			     \
lib64kontactinterface4-4.14.10-1.mga5.x86_64.rpm		     \
lib64kpimidentities4-4.14.10-1.mga5.x86_64.rpm  		     \
lib64kpimtextedit4-4.14.10-1.mga5.x86_64.rpm			     \
lib64kpimutils4-4.14.10-1.mga5.x86_64.rpm			     \
lib64kresources4-4.14.10-1.mga5.x86_64.rpm			     \
lib64ktnef4-4.14.10-1.mga5.x86_64.rpm				     \
lib64kxmlrpcclient4-4.14.10-1.mga5.x86_64.rpm			     \
lib64maildir4-4.14.10-1.mga5.x86_64.rpm 			     \
lib64mailtransport4-4.14.10-1.mga5.x86_64.rpm			     \
lib64microblog4-4.14.10-1.mga5.x86_64.rpm			     \
lib64qgpgme1-4.14.10-1.mga5.x86_64.rpm  			     \
lib64syndication4-4.14.10-1.mga5.x86_64.rpm			     \
kde4-style-oxygen-4.11.22-1.mga5.x86_64.rpm			     \
kdebase4-workspace-4.11.22-1.mga5.x86_64.rpm			     \
kdebase4-workspace-devel-4.11.22-1.mga5.x86_64.rpm		     \
kdebase4-workspace-handbooks-4.11.22-1.mga5.noarch.rpm  	     \
kdebase4-workspace-plasma-config-4.11.22-1.mga5.noarch.rpm	     \
kdm-4.11.22-1.mga5.x86_64.rpm					     \
kdm-handbook-4.11.22-1.mga5.noarch.rpm  			     \
kinfocenter-4.11.22-1.mga5.x86_64.rpm				     \
kinfocenter-handbook-4.11.22-1.mga5.noarch.rpm  		     \
krandr-4.11.22-1.mga5.x86_64.rpm				     \
lib64kdecorations4-4.11.22-1.mga5.x86_64.rpm			     \
lib64kephal4-4.11.22-1.mga5.x86_64.rpm  			     \
lib64kfontinst4-4.11.22-1.mga5.x86_64.rpm			     \
lib64kfontinstui4-4.11.22-1.mga5.x86_64.rpm			     \
lib64khotkeysprivate4-4.11.22-1.mga5.x86_64.rpm 		     \
lib64kscreensaver5-4.11.22-1.mga5.x86_64.rpm			     \
lib64ksgrd4-4.11.22-1.mga5.x86_64.rpm				     \
lib64ksignalplotter4-4.11.22-1.mga5.x86_64.rpm  		     \
lib64kwineffects1-4.11.22-1.mga5.x86_64.rpm			     \
lib64kwinglesutils1-4.11.22-1.mga5.x86_64.rpm			     \
lib64kwinglutils1-4.11.22-1.mga5.x86_64.rpm			     \
lib64kworkspace4-4.11.22-1.mga5.x86_64.rpm			     \
lib64lsofui4-4.11.22-1.mga5.x86_64.rpm  			     \
lib64oxygenstyle4-4.11.22-1.mga5.x86_64.rpm			     \
lib64oxygenstyleconfig4-4.11.22-1.mga5.x86_64.rpm		     \
lib64plasma-geolocation-interface4-4.11.22-1.mga5.x86_64.rpm	     \
lib64plasma_applet_system_monitor4-4.11.22-1.mga5.x86_64.rpm	     \
lib64plasmaclock4-4.11.22-1.mga5.x86_64.rpm			     \
lib64plasmagenericshell4-4.11.22-1.mga5.x86_64.rpm		     \
lib64powerdevilconfigcommonprivate4-4.11.22-1.mga5.x86_64.rpm	     \
lib64powerdevilcore0-4.11.22-1.mga5.x86_64.rpm  		     \
lib64powerdevilui4-4.11.22-1.mga5.x86_64.rpm			     \
lib64processcore4-4.11.22-1.mga5.x86_64.rpm			     \
lib64processui4-4.11.22-1.mga5.x86_64.rpm			     \
lib64systemsettingsview2-4.11.22-1.mga5.x86_64.rpm		     \
lib64taskmanager4-4.11.22-1.mga5.x86_64.rpm			     \
lib64weather_ion6-4.11.22-1.mga5.x86_64.rpm			     \
plasma-applet-battery-4.11.22-1.mga5.x86_64.rpm 		     \
plasma-applet-calendar-4.11.22-1.mga5.x86_64.rpm		     \
plasma-applet-quicklaunch-4.11.22-1.mga5.x86_64.rpm		     \
plasma-applet-system-monitor-cpu-4.11.22-1.mga5.x86_64.rpm	     \
plasma-applet-system-monitor-hdd-4.11.22-1.mga5.x86_64.rpm	     \
plasma-applet-system-monitor-hwinfo-4.11.22-1.mga5.x86_64.rpm	     \
plasma-applet-system-monitor-net-4.11.22-1.mga5.x86_64.rpm	     \
plasma-applet-system-monitor-temperature-4.11.22-1.mga5.x86_64.rpm   \
plasma-applet-webbrowser-4.11.22-1.mga5.x86_64.rpm		     \
plasma-krunner-powerdevil-4.11.22-1.mga5.x86_64.rpm		     \
plasma-runner-places-4.11.22-1.mga5.x86_64.rpm  		     \
plasma-scriptengine-python-4.11.22-1.mga5.x86_64.rpm		     \
plasma-scriptengine-ruby-4.11.22-1.mga5.noarch.rpm		     \
Comment 36 David Walser 2017-05-23 05:55:55 CEST
Thanks!  We should upgrade kdelibs4 again to 4.14.32 and push this to QA.
Comment 37 Nicolas Lécureuil 2017-08-20 21:20:04 CEST
kdelibs   4.14.35 is in updates_testing

CC: (none) => mageia

Comment 38 David Walser 2017-08-20 22:31:41 CEST
Thanks Nicolas!  Assigning this to QA finally.  Most of the package list in Comment 35.

Please make sure to test that things work just as well with existing UIDs below 1000.

In addition to Comment 35, kdelibs4 has also been updated again, a list for which I will post in the next comment.

Advisory:
----------------------------------------

The kdelibs4, kdepimlibs4, kdepim4-runtime, and kdebase4-workspace packages
have been updated to include several bug fixes from upstream.  Most notably,
issues with KDE sessions sometimes not starting properly have been addressed.

CC: luigiwalser => (none)
Assignee: kde => qa-bugs

Comment 39 David Walser 2017-08-20 22:32:29 CEST
Additional package list for kdelibs4:
libkde3support4-4.14.35-1.mga5
libkdecore5-4.14.35-1.mga5
libkdefakes5-4.14.35-1.mga5
libkdesu5-4.14.35-1.mga5
libkdeui5-4.14.35-1.mga5
libkdnssd4-4.14.35-1.mga5
libkfile4-4.14.35-1.mga5
libkhtml5-4.14.35-1.mga5
libkimproxy4-4.14.35-1.mga5
libkio5-4.14.35-1.mga5
libkjsembed4-4.14.35-1.mga5
libkjs4-4.14.35-1.mga5
libkmediaplayer4-4.14.35-1.mga5
libnepomuk4-4.14.35-1.mga5
libknewstuff2_4-4.14.35-1.mga5
libknotifyconfig4-4.14.35-1.mga5
libkntlm4-4.14.35-1.mga5
libkdeclarative5-4.14.35-1.mga5
libkparts4-4.14.35-1.mga5
libkrosscore4-4.14.35-1.mga5
libkrossui4-4.14.35-1.mga5
libktexteditor4-4.14.35-1.mga5
libkunittest4-4.14.35-1.mga5
libkutils4-4.14.35-1.mga5
libsolid4-4.14.35-1.mga5
libthreadweaver4-4.14.35-1.mga5
libkpty4-4.14.35-1.mga5
libkjsapi4-4.14.35-1.mga5
libplasma3-4.14.35-1.mga5
libkunitconversion4-4.14.35-1.mga5
libnepomukquery4-4.14.35-1.mga5
libkdewebkit5-4.14.35-1.mga5
libknewstuff3_4-4.14.35-1.mga5
libkcmutils4-4.14.35-1.mga5
libkprintutils4-4.14.35-1.mga5
libkidletime4-4.14.35-1.mga5
libkemoticons4-4.14.35-1.mga5
libnepomukutils4-4.14.35-1.mga5
kdelibs4-core-4.14.35-1.mga5
kdelibs4-handbooks-4.14.35-1.mga5
kdelibs4-devel-4.14.35-1.mga5

from kdelibs4-4.14.35-1.mga5.src.rpm
Comment 40 David Walser 2017-08-20 22:35:36 CEST
kdepimlibs4 has been rebuilt to include an additional fix:
kdepimlibs4-core-4.14.10-2.1.mga5
kdepimlibs4-handbooks-4.14.10-2.1.mga5
kio4-imap-4.14.10-2.1.mga5
kio4-pop3-4.14.10-2.1.mga5
kio4-ldap-4.14.10-2.1.mga5
kio4-sieve-4.14.10-2.1.mga5
kio4-mbox-4.14.10-2.1.mga5
kio4-smtp-4.14.10-2.1.mga5
kio4-nntp-4.14.10-2.1.mga5
libkabc4-4.14.10-2.1.mga5
libkblog4-4.14.10-2.1.mga5
libkabc_file_core4-4.14.10-2.1.mga5
libkcal4-4.14.10-2.1.mga5
libkimap4-4.14.10-2.1.mga5
libkldap4-4.14.10-2.1.mga5
libkmbox4-4.14.10-2.1.mga5
libkmime4-4.14.10-2.1.mga5
libkpimutils4-4.14.10-2.1.mga5
libkresources4-4.14.10-2.1.mga5
libktnef4-4.14.10-2.1.mga5
libkxmlrpcclient4-4.14.10-2.1.mga5
libmailtransport4-4.14.10-2.1.mga5
libsyndication4-4.14.10-2.1.mga5
libqgpgme1-4.14.10-2.1.mga5
libgpgme++2-4.14.10-2.1.mga5
libkpimidentities4-4.14.10-2.1.mga5
libakonadi-kde4-4.14.10-2.1.mga5
libakonadi-kabc4-4.14.10-2.1.mga5
libakonadi-kmime4-4.14.10-2.1.mga5
libakonadi-notes4-4.14.10-2.1.mga5
libkalarmcal2-4.14.10-2.1.mga5
libkholidays4-4.14.10-2.1.mga5
libkpimtextedit4-4.14.10-2.1.mga5
libmicroblog4-4.14.10-2.1.mga5
libakonadi-contact4-4.14.10-2.1.mga5
libakonadi-kcal4-4.14.10-2.1.mga5
libkontactinterface4-4.14.10-2.1.mga5
libakonadi-calendar4-4.14.10-2.1.mga5
libakonadi_socialutils4-4.14.10-2.1.mga5
libkcalcore4-4.14.10-2.1.mga5
libkcalutils4-4.14.10-2.1.mga5
libakonadi-xml4-4.14.10-2.1.mga5
kdepimlibs4-devel-4.14.10-2.1.mga5

from kdepimlibs4-4.14.10-2.1.mga5.src.rpm
David Walser 2017-08-20 22:37:52 CEST

Blocks: 19488 => (none)

Comment 41 James Kerr 2017-08-21 17:43:57 CEST
On mga5-64 

The packages all installed cleanly, except krandr, which conflicts with installed kscreen. (I think that is expected.)

I added a user with UID 501 (the existing user is 1000). Used KDE System Settings to change the displayed users in KDM to include users between 500 and 1000.

There has been no evidence of the problems cited, with either user, but since these problems can be intermittent, I will continue testing over the next several days before giving the OK.
Comment 42 James Kerr 2017-08-21 17:47:12 CEST
Created attachment 9620 [details]
List of packages for mga5-64


The list of packages installed, referred to in comment#41
Comment 43 James Kerr 2017-08-21 18:05:43 CEST
On mga5-32 in a vbox VM

The packages all installed cleanly, except krandr, which conflicts with installed kscreen. (I think that is expected.)

I added a user with UID 501 (the existing user is 1000) and used KDE System Settings to change the displayed users in KDM to include users between 500 and 1000.

There has been no evidence of the problems cited, with either user, but since these problems can be intermittent, I will continue testing over the next several days before giving the OK.
Comment 44 James Kerr 2017-08-21 18:11:13 CEST
Created attachment 9621 [details]
List of packages for mga5-32


List of packages installed, referred to in comment#43
Comment 45 James Kerr 2017-08-24 18:05:41 CEST
I also tested, in a 64 bit VM, set up with only one user with uid 501 to which I added a second user with uid 502. Both users were listed in the KDM login screen in spite of the fact that system settings identifies users below 1000 as system users; and continue to be listed after installing these packages.

After numerous reboots, logins and switching users I have seen no evidence of the problems cited.
Comment 46 James Kerr 2017-08-24 18:12:53 CEST
After numerous reboots, logins and switching users, I have seen no evidence of the problems cited here on either mga5-64 on real hardware or mga5-32 in a vbox VM.

I think that this update can now be released and so have validated it.

The Advisory in comment#38 needs to be uploaded to SVN. The SRPMs are:

kdebase4-workspace-4.11.22-1.mga5.src.rpm
kdelibs4-4.14.35-1.mga5.src.rpm
kdepim4-runtime-4.14.10-1.mga5.src.rpm
kdepimlibs4-4.14.10-2.1.mga5.src.rpm

The  packages can then be pushed to updates.

CC: (none) => sysadmin-bugs
Keywords: (none) => validated_update
Whiteboard: (none) => MGA5-64-OK MGA5-32-OK

Comment 47 Lewis Smith 2017-08-24 22:42:58 CEST
Many thanks to Jim for the arduous testing.
Advisory from comments 38 & 46.

Whiteboard: MGA5-64-OK MGA5-32-OK => MGA5-64-OK MGA5-32-OK advisory
CC: (none) => lewyssmith

Comment 48 Mageia Robot 2017-08-24 23:19:11 CEST
An update for this issue has been pushed to the Mageia Updates repository.

http://advisories.mageia.org/MGAA-2017-0066.html

Resolution: (none) => FIXED
Status: NEW => RESOLVED

Comment 49 Florian Hubold 2017-08-26 15:27:48 CEST
(In reply to Giuseppe Ghibò from comment #33)
> The only "side effect" I got was that KDM lists "nobody|nobody" in
> the userlist icons (but you can't login it of course).

Since this has been pushed, a few users are disturbed by the "new" nobody user on their login screen. Also it seems that this user can't be seen (and hence also not edited/hidden) in either systemsettings module nor in MCC/userdrake.
Any proposals how to handle that, do we have a workaround for this? I would have to look at someone else's mga5 system to be able to reproduce, but maybe someone from KDE team has an idea what to adjust where?
Comment 50 Florian Hubold 2017-08-26 16:32:06 CEST
(In reply to Florian Hubold from comment #49)
> Any proposals how to handle that, do we have a workaround for this?

After reading the thread on qa-discuss about this, sure this would need another bugreport, but my primary question would be beforehand, do we want to push another update for this, or do we add this e.g. to errata ?

Also in the cases where users have reported this via forums, the issue was with kdm and not with sddm (where I'd know how to hide the user) but for kdm I'd like to hear the opinion of our KDE team first. As this is currently not configurable in systemsettings ...
Comment 51 David Walser 2017-08-26 17:49:23 CEST
Errata is for bugs present at the time of release, not for bugs created by updates.  Yes, we should fix this.
Comment 52 Marja van Waes 2017-09-20 09:15:54 CEST
(In reply to Florian Hubold from comment #49)
> (In reply to Giuseppe Ghibò from comment #33)
> > The only "side effect" I got was that KDM lists "nobody|nobody" in
> > the userlist icons (but you can't login it of course).
> 
> Since this has been pushed, a few users are disturbed by the "new" nobody
> user on their login screen. Also it seems that this user can't be seen (and
> hence also not edited/hidden) in either systemsettings module nor in
> MCC/userdrake.
> Any proposals how to handle that, do we have a workaround for this? I would
> have to look at someone else's mga5 system to be able to reproduce, but
> maybe someone from KDE team has an idea what to adjust where?

For a workaround, see https://bugs.mageia.org/show_bug.cgi?id=21624#c3

CC: (none) => marja11


Note You need to log in before you can comment on or make changes to this bug.