Bug 16859 - Adding support for exFAT filesystems not easy for users ("tainted" issues)
Summary: Adding support for exFAT filesystems not easy for users ("tainted" issues)
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: Daniel Napora
QA Contact:
URL:
Whiteboard:
Keywords: IN_ERRATA6
Depends on:
Blocks:
 
Reported: 2015-09-30 00:47 CEST by Florian Hubold
Modified: 2018-12-28 19:04 CET (History)
8 users (show)

See Also:
Source RPM: mageiawelcome, fuse-exfat
CVE:
Status comment:


Attachments

Description Florian Hubold 2015-09-30 00:47:13 CEST
Description of problem:

To support usage of exFAT filesystems, which are becoming more and more common currently requires the user to manually know about the filesystem type and the Mageia package which provides support for that, otherwise he will only see a pretty useless error message.

Please install it by default in Mageia 6.

Reproducible: 

Steps to Reproduce:
Florian Hubold 2015-09-30 00:47:29 CEST

Target Milestone: --- => Mageia 6
CC: (none) => doktor5000

Comment 1 Thomas Backlund 2015-09-30 00:58:59 CEST
No can do...

It's moved to tainted because of patent issues

Resolution: (none) => WONTFIX
CC: (none) => tmb
Status: NEW => RESOLVED

Comment 2 Samuel Verschelde 2015-09-30 09:34:57 CEST
Then we should at least document that in Release Notes and/or Errata.

Maybe see also what we can do in Mageia Welcome about that. There has been discussion about making the activation of Tainted media more straightforward after installation in the qa-discuss mailing list but I'm not sure the related Feature Proposal has been created.

Source RPM: (none) => fuse-exfat
Resolution: WONTFIX => (none)
Summary: install fuse-exfat (and exfat-utils) by default => Adding support for exFAT filesystems not easy for users ("tainted" issues)
Whiteboard: (none) => FOR_ERRATA6
Status: RESOLVED => REOPENED
Component: Release (media or process) => RPM Packages

Samuel Verschelde 2016-10-10 22:36:03 CEST

Target Milestone: Mageia 6 => ---

Samuel Verschelde 2016-10-18 13:15:30 CEST

Keywords: (none) => FOR_ERRATA6
Whiteboard: FOR_ERRATA6 => (none)

Comment 3 Marja Van Waes 2016-10-30 18:40:08 CET
(In reply to Samuel Verschelde from comment #2)
> Then we should at least document that in Release Notes and/or Errata.
> 
> Maybe see also what we can do in Mageia Welcome about that. There has been
> discussion about making the activation of Tainted media more straightforward
> after installation in the qa-discuss mailing list but I'm not sure the
> related Feature Proposal has been created.

If you mean an "Enable tainted" (and probably also an "Enable nonfree") shortcut, that adds the correct ticks in drakrpm-edit-media without having to do that manually: no, that doesn't exist.

There is a link that'll open drakrpm-editmedia, though, but I can imagine that many users will be confused when they see the long list of media they can enable, disable etc.

Moreover: clicking the help button in that screen *only* works if the help was previously installed (which is seldom the case in a fresh install), because it cannot install the MCC manual:
urpmi database is locked, process 7421 is already using it (/usr/bin/perl /usr/libexec/drakrpm-editmedia --embedded 125829243)


CC'ing napcok, because I missed that discussion on qa-discuss, and he'll know what can or cannot be done :-)

CC: (none) => marja11, napcok

Comment 4 Marja Van Waes 2017-02-15 10:16:54 CET
 

(In reply to Marja van Waes from comment #3)
> (In reply to Samuel Verschelde from comment #2)
> > Then we should at least document that in Release Notes and/or Errata.
> > 
> > Maybe see also what we can do in Mageia Welcome about that. There has been
> > discussion about making the activation of Tainted media more straightforward
> > after installation in the qa-discuss mailing list but I'm not sure the
> > related Feature Proposal has been created.
> 
> If you mean an "Enable tainted" (and probably also an "Enable nonfree")
> shortcut, that adds the correct ticks in drakrpm-edit-media without having
> to do that manually: no, that doesn't exist.

And if created for tainted, a pop-up should appear "The tainted repositories contain software that might be illegal in your country. Are you sure you want to continue? 'Yes' 'No'".

> 
> There is a link that'll open drakrpm-editmedia, though, but I can imagine
> that many users will be confused when they see the long list of media they
> can enable, disable etc.
> 
> Moreover: clicking the help button in that screen *only* works if the help
> was previously installed (which is seldom the case in a fresh install),
> because it cannot install the MCC manual:
> urpmi database is locked, process 7421 is already using it (/usr/bin/perl
> /usr/libexec/drakrpm-editmedia --embedded 125829243)
> 
> 
> CC'ing napcok, because I missed that discussion on qa-discuss, and he'll
> know what can or cannot be done :-)

@ napcok

Now assigning to you, to increase the chance that you'll read this ;-)

Assignee: bugsquad => napcok
Source RPM: fuse-exfat => mageiawelcome, fuse-exfat
CC: sysadmin-bugs => mageiatools

Comment 5 Neal Gompa 2017-02-15 13:52:43 CET
There's an interesting quirk in the libdnf PackageKit backend that allows for reading metadata without the repositories being enabled, so that you can see what's available, and if it's from a repository that's not enabled by default, you can be appropriately prompted about it.

This is set up by having the following lines in the .repo files:

enabled=0
enabled_metadata=1

I'm not sure if DNF (and thus dnfdragora) could also operate this way, but it's something that could potentially be done. If it doesn't support it now, it's something we could ask DNF upstream to consider adding.

If we want to have these flags set on tainted and nonfree repos (which are currently disabled by default in the mageia-repos package), I could do so...

CC: (none) => ngompa13

Marja Van Waes 2017-03-06 17:35:23 CET

Keywords: FOR_ERRATA6 => IN_ERRATA6

Comment 6 Jybz 2018-11-06 19:43:14 CET
Hi all,

I didn't get the paragraph from that article :
https://www.zdnet.com/article/whats-the-deal-with-microsofts-open-source-friendly-patents/

Microsoft released patents, and something about exfat seems to be in the list.

Does it change something with fuse-exfat repository (non-free / tainted... Free ???) ?

CC: (none) => j.biernacki

Comment 7 Jybz 2018-11-06 19:50:44 CET
From the link previously provided, I read :
https://www.zdnet.com/article/whats-the-deal-with-microsofts-open-source-friendly-patents/
> That's not to say you can run out and build an exFAT-based file system for your USB-drive tomorrow with no consequences. Only OIN members have a non-aggression pact with Microsoft. If you're not a member of the OIN, you still must license exFAT from Microsoft.

And from the OIN I see that Mageia.Org is a member of the OIN.
https://www.openinventionnetwork.com/community-of-licensees/
Comment 8 Jybz 2018-11-06 21:44:56 CET
From an IRC discussion :
[21:33:46] <...> https://sfconservancy.org/blog/2018/oct/10/microsoft-oin-exfat/
[21:34:59] <...> La lecture qui est faite des dernières actions est que exfat n'est pas inclus dans les licences de OIN
[21:35:28] <...> donc exfat-fuse reste dans les tainted.

Result => remain in tainted.
Comment 9 papoteur 2018-12-28 19:04:39 CET
Fuse-exfat is now in the applications list of mageiawelcome.

Resolution: (none) => FIXED
Status: REOPENED => RESOLVED
CC: (none) => yves.brungard_mageia


Note You need to log in before you can comment on or make changes to this bug.