Bug 1680 - xrandr not installed by default but required for KDE display config on startup
Summary: xrandr not installed by default but required for KDE display config on startup
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 1
Hardware: All Linux
Priority: Normal major
Target Milestone: ---
Assignee: John Balcaen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-08 07:20 CEST by Jeff Robins
Modified: 2011-07-09 19:00 CEST (History)
2 users (show)

See Also:
Source RPM: kdebase4-workspace-4.6.3-7.mga1.src.rpm
CVE:
Status comment:


Attachments

Description Jeff Robins 2011-06-08 07:20:15 CEST
Description of problem:
KDE requires 'xrandr' to be present to configure the display on startup.  Using the "Display and Monitor" Control Center Module or the tray applet works to configure the monitor but the settings are lost on reboot.  The settings and the 'xrandr' command to run at startup are saved in "~/.kde4/share/config/krandrrc".  I have a dual monitor setup where the monitors have different resolutions and one is to the right of the other.  This may not affect single monitor and/or cloned monitor setups.  

I marked the bug as Major because it breaks a frequently used feature and may turn people off to Mageia.  I almost went back to Mandriva, but I found the line in "krandrrc" and noticed that 'xrandr' was missing.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install fresh mageia 1 on a computer with two monitors
2. Use "Display and Monitor" to configure monitors to different resolutions and positions
3. Set primary monitor
4. Apply settings
5. Click "Save as Default"
6. Reboot
7. Login
8. Get frustrated
9. Install 'xrandr'
10. Reboot
11. Bliss
Comment 1 John Balcaen 2011-06-08 12:31:18 CEST
Ok.
Comment 2 John Balcaen 2011-07-09 19:00:31 CEST
Fixed in svn & should be out with KDE SC 4.6.5

Note You need to log in before you can comment on or make changes to this bug.