Bug 16780 - unable to print PDFv1.6 documents (from DocuSign)
Summary: unable to print PDFv1.6 documents (from DocuSign)
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 5
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: Mageia Bug Squad
QA Contact:
Depends on:
Blocks: 18367
  Show dependency treegraph
Reported: 2015-09-18 17:36 CEST by Pierre Fortin
Modified: 2017-02-28 17:19 CET (History)
2 users (show)

See Also:
Source RPM:
Status comment:


Description Pierre Fortin 2015-09-18 17:36:14 CEST
Description of problem:  Received a document originating from DocuSign and am unable to print it.  What doesn't help is that various PDF tools react differently...  In particular, okular & xpdf display correctly; but print [mostly] blank pages.

pdfinfo reports this about the file (no errors):
     CreationDate:   Sat Sep 12 10:06:36 2015
     ModDate:        Sat Sep 12 10:06:36 2015
     Tagged:         no
     UserProperties: no
     Suspects:       no
     Form:           none
     JavaScript:     no
     Pages:          2
     Encrypted:      no
     Page size:      604 x 792 pts
     Page rot:       0
     File size:      1863239 bytes
     Optimized:      no
     PDF version:    1.6

https://www.pdf-online.com/osa/validate.aspx reports:
  Compliance	pdf1.6
  Result	Document validated successfully.

Version-Release number of selected component (if applicable):

How reproducible: always

Steps to Reproduce (actually, list of programs tried):

1. okular: displays correctly; but Print [preview] produces 2 blank pages 
2. a) xpdf: displays correctly; printed to .ps file
   b) gv <file>.ps:
     Error: /ioerror in --image--GPL Ghostscript 9.14: Unrecoverable error, exit code 1
     Operand stack:
     Execution stack:
       %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2
       %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1
       %stopped_push   1918   1   3   %oparray_pop   1917   1   3   %oparray_pop   1901
       1   3   %oparray_pop   1787   1   3   %oparray_pop   --nostringval--
       %errorexec_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--
       2   %stopped_push   --nostringval--   --nostringval--   1814   1   7   %oparray_pop
     Dictionary stack:
       --dict:1182/1684(ro)(G)--   --dict:0/20(G)--   --dict:78/200(L)--   --dict:68/75(L)--
       --dict:18/25(L)--   --dict:0/15(L)--   --dict:0/15(L)--
     Current allocation mode is local
     Last OS error: Resource temporarily unavailable

2. gv <file>.pdf: displays only the signatures
3. pdf2ps:
     Unknown device: pswrite
     Unrecoverable error: undefined in .uninstallpagedevice
     Operand stack:
4. pdftops: creates .ps with blank pages
5. pdfmod: displays correctly; no print capability.
     [1 Debug 10:27:26.665] Starting PdfMod 0.9.1
     [1 Debug 10:27:26.666] Initializing i18n catalog from /usr/share/locale/
     [1 Debug 10:27:26.709] Loaded custom AccelMap from /home/pfortin/.config/pdfmod/gtk_accel_map
     [1 Debug 10:27:26.713] Cache directory set to /home/pfortin/.cache/pdfmod
     [1 Debug 10:27:26.852] Loaded <file>
6. pdftotext: outputs <file>.txt containing only signatures as text
7. pdfshuffler: displays correctly; no print capability.
8. pdftohtml: creates .jpg files which ImageMagick & gimp can't open
9. pdftk: 
     Done.  Input errors, so no output created.


Steps to Reproduce:
Comment 1 Pierre Fortin 2015-09-18 17:41:27 CEST
I can email pdf file privately --can only compress it down to 1674597 which is too big to attach to this bug report.
Comment 2 David Walser 2015-09-21 23:18:57 CEST
I think the simplest way conceptually to have files like this print correctly is to have a printer queue set up to send PDF and a printer that understands PDF 1.6 natively.  I think queues are supposed to be created as PDF now, but I'm not sure if it's sending the PDF directly to the printer or doing some filtering on it.  It probably depends on how you configure the print queue.
Comment 3 Pierre Fortin 2015-09-22 00:40:23 CEST
I have a PDF print queue, and printing to that "device" which prints to a file; or using "Print to file (PDF)" in the Print dialog produce blank pages.  

Our printers are HP8600 N911g (see http://support.hp.com/us-en/product/HP-Officejet-Pro-8600-e-All-in-One-Printer-series---N9/4322915/model/4323647/product-info and http://support.hp.com/us-en/product/HP-Officejet-Pro-8600-e-All-in-One-Printer-series---N9/4322915/model/4323647/document/c02858465/) which are PCL3.

It's the first time in years I've been unable to print a PDF file.
May I send you the file?
Comment 4 Samuel Verschelde 2015-09-22 10:08:36 CEST
The attachment size limit has been raised, so you can now attach the PDF if you can legally share it.
Comment 5 Pierre Fortin 2015-09-22 13:42:12 CEST
(File size limit: 1000 KB) is not enough...
Comment 6 Samuel Verschelde 2015-09-22 14:14:25 CEST
I thought we had raised it to 5000 KB a few days ago. Maybe the change hasn't be deployed yet.
Comment 7 Pierre Fortin 2015-09-22 14:46:10 CEST
Just tried...  still 1000KB
Marja Van Waes 2016-05-05 10:22:15 CEST

Blocks: (none) => 18367

Comment 8 Marja Van Waes 2016-08-10 19:41:32 CEST
On the 25th of July, Phillipem uploaded the following packages to 
Cauldron's core/updates_testing:




@ Anyone reading this:

* If this bug is valid for you in cauldron, then please test whether updating your system-config-printer packages to version 1.5.7-5.mga6 fixes the problem and report back in this bug report.

* If you do not have this bug in cauldron, but you do run cauldron, then please update those packages, too, and report in bug 18367 whether they work as expected.

CC: (none) => makowski.mageia, marja11

Comment 9 Marja Van Waes 2017-01-10 12:57:02 CET
(In reply to Samuel Verschelde from comment #6)
> I thought we had raised it to 5000 KB a few days ago. Maybe the change
> hasn't be deployed yet.

and now?
Comment 10 Marja Van Waes 2017-02-28 17:19:01 CET
Since there are insufficient details provided in this report for us to investigate the issue further, and we have not received feedback to the information we have requested above, we will assume the problem was not reproducible, or has been fixed in one of the updates we have released for the reporter's distribution.

Users who have experienced this problem are encouraged to upgrade to the latest update of their distribution, and if this issue turns out to still be reproducible in the latest update, please reopen this bug with additional information.

Closing as OLD.

Resolution: (none) => OLD

Note You need to log in before you can comment on or make changes to this bug.