Bug 16759 - problem with bnx2 driver with mageia 5 kernel
Summary: problem with bnx2 driver with mageia 5 kernel
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 5
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: Kernel and Drivers maintainers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on: 16655
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 16:16 CEST by eric gerbier
Modified: 2018-04-28 19:06 CEST (History)
1 user (show)

See Also:
Source RPM: kernel-3.19.8-3.mga5.src.rpm ?
CVE:
Status comment:


Attachments

Description eric gerbier 2015-09-15 16:16:30 CEST
Description of problem:

I an running Mageia linux on a dell poweredge 1950, with a broadcom ethernet card (Broadcom Corporation NetXtreme II BCM5708 Gigabit Ethernet ) It uses the bnx2 driver, which is provided by the kernel-firmware-nonfree package.
The server provides http (apache) and ftp (vsftpd) services.

with Mageia 2, 3, 4, I had no problems, but with Mageia 5, some users reports network access problems, on ftp and http. I had a tcpdump, I can see many ack dup and retransmission packets.

I then reboot the mageia 5 with an old mageia 4 kernel (3.14.41-server-1.mga4) and all problems are solved.


Version-Release number of selected component (if applicable):
kernel-server-latest-3.19.8-3.mga5
kernel-server-3.19.8-3.mga5-1-1.mga5
kernel-server-3.14.41-1.mga4-1-1.mga4
kernel-firmware-20150309-1.mga5
kernel-firmware-nonfree-20150510-1.mga5.nonfree

How reproducible:

boot on kernel-server-3.19.8-3.mga5-1-1.mga5

Steps to Reproduce:
1.
2.
3.


Reproducible: 

Steps to Reproduce:
Comment 1 Samuel Verschelde 2015-09-16 09:54:49 CEST
Thanks for the report. Assigning to our kernel maintainer. You might want to test the 4.1 kernel that is currently in Core/Updates Testing to see if it fixes your issue.

Assignee: bugsquad => tmb

Comment 2 eric gerbier 2015-09-16 11:05:21 CEST
I have also tried the kernel-tmb-desktop-latest-3.19.8-1.mga5 package : same problem

I can't find any 4.1 kernel on update_testing (http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/distrib/5/x86_64/media/core/updates_testing/).

So I installed the 4.1 kernel from cauldron :
kernel-server-4.1.6-5.mga6-1-1.mga6
kernel-firmware-nonfree-20150722-1.mga5.nonfree
kernel-firmware-20150722-1.mga5

and it seems to work. I will wait a day to confirm (or not)
Comment 3 eric gerbier 2015-09-16 17:38:03 CEST
the network is better with kernel 4.1.6, but now the server hangs with the following message :

Sep 16 16:53:50 esurfmar.meteo.fr kernel: INFO: rcu_sched detected stalls on CPUs/tasks: { 0} (detected by 2, t=6002 jiffies, g=94332, c=943
Sep 16 16:53:50 esurfmar.meteo.fr kernel: Task dump for CPU 0:
Sep 16 16:53:50 esurfmar.meteo.fr kernel: swapper/0       R  running task        0     0      0 0x00200008
Sep 16 16:53:50 esurfmar.meteo.fr kernel:  0000000000000000 0000000000000000 0000000000000000 ffffffff81c04000
Sep 16 16:53:50 esurfmar.meteo.fr kernel:  0000000000000000 ffffffffffffff10 ffffffff8101eb2c 0000000000000010
Sep 16 16:53:50 esurfmar.meteo.fr kernel:  0000000000000246 ffffffff81c03ea8 0000000000000018 0000000000000000
Sep 16 16:53:50 esurfmar.meteo.fr kernel: Call Trace:
Sep 16 16:53:50 esurfmar.meteo.fr kernel:  [<ffffffff8101eb2c>] ? mwait_idle+0x8c/0x150
Sep 16 16:53:50 esurfmar.meteo.fr kernel:  [<ffffffff8101f49f>] ? arch_cpu_idle+0xf/0x20
Sep 16 16:53:50 esurfmar.meteo.fr kernel:  [<ffffffff810b2af7>] ? cpu_startup_entry+0x327/0x3a0
Sep 16 16:53:50 esurfmar.meteo.fr kernel:  [<ffffffff816ef59c>] ? rest_init+0x7c/0x80
Sep 16 16:53:50 esurfmar.meteo.fr kernel:  [<ffffffff81d31f7a>] ? start_kernel+0x42d/0x43a
Sep 16 16:53:50 esurfmar.meteo.fr kernel:  [<ffffffff81d31120>] ? early_idt_handler_array+0x120/0x120
Sep 16 16:53:50 esurfmar.meteo.fr kernel:  [<ffffffff81d31339>] ? x86_64_start_reservations+0x2a/0x2c
Sep 16 16:53:50 esurfmar.meteo.fr kernel:  [<ffffffff81d31476>] ? x86_64_start_kernel+0x13b/0x14a
Comment 4 Thomas Backlund 2015-09-16 20:47:28 CEST
Yep, that's one of the reasons I pulled 4.1.6 from testing...

I'm working on a 4.1.7 that should land on mirrors tonight /tomorrow
Comment 5 Thomas Backlund 2015-09-18 15:10:13 CEST
There is now a 4.17 in testing to try out

Depends on: (none) => 16655

Comment 6 eric gerbier 2015-09-21 08:48:46 CEST
I have installed kernel-server-4.1.7-1.mga5-1-1.mga5 on Thu 17 Sep 2015
and all seems fine :
- no more network problem
- no more rcu problems

thanks for your help !
Comment 7 Marja Van Waes 2016-08-26 11:42:38 CEST
Mass-reassigning all bugs with "kernel" in the Source RPM field that are assigned to tmb, to the kernel packagers group, because tmb is currently MIA.

Assignee: tmb => kernel

Comment 8 Marja Van Waes 2018-04-28 19:06:34 CEST
(In reply to eric gerbier from comment #6)
> I have installed kernel-server-4.1.7-1.mga5-1-1.mga5 on Thu 17 Sep 2015
> and all seems fine :
> - no more network problem
> - no more rcu problems
> 
> thanks for your help !

Thanks for the feedback :-)

Closing

Resolution: (none) => FIXED
CC: (none) => marja11
Status: NEW => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.