Bug 16738 - cups takes up 100% of cpu, and HP 1300 printer setup fails horribly.
Summary: cups takes up 100% of cpu, and HP 1300 printer setup fails horribly.
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 5
Hardware: i586 Linux
Priority: Normal critical
Target Milestone: ---
Assignee: Thierry Vignaud
QA Contact:
URL: http://cups.org/str.php?L4605
Keywords: PATCH
Depends on:
Blocks: 18367
  Show dependency treegraph
Reported: 2015-09-11 15:53 CEST by w unruh
Modified: 2018-10-06 13:00 CEST (History)
5 users (show)

See Also:
Source RPM: cups
Status comment:


Description w unruh 2015-09-11 15:53:01 CEST
Description of problem:
I set up my HP 1300 printer using MCC/system-config-printer. When printing out a pdf file the printer would spew out reams of paper, with the first one having "text" slanting down to the right, and then an infinite number of blank pages.

The setup automatically chose the 
MakeModel HP LaserJet 1300 Series Postscript (recommended)

setup. This is badly broken. However system-config-printer does not allow you to choose, whether under hplip or usb as the choise of uri.
If you switch off the printer before running system-config-printer, you can choose, and when I chose

HP LaserJet 1300 - CUPS+Gutenprint v5.2.10
printing works. 

Ie, there seem to be two problems. Cups is broken with the recommended 
HP LaserJet 1300 Series Postscript
and system-config-printer does not allow any other choices, and furthermore chooses the broken configuration by default. 

(I have now wasted 5 hours of my life on this.)

Version-Release number of selected component (if applicable):

How reproducible:Always

Steps to Reproduce:
1.Use system-config-printer to set up the HP LaserJet 1300 printer
2.try to print a pdf file. (or anything but a text file-- a png also does not work-- it just hangs)


Steps to Reproduce:
Comment 1 w unruh 2015-09-26 08:48:21 CEST
Let me give more information.
The HP1300 is connected via usb 1.1 to the computer. 
I have now tried both the MGA5 x86_64 and MGA5 i586, and both have the same problems.

When I use either or system-config-printer, and change the printer setup,  cups begins to uses 100% of one of the two cores and keeps doing that for many minutes (usually I do not . Doing an strace on cupsd,It seems to be doing many epoll-wait during this time-- they are not timing out.

The printing is flakey. Using cups+gutenprint it sometimes works, and then sometimes it will not put out the last page of sequence of pages, and on the next print job, put out a page with one or to letters on it (eg 3Y on the bottom of the page).

If I switch back to MGA3, the printer and cups work perfectly. I have tried switching back and forth and it consistantly does not work in MGA5 and works in MGA3, so it is not a problem with the printer or the connection or the usb port.
Comment 2 w unruh 2015-09-26 23:02:29 CEST
While looking through the bugs list on cups.org, I came across STR #4605 applying it to the cups-2.0.2-5.mga5 package, it fixes the problem of cups taking up 100% of the cpu. This really needs to be pushed through.

People on Suse, Redhat, Ubuntu have had this problem with post 2.0 cups versions  so it is very common. It does not seem to be universal, so there may be some sort of race condition which triggers it, but I am not alone.

I still need to determine whether this does anything for the hp1300 problem. 
But nevertheless a patch needs to be pushed through for this bug
w unruh 2015-09-26 23:04:32 CEST

Summary: HP 1300 printer setup fails horribly. => cups takes up 100% of cpu, and HP 1300 printer setup fails horribly.
Source RPM: cups or system-config-printer => cups

Comment 3 w unruh 2015-09-27 21:00:54 CEST
cups-2.0.3 in updates_testing does include this patch. I have downloaded it,compiled it, and briefly run it to show that in cases in which that 100% load was triggered on 2.0.2, it is not triggered on 2.0.3

On the hp1300 front, running 2.0.2 with the patch still ran into problems. With the Pstscript (recommended) ppd, it loaded the file to the printer, but nothing printed and the download of one page went on "forever". With the Gutenprint+cups it printed for a while and then stopped working-- jobs just piled up waiting for something. The printer light never flashed but cups reported the job was active. switching off the printer did nothing for this. restarting cups did nothing. Rebooting did nothing. The only thing that worked was to erase the printer and reinstall it in system-config-printer.

It might have something to do with scanning, as the scanner was used before that printing stopped. (although the scanner had been used before that as well, and the printer worked). 

I will try installing 2.0.3 and see if that helps with the hp1300 problems.
Comment 4 Samuel Verschelde 2015-09-28 09:14:38 CEST
Thanks for the detailed report. Assigning to our cups maintainer. Try to investigate hplip too because it might not be 100% of cups' fault.

Please also attach /etc/cups/printers.conf and /var/log/cups/error_log.

This might also be of interest to debug the issue: http://fedoraproject.org/wiki/How_to_debug_printing_problems#Printing_troubleshooter

Keywords: (none) => PATCH
CC: (none) => contact, doktor5000
Assignee: bugsquad => thierry.vignaud

Comment 5 w unruh 2015-09-29 17:50:32 CEST
I have now added the patch STR 4605 to my cups, and the 100% of cpu has disappeared. 
Regarding the other issues regarding the Postscript (recommended)ppd spewing out millions of blank pages (well 10s until I switch off the printer), its behaviour has changed since I inserted that bug fix. Now the printer on the Postscript ppd just does nothing at all, and sits there with its light blinking. 

I have not been printing very much recently and so cannot tell if the printer is misbehaving on the "cups+gutenprint" ppd. Last time it was after about 20 pages of various print jobs that cups refused to print-- stuff jut piled up in the queue until I deleted the printer using system-config-printer and reinstalled it. 
But I have not had problems since, but not many pages printed either. 
Anyway, it certainly seems that that STR 4605 definitely needs to be incorporated into cups. Note that it is already incorporated in the cups 2.0.3 which has been languishing in update_testing since June.
Comment 6 Florian Hubold 2015-10-04 18:41:48 CEST
FWIW, this is the upstream report:

Gentoo has already added this for cups 2.0.2:

Ubuntu report for this issue:

And can you please test if this is fixed with the cups update candidate in core_updates_testing, which is cups-2.0.3-1.mga5 tracked via https://bugs.mageia.org/show_bug.cgi?id=16152

URL: (none) => http://cups.org/str.php?L4605

Comment 7 w unruh 2015-10-04 18:51:27 CEST
Yes, 2.0.3 does not display this bug. Please get this update out.
Comment 8 w unruh 2015-10-04 19:05:23 CEST
I read the comments there. Even if you cannot figure out 2.0.3 and the "reinstall printer" problem, the patch, str4605 needs to added to the current cups as a patch. There was a note that seemed to say that the current 2.0.2 already included this patch, but it does not. 

Note that even with this patch there are sometimes strange behaviours.
The Postscript (Recommended) ppd file either does not work, or it only works after a few minutes. cups-gutenprint ppd prints immediately on a text file and within a few seconds on a pdf. Under the Postscript ppd, it works with the above patch, but it takes about 3 minutes to print. I only tried once. 

I also had trouble printing from a remote printer-- nothing in error_log to indicate cups had even received the job, although the remote cups claimed the file had been transfered. Now I was playing with firewalls, etc on the way, so am not sure if that played into the problem. I will have to spend more time on this to see if it is cups on the hp1300 machine or something else.
Marja Van Waes 2016-05-05 10:22:15 CEST

Blocks: (none) => 18367

Comment 9 Marja Van Waes 2016-08-10 19:41:15 CEST
On the 25th of July, Phillipem uploaded the following packages to 
Cauldron's core/updates_testing:




@ Anyone reading this:

* If this bug is valid for you in cauldron, then please test whether updating your system-config-printer packages to version 1.5.7-5.mga6 fixes the problem and report back in this bug report.

* If you do not have this bug in cauldron, but you do run cauldron, then please update those packages, too, and report in bug 18367 whether they work as expected.

CC: (none) => makowski.mageia, marja11

Comment 10 Morgan Leijström 2018-04-18 11:37:00 CEST
Still valid?

CC: (none) => fri

Comment 11 Marja Van Waes 2018-10-06 13:00:07 CEST
No reply, so closing as OLD

Resolution: (none) => OLD

Note You need to log in before you can comment on or make changes to this bug.