Bug 16561 - ipython-2.3.0-1.mga4.noarch won't install
Summary: ipython-2.3.0-1.mga4.noarch won't install
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 4
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
Whiteboard: MGA4-64-OK advisory
Keywords: validated_update
Depends on:
Reported: 2015-08-10 09:00 CEST by Claire Revillet
Modified: 2015-08-21 20:55 CEST (History)
4 users (show)

See Also:
Source RPM: ipython-2.3.0-1.mga4.noarch
Status comment:


Description Claire Revillet 2015-08-10 09:00:36 CEST
drakrpm-update says that:

 ipython-2.3.0-1.mga4.noarch (because python-mglob is not satisfied)


Steps to Reproduce:
Philippe Makowski 2015-08-10 09:39:18 CEST

CC: (none) => makowski.mageia
Assignee: bugsquad => makowski.mageia

Comment 1 Philippe Makowski 2015-08-11 22:01:13 CEST
ipython-2.3.0-1.1.mga4.noarch from ipython-2.3.0-1.1.mga4.src is in update/testing for Mageia 4

Suggested Advisory
Updated ipython package.
ipython don't require any more python-mglob that is not in Mageia4.

Assignee: makowski.mageia => qa-bugs

Comment 2 Lewis Smith 2015-08-15 09:37:21 CEST
Testing Mageia 4 x64

It seems that this bug relates to updating iPython from 1.1.0 to 2.3.0 ; rather, not being able to.
Installed deliberately: ipython-1.1.0-3.mga4
It worked.

BEFORE this update:
Doing then, with normal repos enabled:
 # drakrpm-update ipython
yielded a lot of console O/P, a large 'Update Software Packages' window, and a small one saying "Yn anffodus, nid oes modd dewis y pecyn canlynol:
- ipython-2.3.0-1.mga4.noarch (python-mglob heb ei foddloni)"
which means "Unfortunately there is no way of selecting the following package ...
(python-mglob not satisfied)". The fault demonstrated.

This update: enabling Updates Testing repos in lieu of normal ones, repeating
 # drakrpm-update ipython
ignored the ipython parameter and showed everything applicable in Upates Testing. Never mind. Selecting just ipython 2.3.0 1.1 pulled in also python-simplegeneric:
 - ipython-2.3.0-1.1.mga4.noarch
 - python-simplegeneric-0.8.1-3.mga4.noarch
and the update went OK. So the fault is cleared, you *can* update iPython from 1.1.0 to 2.3.0 .

AFTER this update: ipython-2.3.0-1.1.mga4
and it worked.

CC: (none) => lewyssmith
Whiteboard: (none) => MGA4-64-OK

Comment 3 Samuel Verschelde 2015-08-18 10:55:46 CEST
Validating. Needs advisory to be uploaded, though.

Keywords: (none) => validated_update
CC: (none) => sysadmin-bugs

Olivier FAURAX 2015-08-18 20:32:35 CEST

CC: (none) => olivier

Rémi Verschelde 2015-08-21 16:28:50 CEST

Whiteboard: MGA4-64-OK => MGA4-64-OK advisory

Comment 4 Mageia Robot 2015-08-21 20:55:58 CEST
An update for this issue has been pushed to Mageia Updates repository.


Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.