Bug 16544 - sddm shows nothing but a black screen & cursor (sddm-greeter: QOpenGLShader: could not create shader)
Summary: sddm shows nothing but a black screen & cursor (sddm-greeter: QOpenGLShader: ...
Status: REOPENED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: KDE maintainers
QA Contact:
URL: https://github.com/sddm/sddm/issues/376
Whiteboard:
Keywords: IN_ERRATA6, UPSTREAM
: 19798 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-08-06 15:27 CEST by Marja Van Waes
Modified: 2019-03-03 20:14 CET (History)
7 users (show)

See Also:
Source RPM: sddm
CVE:
Status comment:


Attachments
journalctl -b output (147.36 KB, text/plain)
2015-12-17 08:08 CET, Marja Van Waes
Details
Xorg.0.log (16.83 KB, text/plain)
2015-12-17 08:09 CET, Marja Van Waes
Details

Description Marja Van Waes 2015-08-06 15:27:46 CEST
This is an upstream bug, but now filing it in our Bugzilla, so that the workaround is easier to find for us.

I found the upstream report when searching for the following that was in my journalctl -b output:

  sddm-greeter qopenglshader: could not create shader


Putting

  Option "DRI"  "false"

in the 'Section "Device"' for the intel in /etc/X11/xorg.conf fixes the problem. 
It also fixed Plasma5 easily crashing on this laptop when started from another DM (gdm, lightdm)

I only hit this problem on this "Intel 810 and later" laptop
https://wiki.mageia.org/en/User:Marja/QA/Hardware#IBM_ThinkPad_R50e
but not on any other "Intel 810 and later".

This was all in the third week of July, I'm not aware that anything related changed in Mageia, so did not try whether I can now safely remove
  Option "DRI"  "false"
Comment 1 Marja Van Waes 2015-08-06 15:30:39 CEST
s/when started from another DM/when started/

(not sure I really tried again from another DM since sddm works well!)
Comment 2 Florian Hubold 2015-12-13 16:09:36 CET
Should not be in bugzilla but in our errata if there's nothing we can fix IMHO.
Also according to upstream this particular bug should be fixed in 0.13, can you still reproduce in cauldron?

CC: (none) => doktor5000
Hardware: i586 => All
Assignee: bugsquad => doktor5000

Comment 3 Marja Van Waes 2015-12-14 08:54:33 CET
(In reply to Florian Hubold from comment #2)
> Should not be in bugzilla but in our errata if there's nothing we can fix
> IMHO.

Well, I was hoping for an upstream fix :-)
(And we don't start filling the errata this early in the development cycle)

> Also according to upstream this particular bug should be fixed in 0.13, can
> you still reproduce in cauldron?

Thanks for having spotted that. There is no way I can test, because this system is now affected by bug 17221 (sddm-greeter: Failed to create OpenGL context for format QSurfaceFormat), even on bare metal.

Assuming it's fixed, though, since you already pushed sddm-0.13.0 over a month ago.

Status: NEW => RESOLVED
Resolution: (none) => FIXED

Comment 4 Florian Hubold 2015-12-14 22:04:55 CET
(In reply to Marja van Waes from comment #3)
> (In reply to Florian Hubold from comment #2)
> > Should not be in bugzilla but in our errata if there's nothing we can fix
> > IMHO.
> 
> Well, I was hoping for an upstream fix :-)
> (And we don't start filling the errata this early in the development cycle)

development cycle? - that would have also affected mga5, so not early :p

> Assuming it's fixed, though, since you already pushed sddm-0.13.0 over a
> month ago.

Please reopen if it reoccurs.
Comment 5 Marja Van Waes 2015-12-17 08:05:29 CET
(In reply to Florian Hubold from comment #4)
> (In reply to Marja van Waes from comment #3)
> > (In reply to Florian Hubold from comment #2)
> > > Should not be in bugzilla but in our errata if there's nothing we can fix
> > > IMHO.
> > 
> > Well, I was hoping for an upstream fix :-)
> > (And we don't start filling the errata this early in the development cycle)
> 
> development cycle? - that would have also affected mga5, so not early :p

:-)

Mga6 development cycle

> 
> > Assuming it's fixed, though, since you already pushed sddm-0.13.0 over a
> > month ago.
> 
> Please reopen if it reoccurs.

after commenting
    Option "DRI"  "false"

it occurs again.

sddm-greeter segfaults and before that the "sddm-greeter qopenglshader: could not create shader" that made me find the upstream bug report, is still there.

I'll attach journalctl -b and Xorg.0.log (no errors, only one warning) later

Status: RESOLVED => REOPENED
Resolution: FIXED => (none)

Comment 6 Marja Van Waes 2015-12-17 08:08:52 CET
Created attachment 7286 [details]
journalctl -b output
Comment 7 Marja Van Waes 2015-12-17 08:09:32 CET
Created attachment 7287 [details]
Xorg.0.log
Comment 8 Marja Van Waes 2015-12-17 19:58:41 CET
In reply to (on IRC):

> 2015:12:17:16:00 < doktor5000> marja: for 
>                  https://bugs.mageia.org/show_bug.cgi?id=16544 - if you run
>                  startx do you get a normal X session ?

I never use startx, so don't know what is normal.

The following is all with 
   #    Option "DRI"  "false"
instead of
        Option "DRI"  "false"
:
 
When I run startx as root it starts an IceWM session as root (it looks normal to me, the background is red as it should be for root). 

When I run startx as normal user, then xinit loses the connection to X server.

When I use lightdm, then I can login to XFCE as normal user. 
However, I don't manage to login to anything else than XFCE, no matter how I try to toggle the "XF" button in the lightdm screen (nor left nor right clicking work)
Comment 9 Marja Van Waes 2015-12-17 19:59:32 CET
and XFCE works fine, then :-)
Marja Van Waes 2016-11-17 10:47:11 CET

See Also: (none) => https://bugs.mageia.org/show_bug.cgi?id=19798

Comment 10 Marja Van Waes 2016-11-17 18:49:18 CET
Bug 19798 seems to be about the same issue, and was also in a 32bit installation.

I'm hoping for some more information in that bug report than is available now.


Reassigning this bug to kde-team, since neoclust / kde team now maintains SDDM

Summary: sddm shows nothing but a black screen (and the mouse cursor) => sddm shows nothing but a black screen & cursor (sddm-greeter: QOpenGLShader: could not create shader)
Assignee: doktor5000 => kde

Marja Van Waes 2016-11-18 10:49:03 CET

Keywords: (none) => FOR_ERRATA6

Marja Van Waes 2016-11-18 11:44:27 CET

Keywords: FOR_ERRATA6 => IN_ERRATA6

Comment 11 Marja Van Waes 2016-12-17 18:31:55 CET
Still valid for Mageia-6-sta2-i586-DVD.iso of December 16.

After adding 

    Option "DRI"  "false"


again, SDDM and Plasma5 start fine
Comment 12 Marja Van Waes 2017-01-08 13:48:54 CET
Still valid for Mageia-6-sta2-LiveDVD-Plasma-i586-DVD.iso of January 6 
(from mageia6-pretesting, but it'll probably be made available for all QA testers, soon)
Comment 13 Marja Van Waes 2017-01-12 00:20:04 CET
*** Bug 19798 has been marked as a duplicate of this bug. ***

CC: (none) => swbutler38

Comment 14 Phil Terry 2017-08-08 00:13:11 CEST
Upgraded a mga5 1586 which was uptodate with updates using the online upgrade path to the released mga6. It booted to a back screen with a blinking cursor.

If I used a ALT-F2 login to root and drakdm changed to xdm I got a x greeter. Here I could login and got an icewm session. Running a terminal here I could run startkde and get the normal login plasma session.

Searching through journal logs I found error messages saying "no user sddm".

Searching online I found threads saying that user sddm had to be added to the video group.

So I did an "adduser sddm" and an "usermod -a -G video sddm", then a drakdm to reselect sddm and then rebooted. Everything was fine and dandy.

So for my online upgrade i586 mga5 to mga6 somewhere sddm user and group membership was not setup correctly.

Hope this helps.

CC: (none) => phil

Comment 15 Marja Van Waes 2019-03-03 18:29:22 CET
I can't tell whether this bug is still valid, because I do no longer have the ThinkPad R50e which suffered from it.

@ Herman

Do you know whether SDDM now works in current cauldron on that laptop without needing the workaround from comment #0 (so from the Description)?

CC: (none) => herman.viaene

Comment 16 Herman Viaene 2019-03-03 20:14:47 CET
I very much doubt I can test this as the regular M7 iso can be installed but does not boot unless in recovery mode.

Note You need to log in before you can comment on or make changes to this bug.