Bug 16505 - mod_perl 2.0.10 is required to work with Apache 2.4 and perl 5.22
Summary: mod_perl 2.0.10 is required to work with Apache 2.4 and perl 5.22
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: i586 Linux
Priority: Normal major
Target Milestone: Mageia 6
Assignee: Shlomi Fish
QA Contact:
URL:
Whiteboard: MGA5TOO
Keywords: FOR_ERRATA6
Depends on:
Blocks:
 
Reported: 2015-07-31 02:17 CEST by Frédéric Buclin
Modified: 2017-08-20 10:27 CEST (History)
2 users (show)

See Also:
Source RPM: apache-mod_perl-2.0.7-17.20130221svn1448245.mga5
CVE:
Status comment:


Attachments
patch for the mod_perl RPM (2.49 KB, patch)
2017-08-20 03:52 CEST, Frédéric Buclin
Details | Diff

Description Frédéric Buclin 2015-07-31 02:17:35 CEST
The mod_perl 2.0.9 documentation mentions that:

  http://search.cpan.org/~shay/mod_perl-2.0.9/Changes

  "Add support for Apache httpd-2.4.x."


Testing mod_perl with Bugzilla indeed shows that 2.0.8 and older do not work with Apache 2.4.x. But Mageia 5 released Apache 2.4.10 and mod_perl 2.0.7-17.20130221svn... i.e a snapshot which looks like to be 2.5 years old. It really needs to be updated to be usable.
Comment 1 David Walser 2015-07-31 16:42:45 CEST
This was discussed on IRC when 2.0.9 was released.  I was told that 2.0.9 still doesn't support perl 5.22, which is what we have in Cauldron.  It may have been that it doesn't support perl 5.20 either (Mageia 5), but I can't remember for sure.

Whiteboard: (none) => MGA5TOO
CC: (none) => mageia, pterjan
Version: 5 => Cauldron

Comment 2 Frédéric Buclin 2015-07-31 17:14:30 CEST
Perl 5.20 is supported, per their changelog.
Comment 3 Frédéric Buclin 2016-10-02 17:48:21 CEST
mod_perl 2.0.10 RC1 is just around the corner:

https://github.com/apache/mod_perl/commit/c9bd1e45

Its changelog mentions support for perl 5.22:

2.0.10-rc1

Automatically select the appropriate c89 option when modperl is being
built with either gcc 5 or clang.

Fix non-threaded Perl 5.22.x build and tests.

Add support for Perl 5.22.x.

Target Milestone: --- => Mageia 6
Summary: mod_perl 2.0.9 is required to work with Apache 2.4.x => mod_perl 2.0.10 is required to work with Apache 2.4 and perl 5.22

Comment 4 Samuel Verschelde 2016-10-10 22:38:44 CEST
Assigning to apache-mod_perl maintainer, Shlomi Fish

Assignee: bugsquad => shlomif

Comment 5 Frédéric Buclin 2016-10-29 17:45:48 CEST
mod_perl 2.0.10 final has been released two days ago:

http://www.apache.org/dyn/closer.cgi/perl/mod_perl-2.0.10.tar.gz
Comment 6 Frédéric Buclin 2017-03-21 20:13:05 CET
@Shlomi: ping?
Comment 7 Samuel Verschelde 2017-07-10 16:17:10 CEST
It would be good to add a note about this in the Errata, thus I'm adding the
FOR_ERRATA6 keyword.

Once added to https://wiki.mageia.org/en/Mageia_6_Errata please replace
FOR_ERRATA6 with IN_ERRATA6.

Keywords: (none) => FOR_ERRATA6

Comment 8 Frédéric Buclin 2017-08-20 03:52:38 CEST
Created attachment 9614 [details]
patch for the mod_perl RPM

I tested mod_perl 2.0.10 locally using Bugzilla 5.0.3 on Mageia 6, and it's working fine.

The patch doesn't include the new binary. Here is the link to download it:

http://www-eu.apache.org/dist/perl/mod_perl-2.0.10.tar.gz


Someone please commit and push. :)
Comment 9 Shlomi Fish 2017-08-20 10:27:58 CEST
Thanks Frederic!

(In reply to Frédéric Buclin from comment #8)
> Created attachment 9614 [details]
> patch for the mod_perl RPM
> 
> I tested mod_perl 2.0.10 locally using Bugzilla 5.0.3 on Mageia 6, and it's
> working fine.
> 
> The patch doesn't include the new binary. Here is the link to download it:
> 
> http://www-eu.apache.org/dist/perl/mod_perl-2.0.10.tar.gz
> 

You can put a similar URL in the .spec. I was able to build the mgarepo checkout, but noticed that it didn't complain about the PGP .asc file being missing. It should have. Anyway, I am going to submit it for now.
> 
> Someone please commit and push. :)

Note You need to log in before you can comment on or make changes to this bug.