Bug 16460 - Clocksource tsc unstable
Summary: Clocksource tsc unstable
Status: RESOLVED OLD
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 5
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: Kernel and Drivers maintainers
QA Contact:
URL:
Whiteboard:
Keywords: NEEDINFO
Depends on: 16655
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-23 22:24 CEST by Matthieu Duchemin
Modified: 2018-04-29 09:51 CEST (History)
2 users (show)

See Also:
Source RPM: kernel
CVE:
Status comment:


Attachments

Description Matthieu Duchemin 2015-07-23 22:24:21 CEST
Description of problem:

The kernel switch from tsc to refined-jiffies during boot.

Jul 21 08:40:35 localhost kernel: Clocksource tsc unstable (delta = 133764044 ns)
Jul 21 08:40:35 localhost kernel: Switched to clocksource refined-jiffies


with refined-jiffies, system clock is really slow, 4-5 times slower than real time.

I can switch back to tsc with 
echo tsc > /sys/devices/system/clocksource/clocksource0/current_clocksource

But tht system freeze ramdomly.

My hardware is a Baytrail based HP Pavilion x2 - 10-k020nf.

Tested with:
- kernel-desktop586-3.19.8-1.mga5-1-1
- kernel-tmb-desktop-3.19.8-1.mga5-1-1
- kernel-linus-3.19.8-2.mga5-1-1

I have tested Ubuntu 14.10 and the problem does not occur.



Reproducible: 

Steps to Reproduce:
David Walser 2015-07-30 18:16:34 CEST

Source RPM: (none) => kernel
Assignee: bugsquad => tmb

Comment 1 Thomas Backlund 2015-09-18 15:17:21 CEST
is 4.1.7 in testing working any better ?

Depends on: (none) => 16655

Comment 2 Matthieu Duchemin 2015-09-21 22:20:32 CEST
tested with 4.1.8-1

Same problem. The clocksource siwtched to refined-jiffies and the clock is still slow.

kernel: timekeeping watchdog: Marking clocksource 'tsc' as unstable, because the skew is too large: 
kernel:         'refined-jiffies' wd_now: fffbf891 wd_last: fffbf69c mask: ffffffff
kernel:         'tsc' cs_now: 1a9335e0f0 cs_last: 1a6675c050 mask: ffffffffff
kernel: Switched to clocksource refined-jiffies
Comment 3 Marja Van Waes 2016-08-26 11:43:23 CEST
Mass-reassigning all bugs with "kernel" in the Source RPM field that are assigned to tmb, to the kernel packagers group, because tmb is currently MIA.

Assignee: tmb => kernel

Comment 4 Thierry Vignaud 2016-10-05 07:48:50 CEST
What about newer kernels?

CC: (none) => thierry.vignaud
Keywords: (none) => NEEDINFO

Comment 5 Marja Van Waes 2018-04-29 09:50:51 CEST
(In reply to Thierry Vignaud from comment #4)
> What about newer kernels?

It's 2½ years later, still no reply.

Closing as OLD.

Status: NEW => RESOLVED
Resolution: (none) => OLD
CC: (none) => marja11

Comment 6 Marja Van Waes 2018-04-29 09:51:25 CEST
s/2½/1½/

Note You need to log in before you can comment on or make changes to this bug.