Bug 16200 - areca won't start after upgrade from Mageia 4
Summary: areca won't start after upgrade from Mageia 4
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal critical
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA6-64-OK
Keywords: advisory, validated_update
: 16240 (view as bug list)
Depends on:
Blocks: 16241
  Show dependency treegraph
 
Reported: 2015-06-24 18:58 CEST by Stephan Mueller
Modified: 2018-04-22 21:59 CEST (History)
5 users (show)

See Also:
Source RPM: areca-backup-7.5-2.mga6.src.rpm
CVE:
Status comment:


Attachments
Screenshot (19.62 KB, image/png)
2018-04-15 20:41 CEST, Stephan Mueller
Details

Description Stephan Mueller 2015-06-24 18:58:41 CEST
Description of problem:
Areca won't start and throws these errors:
ls: Zugriff auf /usr/java nicht möglich: Datei oder Verzeichnis nicht gefunden
No valid JRE found in /usr/java.

which is correct, there is no /usr/java . I don't know why it isn't able to find the JRE. 

rpm -qa|grep -i java
javapackages-tools-4.1.0-15.mga5
timezone-java-2015d-1.mga5
rootcerts-java-20150420.00-1.mga5
java-1.8.0-openjdk-headless-1.8.0.45-6.b14.1.mga5
lib64javascriptcore-gir3.0-2.4.8-2.mga5
liblog4j12-java-1.2.17-7.mga5
lib64javascriptcoregtk3.0_0-2.4.8-2.mga5
python-javapackages-4.1.0-15.mga5
javamail-1.5.1-1.mga5
java-1.8.0-openjdk-1.8.0.45-6.b14.1.mga5
lib64javascriptcoregtk1.0_0-2.4.8-2.mga5
liblog4j-java-1.2.17-3.mga3

java -version
openjdk version "1.8.0_45"
OpenJDK Runtime Environment (build 1.8.0_45-b14)
OpenJDK 64-Bit Server VM (build 25.45-b02, mixed mode)

Version-Release number of selected component (if applicable):
7.4.7

How reproducible:
100%

Steps to Reproduce:
1. try running /usr/share/areca-backup/areca.sh
2.
3.


Reproducible: 

Steps to Reproduce:
David Walser 2015-06-24 20:00:17 CEST

Assignee: bugsquad => matteo.pasotti

Comment 1 David Walser 2015-06-29 00:58:11 CEST
*** Bug 16240 has been marked as a duplicate of this bug. ***

CC: (none) => steve

David Walser 2015-06-29 00:58:38 CEST

Blocks: (none) => 16241

Comment 2 Marja Van Waes 2018-04-14 10:48:41 CEST Comment hidden (obsolete)

Status: NEW => RESOLVED
CC: (none) => marja11
Resolution: (none) => OLD

Comment 3 Matteo Pasotti 2018-04-15 16:38:50 CEST
As this bug was also affecting mga6, I made a patch to make it fully functional again.

Advisory:
========================
I have uploaded a patched package for Mageia 6.
You can test it by launching /usr/share/areca-backup/areca.sh and waiting for areca backup GUI to appear.

It will spawn some Gtk-WARNING but it will not prevent areca from working well.

Updated packages in core/updates_testing:
========================
areca-backup-7.5-2.1.mga6

SOURCES:
areca-backup-7.5-2.1.mga6.src.rpm

Version: 5 => 6
Status: RESOLVED => REOPENED
Resolution: OLD => (none)
Source RPM: areca-backup-7.4.7-3.mga5.src.rpm => areca-backup-7.5-2.mga6.src.rpm

Matteo Pasotti 2018-04-15 16:39:23 CEST

Assignee: matteo.pasotti => qa-bugs

Comment 4 Stephan Mueller 2018-04-15 17:41:17 CEST
Okay, with the mentioned patch installed the gui will start up again, thanks. It is still not usable since there is a dialogue showing up saying that I used it more than 96 times and I should consider making a donation. This dialogue can't be closed and blocks usage of the actual gui. Clicking the close button doesn't work, closing the window through the little x doesn't work either.
Comment 5 Matteo Pasotti 2018-04-15 19:55:35 CEST
Hi Stephan, can you provide some screenshot of this nag screen?
It should definitely not be blocking.

CC: (none) => matteo.pasotti

Comment 6 Matteo Pasotti 2018-04-15 20:28:40 CEST
Pushed a new package to the bs, refer to areca-backup-7.5-2.2.mga6 that ships with a workaround for a GTK3 related issue.

This w/a will prevent critical error on 
   [libgdk-x11-2.0.so.0+0x4d784]  gdk_display_open+0x44
that makes areca-backup suddenly crash.

Give it a try, pls.
Comment 7 Stephan Mueller 2018-04-15 20:41:45 CEST
Created attachment 10084 [details]
Screenshot
Comment 8 Stephan Mueller 2018-04-15 20:47:50 CEST
Sorry, I'm not sure what you mean by bs. Will this show up under updates_testing ?
Comment 9 Marja Van Waes 2018-04-15 20:54:14 CEST
(In reply to Stephan Mueller from comment #8)
> Sorry, I'm not sure what you mean by bs. Will this show up under
> updates_testing ?

Yes, it will. With "bs" Matteo meant our "Build Server", you can see the progress of packages getting built here: http://pkgsubmit.mageia.org/

areca-backup-7.5-2.2.mga6 is green there, which means it did build successfully and is landing on the mirrors
Comment 10 Len Lawrence 2018-04-16 12:02:36 CEST
Mageia 6, x86_64

Tried this out before updating and could not even launch it.

Updated areca-backup and it launched without a problem.
Explored the interface and accessed the online tutorial via the Help button.
Set up a backup directory on a data disk, created a group and a target and ran a full directory backup of Documents using zip compression on each file.  Made an external check that the backup had been made and then recovered the whole backup to a temporary local folder.  All present and correct.

This can be sent on.

Whiteboard: (none) => MGA6-64-OK
CC: (none) => tarazed25

Comment 11 Stephan Mueller 2018-04-16 13:59:39 CEST
I have the same problem as before. The look of the dialogue changed slightly but it still can't be closed.
Comment 12 Matteo Pasotti 2018-04-16 20:39:47 CEST
Can you provide your configuration file inside ~/.areca (be sure to strip sensitive data)
Comment 13 Stephan Mueller 2018-04-16 20:51:37 CEST
Here it is:

#Areca user preferences
#Mon Apr 16 20:30:01 CEST 2018
mainframe.x=0
ws.history.0=/home/matt/.areca/workspace
lastworkspace=/home/matt/.areca/workspace
check.force.default.location.59425332=false
mainframe.width=1920
launch.count=98
show.transaction.ziparchive.incompatibility.warning=true
mainframe.leftsplitpos=70
check.specific.location.1564030619=/home/matt/hdd
check.specific.location.1126279777=/home/matt/hdd
check.specific.location.844269531=/home/matt/hdd
check.specific.location.844269531=/home/matt/hdd
mainframe.mainsplitpos=30
check.force.default.location.1564030619=false
mainframe.height=1135
dnt.msg.day=5913
check.force.default.location.844269531=false
check.force.default.location.1126279777=false
mainframe.maximized=true
mainframe.y=0
Comment 14 Stephan Mueller 2018-04-16 20:54:26 CEST
If I change the "launch.count" to a lower value I can access the interface just fine since the dialogue doesn't appear but obviously this is only a temporary solution.
Comment 15 Matteo Pasotti 2018-04-17 00:02:06 CEST
I was able to reproduce the same issue.

It seems that the DonationWindow get stuck.

I'm working on it.
Comment 16 Matteo Pasotti 2018-04-17 07:45:44 CEST
areca-backup-7.5-2.3.mga6 is on its way, tested here and worked properly (i.e. the donation window can be closed)
Comment 17 Len Lawrence 2018-04-17 10:16:08 CEST
Since I did not see the donation message after the update my testing does not help with this.  launch.count=1 in the preferences file.
dnt.msg.day=6586
Comment 18 Matteo Pasotti 2018-04-17 10:51:29 CEST
You can force a launch.count greater than 96 to make it visible and test it.
Comment 19 Len Lawrence 2018-04-17 10:56:35 CEST
Yes, already tried that, with very large counts, and still no donation window.  The count is incremented, as expected.

Removing the 64-bit OK for the time being.

Whiteboard: MGA6-64-OK => (none)

Comment 20 Len Lawrence 2018-04-17 13:26:12 CEST
Tried again with version .3 and recovered a target backup without any problem.  The launch count went up to 490 but there was no request for a donation.  dnt.msg.day remains stuck at 6586.  Wondering if that is some kind of threshold but that would imply a history of 18 years or more.  Maybe it is a count of the number of donations to date.
Comment 21 Matteo Pasotti 2018-04-17 20:25:15 CEST
If the proposed update works properly please confirm it so it can be pushed to the repository. If you want, we can deep the understanding of the areca preferences in pvt or using another channel (e.g. forum, IRC, etc).
Thanks for your kindness and your understanding.
Len Lawrence 2018-04-17 23:53:26 CEST

Keywords: (none) => validated_update
Whiteboard: (none) => MGA5-64-OK
CC: (none) => sysadmin-bugs

Len Lawrence 2018-04-17 23:54:46 CEST

Whiteboard: MGA5-64-OK => MGA6-64-OK

Matteo Pasotti 2018-04-18 08:31:45 CEST

Hardware: x86_64 => All

Comment 22 Stephan Mueller 2018-04-19 18:20:38 CEST
I hate to say this but it still doesn't work. But we are getting there. Updated to 7.5-2.3, increased launch.count so the donation request pops up- now I can close the dialogue but the gui is dead, it doesn't matter where I click, there is no reaction, it can't even be closed via the gui, I have to kill it with CTRL+C.
Comment 23 Lewis Smith 2018-04-20 09:01:53 CEST
UNvalidating etc due to the previous comment. c19-20 are not encouraging either.

Whiteboard: MGA6-64-OK => (none)
Keywords: validated_update => (none)

Comment 24 Matteo Pasotti 2018-04-20 23:04:25 CEST
areca-backup-7.5-2.4.mga6 landed on updates_testing.

It provides a patch that disable the Donation Window that causes areca-backup to suddenly freeze.

Try this new package by creating a new ~/.areca directory (rename the old one to save you preferences) and then forcing the launch.count to values greater than 96.

No windows should appear.

You can still support the development of areca-backup by clicking the About menu (consider that the developer last released on august 2015).

Let me know if it properly works (local tests was successful).
Comment 25 Len Lawrence 2018-04-21 01:49:30 CEST
Mageia 6, x86_64

Installed the update and ran through the create target steps and backed up the Documents directory.  Made a backup of my ruby directory after relaunching areca-backup with the launch count advanced to 97.  No nag-screen appeared.  Both targets were stored on a local data disk.  Recovered both in full to directories in user home.  Shall try incremental backups and other tests later.

Hoping Stephan will try this.
Comment 26 Len Lawrence 2018-04-21 09:39:00 CEST
Added some files to the Documents folder and performed an incremental backup.  That worked fine and a recovery operation specifying newer files only also succeeded.  This certainly looks good for 64-bits but needs confirmation from Stephan.
Comment 27 Stephan Mueller 2018-04-22 13:35:48 CEST
Okay, that did the trick, the donation window is gone and everything works as expected (version 7.5-2.4)

Thank you !
Comment 28 Len Lawrence 2018-04-22 19:00:05 CEST
Thanks Stephan.  We'll send this on.

Whiteboard: (none) => MGA6-64-OK

Comment 29 Lewis Smith 2018-04-22 20:29:18 CEST
Well done, testers! What a haul it was.

Keywords: (none) => advisory, validated_update

Comment 30 Mageia Robot 2018-04-22 21:59:51 CEST
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2018-0062.html

Resolution: (none) => FIXED
Status: REOPENED => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.