Bug 16187 - German localisation issue in drakrpm-editmedia (Unable to parse accelerator '<Strg>-U' for action 'Update')
Summary: German localisation issue in drakrpm-editmedia (Unable to parse accelerator '...
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 5
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA5-32-OK advisory MGA6-64-OK
Keywords: validated_update
Depends on:
Blocks:
 
Reported: 2015-06-23 13:26 CEST by Rémi Verschelde
Modified: 2017-03-25 17:57 CET (History)
8 users (show)

See Also:
Source RPM: rpmdrake-6.20-1.mga5
CVE:
Status comment:


Attachments

Description Rémi Verschelde 2015-06-23 13:26:17 CEST
When starting drakrpm-editmedia from the command line with the German locale, those warnings appear:

(drakrpm-editmedia:2869): Gtk-WARNING **: Unable to parse accelerator '<Strg>-U' for action 'Update'
(drakrpm-editmedia:2869): Gtk-WARNING **: Unable to parse accelerator '<Strg>-M' for action 'Add_a_specific_mirror'
(drakrpm-editmedia:2869): Gtk-WARNING **: Unable to parse accelerator '<Strg>-A' for action 'Add_a_custom_medium'
(drakrpm-editmedia:2869): Gtk-WARNING **: Unable to parse accelerator '<Strg>-W' for action 'Close'
(drakrpm-editmedia:2869): Gtk-WARNING **: Unable to parse accelerator '<Strg>-G' for action 'Global_options'
(drakrpm-editmedia:2869): Gtk-WARNING **: Unable to parse accelerator '<Strg>-K' for action 'Manage_keys'
(drakrpm-editmedia:2869): Gtk-WARNING **: Unable to parse accelerator '<Strg>-P' for action 'Parallel'
(drakrpm-editmedia:2869): Gtk-WARNING **: Unable to parse accelerator '<Strg>-R' for action 'Proxy'

<Strg> in German is AFAIK supposed to be the <Ctrl> key, but somehow it does not work, so these warnings are issued and the hotkeys are not working in the GUI.

I guess it's a localisation issue, though I haven't checked the PO file yet.

Reproducible: 

Steps to Reproduce:
Rémi Verschelde 2015-06-23 13:29:47 CEST

CC: (none) => linux, marc.lattemann, thierry.vignaud

Comment 1 Thierry Vignaud 2015-06-23 15:15:22 CEST
The "<Ctrl>" part shouldn't have been translated at all...
Comment 2 Rémi Verschelde 2015-06-23 15:15:58 CEST
Yes that's what I guessed.
Comment 3 psyca 2015-06-23 15:54:38 CEST
This affects MGA4, too.
<control> was translated to <strg>.

I changed it in transifex (change to <control>)

This affects

rpmdrake
drakx_standalone
drakx-net
userdrake2

Whiteboard: (none) => MGA4TOO

Comment 4 psyca 2015-06-23 19:03:31 CEST
Allright, Yuri pushed tx to git now.
Comment 5 Rémi Verschelde 2015-06-23 20:25:22 CEST
Thanks psyca, I'll backport the fixes for mga4 and mga5 as soon as I find how to create the distro/mga5 branch :)
Comment 6 Rémi Verschelde 2015-10-05 09:16:26 CEST
(In reply to Rémi Verschelde from comment #5)
> I'll backport the fixes for mga4 and mga5 as soon as I find
> how to create the distro/mga5 branch :)

I forgot about it, so assigning the bug to myself.

Assignee: bugsquad => rverschelde

psyca 2016-10-10 21:34:52 CEST

Whiteboard: MGA4TOO => (none)

Comment 7 Rémi Verschelde 2017-03-11 10:28:56 CET
I finally got to fixing this issue.

Given the changelog since Mageia 5's rpmdrake 6.20 (mostly translation updates), I decided to push an adapted version of Cauldron's 6.24 for Mageia 5, as version 6.20.1. The main difference with 6.24 is that it does not contain the new icons from Animtim, nor the updates to the GUI packages list.

http://gitweb.mageia.org/software/rpmdrake/log/?h=distro/mga5

CC: (none) => mageiatools
Assignee: rverschelde => qa-bugs

Comment 8 Rémi Verschelde 2017-03-11 10:32:36 CET
Advisory:
=========

Updated rpmdrake package improves translations

  This update to Mageia's rpmdrake software improves the translations for many
  languages, including a translation bug fix (mga#16187).

  It also adds tooltips for the arch and status columns (mga#7962) and prevents
  an issue when copying text (mga#18569).

References:
 - http://gitweb.mageia.org/software/rpmdrake/log/?id=6.20.1
 - https://bugs.mageia.org/show_bug.cgi?id=7962
 - https://bugs.mageia.org/show_bug.cgi?id=16187
 - https://bugs.mageia.org/show_bug.cgi?id=18569


RPM in core/updates_testing:
============================

rpmdrake-6.20.1-1.mga5.noarch


SRPM in core/updates_testing:
=============================

rpmdrake-6.20.1-1.mga5
Comment 9 Herman Viaene 2017-03-17 11:40:50 CET
MGA5-32 on Asus A6000VM Xfce (originally installed in Dutch).
After a lot of fiddling to change localization I get to a point where at CLI as root:
# locale
LANG=de_BE.utf8
LC_CTYPE="de_BE.utf8"
LC_NUMERIC="de_BE.utf8"
LC_TIME="de_BE.utf8"
LC_COLLATE="de_BE.utf8"
LC_MONETARY="de_BE.utf8"
LC_MESSAGES="de_BE.utf8"
LC_PAPER="de_BE.utf8"
LC_NAME="de_BE.utf8"
LC_ADDRESS="de_BE.utf8"
LC_TELEPHONE="de_BE.utf8"
LC_MEASUREMENT="de_BE.utf8"
LC_IDENTIFICATION="de_BE.utf8"
LC_ALL=

and 
# drakrpm-editmedia 
Ignore the following Glib::Object::Introspection & Gtk3 warnings
Subroutine Gtk3::main redefined at /usr/lib/perl5/vendor_perl/5.20.1/Gtk3.pm line 296.
getting exclusive lock on urpmi
wrote config file [/etc/urpmi/urpmi.cfg]
unlocking urpmi database

So I cannot reproduce the problem here. To be remarked that MCC itself completely comes in English.

CC: (none) => herman.viaene

Comment 10 Marja van Waes 2017-03-17 11:56:57 CET
(In reply to Herman Viaene from comment #9)

> 
> So I cannot reproduce the problem here. To be remarked that MCC itself
> completely comes in English.

To start the tool in German, the easiest way is to run
 
            LANGUAGE=de drakrpm-editmedia

MCC can be started like that in German, too:

            LANGUAGE=de mcc

CC: (none) => marja11

Comment 11 Herman Viaene 2017-03-17 12:19:56 CET
# LANGUAGE=de drakrpm-editmedia
Ignore the following Glib::Object::Introspection & Gtk3 warnings
Subroutine Gtk3::main redefined at /usr/lib/perl5/vendor_perl/5.20.1/Gtk3.pm line 296.
getting exclusive lock on urpmi
wrote config file [/etc/urpmi/urpmi.cfg]
unlocking urpmi database

So, that is the same (what I expected in this case in view of the locale command results. And yes, the tool is even with this command completely in English, so there must be still something missing.
Comment 12 Rémi Verschelde 2017-03-17 12:30:25 CET
To get the German translation, you need to install rpmdrake *after* locales-de, otherwise the German translation files will not be installed as apparently unneeded (like for all other languages).

You could try `urpmi --replacepkgs --replacefiles rpmdrake` and see if that works.
Comment 13 Herman Viaene 2017-03-17 14:17:43 CET
Testing bug 20477 draws in a new version of rpmdrake 6.20.1-1. The result is that rmpdrake is now in German, but the rest of MCC is still in English.
So I can now confirm that the issue with drakrpm-editmedia is solved since I get now
# drakrpm-editmedia 
Ignore the following Glib::Object::Introspection & Gtk3 warnings
Subroutine Gtk3::main redefined at /usr/lib/perl5/vendor_perl/5.20.1/Gtk3.pm line 296.
getting exclusive lock on urpmi
wrote config file [/etc/urpmi/urpmi.cfg]
unlocking urpmi database
using a German version.

Whiteboard: (none) => MGA5-32-OK

Comment 14 Dave Hodgins 2017-03-25 00:50:01 CET
Validating the update, based on rpmdrake also working ok on x86_64.

Keywords: (none) => validated_update
Whiteboard: MGA5-32-OK => MGA5-32-OK advisory MGA6-64-OK
CC: (none) => davidwhodgins, sysadmin-bugs

Comment 15 Mageia Robot 2017-03-25 17:57:25 CET
An update for this issue has been pushed to the Mageia Updates repository.

http://advisories.mageia.org/MGAA-2017-0013.html

Status: NEW => RESOLVED
Resolution: (none) => FIXED


Note You need to log in before you can comment on or make changes to this bug.