Bug 16092 - Gnome, All Live Media, Firefox, no sound
Summary: Gnome, All Live Media, Firefox, no sound
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: i586 Linux
Priority: Low minor
Target Milestone: ---
Assignee: ISO building group
QA Contact:
Whiteboard: MGA5TOO
Depends on:
Reported: 2015-06-08 16:39 CEST by William Kenney
Modified: 2017-03-13 20:46 CET (History)
3 users (show)

See Also:
Source RPM:
Status comment:


Description William Kenney 2015-06-08 16:39:42 CEST
Description of problem:

Launch any Gnome Live media. i586 Live-CD, i586 Live-DVD, x86_64 Live-DVD

Open Firefox, open YouTube.com

Play any video. No sound. Live media plays MP3 files just fine. All other sound functions seem to work fine.


Steps to Reproduce:
William Kenney 2015-06-08 16:40:35 CEST

Priority: Normal => High
Whiteboard: (none) => M5final

Comment 1 Samuel Verschelde 2015-06-08 16:45:02 CEST
Does it work in KDE Live media?

Whiteboard: M5final => M5final FOR_ERRATA

Comment 2 Samuel Verschelde 2015-06-08 17:17:23 CEST
Could it be bug 15043? Does it work if you add flash-player-plugin?
Comment 3 William Kenney 2015-06-08 17:34:00 CEST
(In reply to Samuel VERSCHELDE from comment #2)
> Could it be bug 15043? Does it work if you add flash-player-plugin?

In you install from the gnome desktop the problem will be in the install. If If you then install flash there is sound.
Comment 4 Samuel Verschelde 2015-06-08 17:40:33 CEST
Ok, it's the same bug, then. Firefox without flash will not play sound from h264 videos.

You might want to help writing the Errata entry for bug 15043

*** This bug has been marked as a duplicate of bug 15043 ***

Resolution: (none) => DUPLICATE

Comment 5 William Kenney 2015-06-08 17:52:57 CEST
Why then does it work in KDE live media.
Comment 6 Samuel Verschelde 2015-06-08 18:00:00 CEST
(In reply to William Kenney from comment #5)
> Why then does it work in KDE live media.

Well, you hadn't confirmed this point when I asked, I supposed it didn't.

It looks like the same bug, but I think we haven't identified precisely enough in bug 15043 what causes it. Worth some investigation, maybe there's still a way to fix it in GNOME Lives. Reopening for now.

Resolution: DUPLICATE => (none)

Comment 7 William Kenney 2015-06-08 18:16:19 CEST
Note that I am away from home today and not able to do testing.
But, I can confirm that what testing I did do I confirmed that M5 KDE Live media,
KDE i586 Live-CD, i586 Live-DVD, x86_64 Live-DVD.  All present YouTube Videos with sound. No modifications required.
Comment 8 Sander Lepik 2015-06-08 19:21:11 CEST
Did this also happen with RC ISOs? Or are we dealing with a regression in final ISOs? I tested Gnome LiveDVD (i586) RC and all videos that worked with HTML5 player had sound.

I'll see if I can test with latest ISOs too.

CC: (none) => mageia

Comment 9 William Kenney 2015-06-08 20:29:56 CEST
My prerelease testing involves mostly KDE. So it was not until I think Friday that I looked at the Live Media both KDE & Gnome for things like Firefox operation. I check all the ISO's for boot to a working desktop, Firefox open CNN, Gedit, File mgr, terminal. But just for yuks I tried Gnome/Firefox/play YouTube video. So I kinda stumbled across it. So I can't say how long this has been around or not.
Comment 10 Sander Lepik 2015-06-08 20:44:09 CEST
OK.. Tested with final ISO and I can confirm that sound in YouTube is now missing. The weird part is that there are no big changes in packages. Only in package versions. So some update to one of the packages broke sound. And the only one that could probably affect this is ffmpeg (2.4.7 -> 2.4.9).


I downloaded LiveDVD with KDE4 as well and guess what - sound is working there!

So I have no idea what broke it for Gnome. It's probably fixable with an update but we would have to figure out what went wrong :/
Comment 11 William Kenney 2015-06-08 20:58:54 CEST
(In reply to Sander Lepik from comment #10)

> I downloaded LiveDVD with KDE4 as well and guess what - sound is working
> there!
> So I have no idea what broke it for Gnome. It's probably fixable with an
> update but we would have to figure out what went wrong :/

Super, many many thanks for confirming that it works on KDE Live media..
Comment 12 Sander Lepik 2015-06-09 15:44:54 CEST
Ok, I figured out why it's working on KDE LiveDVD and not with the Gnome one. Gnome LiveDVD has gstreamer plugins installed and so tries to play the h264 version of the video (which seems like bug #15043). On the KDE LiveDVD we have no such plugins installed, so Firefox plays webm which has sound..

To fix the problem with Gnome you just have to enable Tainted repos and update.

I'm not sure why it worked with the RC ISO.
Comment 13 William Kenney 2015-06-11 18:21:28 CEST
After you boot to the desktop:

MCC -> Software Management -> Configure media sources - Add sources
MCC -> Software Management -> Install & Remove Software
Find: task-codec-audio tainted & task-codec-video tainted
everything works fine

I'm gonna reduce the Priority to Low, Severity to minor

Priority: High => Low
Severity: major => minor

Comment 14 Renato Dali 2015-07-18 23:39:34 CEST
Hi, William, I reached the same conclusions as you. I've written about it on bug 15043. I carelessly didn't notice the reference to the present bug as duplicate (and yet with your interesting observations).

One minor nitpick I have is that in the past, I was used to enabling the tainted repos and just updating (or rather, waiting for the applet to warn me about available updates).

That part about finding the packages (task-codec-*) and manually asking to updating them I find annoying. I'd like to know whether that is a feature or a bug...

On the whole though, after that fix, things are really working very well. Mageia really keeps the magic alive...

CC: (none) => mkare

Samuel Verschelde 2016-10-18 13:12:19 CEST

Whiteboard: M5final FOR_ERRATA => MGA5TOO

Samuel Verschelde 2016-11-01 13:09:44 CET

Assignee: bugsquad => isobuild

Comment 15 Martin Whitaker 2017-03-08 21:27:31 CET
I've tested this on the 6-sta2 GNOME Live DVD, and had working audio in the small sample of YouTube videos I tried.

Is anyone still experiencing problems?

CC: (none) => mageia

Comment 16 William Kenney 2017-03-08 23:35:32 CET
I've not experienced a no-sound situation in M6/Gnome.
Comment 17 Martin Whitaker 2017-03-13 20:46:20 CET
OK, I'll close this bug then. Feel free to reopen if there are still problems.

Resolution: (none) => OLD

Note You need to log in before you can comment on or make changes to this bug.