Bug 15760 - quvi broken since mga5: need to be obsoleted
Summary: quvi broken since mga5: need to be obsoleted
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: Funda Wang
QA Contact:
Whiteboard: MGA5TOO
Depends on:
Blocks: 30163
  Show dependency treegraph
Reported: 2015-04-24 05:35 CEST by Keith Bowes
Modified: 2023-06-19 23:34 CEST (History)
3 users (show)

See Also:
Source RPM: quvi
Status comment:


Description Keith Bowes 2015-04-24 05:35:17 CEST
When I try to download a video, I get:
error: libquvi: while parsing media properties: .../share/libquvi-scripts/0.9/util/resolve_redirections.lua:60: attempt to index global 'quvi' (a nil value)

If I uninstall quvi, lua-socket, and task-obsolete and install Mageia 4's quvi, lua-socket, and lua-expat, it works fine again.
Rémi Verschelde 2015-04-24 09:05:47 CEST

CC: (none) => fundawang

Comment 1 Rémi Verschelde 2015-04-24 09:09:02 CEST
I can reproduce the issue. BTW libquvi-scripts is badly packaged because it does not explicitly require lua-socket, when it should.

CC: (none) => rverschelde

Samuel Verschelde 2015-06-06 02:36:45 CEST

Source RPM: (none) => quvi
Keywords: (none) => Junior_job
Assignee: bugsquad => fundawang
Summary: quvi doesn't work in mga5 cauldron => quvi doesn't work in mga5 (missing requires)
Whiteboard: (none) => MGA5TOO

Samuel Verschelde 2015-06-06 02:37:03 CEST

Summary: quvi doesn't work in mga5 (missing requires) => quvi doesn't work in mga5 (+ missing requires)
Keywords: Junior_job => (none)

Comment 2 Keith Bowes 2019-09-11 21:13:13 CEST
Probably quvi, libquvi, and libquvi-scripts should be removed from Mageia (it seems that cclive, a more user-friendly interface for quvi, already has been removed from Cauldron).  If they actually haven't worked since Mageia 5, I doubt they ever will, and the projects seem to have been abandoned.  youtube-dl is in the repos and is maintained, so that's an adequate replacement.  If by some chance, an old version of Lua were used, I seriously doubt that quvi would work, as youtube-dl has had to be updated various times to adjust for API changes at YouTube and other video-sharing sites.  Just a suggestion of course, but for Mageia 8, you guys really should obsolete these outdated packages in favor of youtube-dl.
Comment 3 sturmvogel 2022-06-05 00:58:14 CEST
quvi is broken since MGA5 (also confirmed on MGA8 and cauldron MGA9). Still the same error from comment 1 when you try to download a video.

quvi got abandoned from developer in 2013!

Needs to be obsoleted.

Summary: quvi doesn't work in mga5 (+ missing requires) => quvi broken since mga5: need to be obsoleted
Blocks: (none) => 30163

Comment 4 Nicolas Lécureuil 2023-06-19 23:34:44 CEST
Added in task-obsolete

CC: (none) => mageia
Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.