Bug 14800 - Freezing system with ATI Radeon 4770 & dual screen.
Summary: Freezing system with ATI Radeon 4770 & dual screen.
Status: REOPENED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: Thomas Backlund
QA Contact:
URL:
Whiteboard: MGA5TOO
Keywords:
Depends on: 16655
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-15 10:20 CET by Pascal Bialais
Modified: 2015-09-18 15:44 CEST (History)
5 users (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments
The screen (190.23 KB, image/jpeg)
2015-03-29 10:57 CEST, Bernard SIAUD
Details

Description Pascal Bialais 2014-12-15 10:20:16 CET
(Google translation, je ne parle que le franchouilleglais ;) )

Using two screens for some time with no problem.
1- A principal iiyama 1024x768 screen dashboard.
2- Belinea work in a 1280x1024 screen.
This on a graphics card ATI Radeon HD4770 (driver "Radeon HD 4870 and earlier")

Under Mageia4 to kernel-core 3.12.25-3.mga4 no worries and independent configuration screens are configured.

With the arrival of kernel-3.14.* Kernels the system freezes consistently 10, 15 seconds after login. Also with a visually successful display, but the keyboard and mouse do not work (Ctrl + Alt + F1 ...). The discs "scratching" more. No log for recovery. Reset mandatory.

I installed Mageia5 Cauldron. And surprise, it works very well again (kernel-desktop-3.17.4-1.mga).

But with the arrival of the kernel-desktop-3.18.*. I found exactly the same with figeages Magei4. So I roll in kernel-desktop-3.17.4-1.mga5

To sum up:

Mageia4
kernel-desktop-3.12.25-3.mga4 2 screens OK
kernel-desktop-3.14.23-1.mga4 2 screens KO !!
kernel-desktop-3.14.24-1.mga4 2 screens KO !!

Install Mageia5 le 16/11/2014

kernel-desktop-3.17.4-1.mga5 		2 screens OK
kernel-desktop-3.18.0-0.rc7.1.mga5 	2 screens KO !!
kernel-desktop-3.18.0-0.rc7.2.mga5 	2 screens KO !!
kernel-desktop-3.18.0-1.mga5 		2 screens KO !!
kernel-desktop-3.18.0-2.mga5		2 screens KO !!

Equipment:
Gigabyte GA-MA785GT-UD3H - AMD Phenom II X4 955 Black Edition - 
Vidéo ATI RADEON HD4770 -Mem 8Go - SSD 1x128Go HD 1X500Go  1x3To - Webcam Logitech C270.
Linux localhost 3.17.4-desktop-1.mga5 #1 SMP Fri Nov 21 20:15:17 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Graphics card:
Vendor
  ATI
    Radeon HD 4870 and earlier.

Reproducible: 

Steps to Reproduce:
claire robinson 2014-12-15 13:43:11 CET

CC: (none) => eeeemail, tmb
Product: Infrastructure => Mageia
Component: Others => RPM Packages
Version: unspecified => Cauldron
Target Milestone: --- => Mageia 5

claire robinson 2014-12-15 13:43:41 CET

Assignee: sysadmin-bugs => tmb

Comment 1 Rémi Verschelde 2014-12-19 08:48:28 CET
Pascal, do you still have an issue with kernel-desktop-3.18.1-1.mga5 and fglrx-kernel-3.18.1-desktop-1.mga5 ?

---

Pascal, est-ce que tu as toujours le même problème avec kernel-desktop-3.18.1-1.mga5 et fglrx-kernel-3.18.1-desktop-1.mga5 ?

CC: (none) => remi

Comment 2 Thomas Backlund 2014-12-19 08:49:53 CET
fglrx does not support hw < 5000 series
Comment 3 Rémi Verschelde 2014-12-19 08:53:05 CET
Ah thank Thomas, so I guess XFdrake needs fixing?
Comment 4 Thomas Backlund 2014-12-19 08:54:55 CET
Nope, "Radeon HD 4870 and earlier" only configures free driver
Comment 5 Pascal Bialais 2014-12-19 09:14:51 CET
The Problème is the same with kernel-desktop-3.18.1-1.mga5 and free driver
Comment 6 Pascal Bialais 2015-01-14 12:58:24 CET
Donc à ce jour cela ne fonctionne toujours pas.

En echec avec:
kernel-desktop-3.18.0-0.rc7.1.mga5
kernel-desktop-3.18.0-0.rc7.2.mga5
kernel-desktop-3.18.0-1.mga5
kernel-desktop-3.18.0-2.mga5
kernel-desktop-3.18.1-1.mga5
kernel-desktop-3.18.1-2.mga5
kernel-desktop-3.18.1-3.mga5
kernel-desktop-3.18.1-4.mga5
kernel-desktop-3.18.2-1.mga5

Je reste donc en : kernel-desktop-3.17.4-1.mga5
Comment 7 Pascal Bialais 2015-01-30 12:08:14 CET
Problem solved. Under kernel "kernel-desktop-3.18.3-1.mga5-1-1.mga5.x86_64" and especially updates of these past two days. Thank you.

Status: NEW => RESOLVED
Resolution: (none) => FIXED

Comment 8 Pascal Bialais 2015-01-31 10:08:29 CET
Well no. Restart this morning. Freezing income. While it worked all day yesterday.

Resolution: FIXED => (none)
Status: RESOLVED => REOPENED

Comment 9 Thomas Backlund 2015-01-31 11:14:16 CET
Since you are using the free driver, does the kernel-3.19.0-0.rc6.1.mga5 in updates_testing work any better ?
Comment 10 Bernard SIAUD 2015-02-01 11:36:27 CET
This problem is not solved with 3.19.0-desktop-0.rc6.1.mga5 . It is even more unstable.

First I have this problem : http://troumad.org/OOo/20150131_152835.jpg
After, the server X blocks.
I can not always do Ctrl-Alt-F3 for have a shell screen to do "systemctl restart dm". But, with a another computer, I can take control of the computer with the command ssh and after do "systemctl restart dm". After that, the server X restart unstable.

For the picture http://troumad.org/OOo/20150131_152835.jpg.
When the computer boot, the screen of the mother have problem, the screen of the hard boot have problem (I can take photo if you want).
This problem remains after a boot, with 1 ou 2 screen. So that it disappears , I boot with windows (2008 server SP 2, my windows). During the boot the screen are not good (if you want, I can take photo), after, if I open a window , it cleans the screen. And now I can reboot with Linux and this problem no longer appears at startup.

CC: (none) => liste

Comment 11 Pascal Bialais 2015-02-01 12:24:40 CET
Since yesterday I tested the "kernel-3.19.0-0.rc6.1.mga5." Apart from a freeze with "systemsettings" tool to configure the dual screen (the tool is sensitive and delicate) I have not found a malfunction yesterday. So this morning restarting double screen and it works correctly. To be continued ...
Comment 12 Bernard SIAUD 2015-02-01 14:15:02 CET
unstable with kernel-desktop-3.17.4-1.mga5-1-1.mga5.x86_64.rpm and 2 screens.

the photos :
boot, the mother board : http://troumad.org/OOo/CM.jpg
grub : http://troumad.org/OOo/grub.jpg
grub : http://troumad.org/OOo/grub_2.jpg
windows boot : http://troumad.org/OOo/boot_windows.jpg
windows boot : http://troumad.org/OOo/X_windows_boot.jp
windows screen : http://troumad.org/OOo/X_windows_root.jpg

After, I open a window and all become good. I can reboot and run with the next kernel, but only one screen.
Comment 13 Bernard SIAUD 2015-02-09 09:27:31 CET
I think that the new kernel ( 3.19.0-desktop-0.rc7.3.mga5 ) is goot with 23 screen.

mcc found that I have a "RV770 [Radeon HD 4850]". But, when it has found this, it has write in my bash :
Warning: skip "is_pciexpress" field => "1"
Warning: skip "sysfs_device" field => "/sys/bus/pci/devices/0000:01:00.0"
Warning: skip "nice_bus" field => "PCI Express"
Warning: skip "Handlers" field => "HASH(0x484f440)"
modinfo: ERROR: Module Card:ATI Radeon HD 4870 and earlier not found.
(see : http://www.mageialinux-online.org/forum/topic-19382-2.php#m188865 )
Comment 14 Bernard SIAUD 2015-02-22 10:44:20 CET
With the new kernel ( vmlinuz-3.19.0-desktop-1.mga5 ) it's not good.
Comment 15 Bernard SIAUD 2015-03-28 15:38:05 CET
vmlinuz-3.19.2-desktop-1.mga5 was not good. The computer with this problem is not use every day.
Comment 16 Bernard SIAUD 2015-03-29 10:48:22 CEST
Today the last kernel ( vmlinuz-3.19.2-desktop-2.mga5 ) scrath with 1 screen only :(
Comment 17 Bernard SIAUD 2015-03-29 10:57:18 CEST
Created attachment 6156 [details]
The screen
Samuel Verschelde 2015-06-06 00:49:04 CEST

Target Milestone: Mageia 5 => ---
Whiteboard: (none) => MGA5TOO

Comment 18 Thomas Backlund 2015-09-18 15:44:33 CEST
does kernel 4.1.7 in cauldron or mga5 testing work any better ?

Depends on: (none) => 16655


Note You need to log in before you can comment on or make changes to this bug.