Bug 14761 - Failure in Mintmenu item Desktop in French language (Bureau)
Summary: Failure in Mintmenu item Desktop in French language (Bureau)
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 4
Hardware: i586 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
Whiteboard: has_procedure advisory MGA4-64-OK MGA...
Keywords: validated_update
Depends on:
Reported: 2014-12-09 16:54 CET by olivier charles
Modified: 2015-03-06 19:09 CET (History)
2 users (show)

See Also:
Source RPM: mintmenu-5.5.0-2.1.mga4
Status comment:

Snapshot of mintmenu opened and configuration (933.83 KB, image/png)
2015-03-02 22:55 CET, olivier charles

Description olivier charles 2014-12-09 16:54:27 CET
Description of problem:

Using Mintmenu in French language, selecting menu item "Bureau" (Desktop) fails and opens a window :

Impossible de trouver << /home/zitounu/Desktop >>.
Vérifiez l'orthographe et essayez à nouveau.

In ~/.config/user-dirs.dirs :

Other items in Mintmenu perform well.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:


Steps to Reproduce:
claire robinson 2014-12-09 17:01:00 CET

Assignee: bugsquad => tarakbumba

Comment 1 Atilla ÖNTAŞ 2015-03-02 22:00:52 CET
Please try and feedback mintmenu-5.5.0-2.2.mga4 from core/updates_testing repository which should fix this issue.
Comment 2 olivier charles 2015-03-02 22:53:34 CET
On mageia4x64, mate desktop, French language,

I first checked that with mintmenu-5.5.0-2.1, I could reproduce the bug I had in Mageia 4x32.
I could.

Installed mintmenu-5.5.0-2.2.mga4.
When enabling it in taskbar, a window opened with this message :

Impossible d'initialiser le plugin places : Traceback (most recent call last):

  File "/usr/share/mintMenu/mintMenu.py", line 330, in PopulatePlugins

  File "/usr/share/mintMenu/plugins/places.py", line 275, in do_plugin

  File "/usr/share/mintMenu/plugins/places.py", line 178, in do_standard_places
    from configobj import ConfigObj

ImportError: No module named configobj

Validated nonetheless, mintmenu appears but in its main window, in Places, Desktop and Trash don't appear though they are enabled if I check in mintmenu configuration.
Comment 3 olivier charles 2015-03-02 22:55:36 CET
Created attachment 5973 [details]
Snapshot of mintmenu opened and configuration

Related to comment 2

CC: (none) => olchal

Comment 4 Atilla ÖNTAŞ 2015-03-03 00:28:46 CET
Thanks for feedback. Installing python-configobj should fix this issue. Please retry with mintmenu-5.5.0-2.3.mga4 from core/updates_testing
Comment 5 olivier charles 2015-03-03 01:40:41 CET
Installed updated testing mintmenu-5.5.0-2.3.mga4
which brought along python-configobj-4.7.2-7.mga4.noarch

Could add mintmenu in taskbar, no more warnings shown.
In Places could find Desktop ("Bureau") and Trash ("Corbeille")

When selecting "Bureau" , it now opens the desktop window.

Tried various items in mintmenu, all went well.

Bug 14761 solved by this update, no regression found.

Thanks Atilla !
Comment 6 Atilla ÖNTAŞ 2015-03-04 02:44:00 CET
I have uploaded a patched/updated mintmenu package for Mageia 4.

Suggested advisory:

Updated mintmenu fixes a bug in mintmenu.py which makes mintmenu to use "~/Desktop" directory for desktop and not respect xdg translated user dirs.

Updated package also ensures that required python-configobj package is installed.

Updated packages in core/updates_testing:

Source RPMs: 

Assignee: tarakbumba => qa-bugs

Comment 7 claire robinson 2015-03-05 17:23:15 CET
Did you OK this one Olivier?
Comment 8 olivier charles 2015-03-05 22:55:15 CET
Testing again on Mageia 4x32 and 4x64 real hardware, MATE desktop, French localization.

With current package :

could reproduce the bug (unable to open desktop with mintmenu places entry)

With updated testing package :

which installs : python-configobj-4.7.2-7.mga4.noarch 

The desktop item in mintmenu now opens well. All other items in mintmenu function well too.

Whiteboard: (none) => MGA4-64-OK MGA4-32-OK

Comment 9 claire robinson 2015-03-06 18:02:36 CET
Validating. Advisory uploaded.

Please push to 4 updates


Keywords: (none) => validated_update
Whiteboard: MGA4-64-OK MGA4-32-OK => has_procedure advisory MGA4-64-OK MGA4-32-OK
CC: (none) => sysadmin-bugs

Comment 10 Mageia Robot 2015-03-06 19:09:35 CET
An update for this issue has been pushed to Mageia Updates repository.


Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.