Bug 14188 - new cauldron plasma5 fails to read volume label on DVD
Summary: new cauldron plasma5 fails to read volume label on DVD
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: x86_64 Linux
Priority: Normal major
Target Milestone: ---
Assignee: KDE maintainers
QA Contact:
Depends on:
Blocks: 17523
  Show dependency treegraph
Reported: 2014-09-28 17:04 CEST by Frank Griffin
Modified: 2016-10-17 15:58 CEST (History)
2 users (show)

See Also:
Source RPM: plasma5
Status comment:


Description Frank Griffin 2014-09-28 17:04:27 CEST
Since the last KDE refresh, the device list shows DVDs not by the DVD label as it always did, but simply as "DVD-ROM".

In this state, applications can't use the DVD.  The usual choices are given in the device list entry, but they all throw unspecified errors if you attempt to open then for the disk.

Reverting to a cauldron system from last December, normal behavior is restored.

Blank disks seem to be recognized by k3b, and burns seem to work, but nothing else does.

I've tried rebooting with no success.  The error is solid, and occurs with both of the drives I have on the machine.


Steps to Reproduce:
Comment 1 Frank Griffin 2014-09-30 19:03:01 CEST
Either the bug has been fixed or else this may be significant...
I logged out of KDE and into GNOME, inserted a DVD, and it was recognized fine.  Then I logged uot of GNOME, back into KDE, and the disk was also recognized there.  I unloaded and reloaded the disk, and it was still recognized.  I unloaded that DVD and loaded another, and it too was recognized.

The true test will be when I can reboot and try it first in KDE.
Comment 2 Frank Griffin 2014-10-07 13:21:37 CEST
Looks like this got fixed.

Resolution: (none) => FIXED

Comment 3 Frank Griffin 2015-11-04 23:58:47 CET
No, it's not.  In current cauldron with plasma5, this has resurfaced.

It happens primarily with commercial DVDs.  It will happen sometimes with a locally-burned DVD.  The Device List popup shows only DVD-ROM, and none of the apps shown in the "choices" list in the popup can open the disk, showing either an error or "no media present".

However, DVDFab running under Wine detects the disk, displays the correct volume label, nd reads it just fine.

Resolution: FIXED => (none)
Source RPM: kde => plasma5

Frank Griffin 2015-11-04 23:59:14 CET

Summary: new cauldron kde fails to read volume label on DVD => new cauldron plasma5 fails to read volume label on DVD

Rémi Verschelde 2016-01-19 11:05:37 CET

Blocks: (none) => 17523

Comment 4 Nicolas Lécureuil 2016-01-24 22:54:27 CET
can you test with plasma 5.5.3 ?

CC: (none) => mageia

Comment 5 Frank Griffin 2016-01-25 21:45:29 CET
plasma-desktop 5.5.3 installs fine.  plasma-framework gets:

[root@ftglap ~]# urpmi plasma-framework

installing plasma-framework-5.18.0-1.mga6.x86_64.rpm from /mnt/cauldron/x86_64/media/core/release
Preparing...                     #############################################
Installation failed:    file /usr/share/kdevappwizard/templates/qml-plasmoid.tar.bz2 from install of plasma-framework-5.18.0-1.mga6.x86_64 conflicts with file from package kapptemplate-1:15.12.1-1.mga6.x86_64

Is that a problem ?
Comment 6 Frank Griffin 2016-02-21 04:38:38 CET
I still haven't got plasma-framework to install, but plasma-desktop is at 5.5.4-1 and this problem still occurs, sort of.

The DVD label still doesn't get read, and the notification display still shows DVD-ROM.  However, the various applications are now able to read the disk and show the correct label.
Samuel Verschelde 2016-02-23 14:37:47 CET

Assignee: bugsquad => mageia

Comment 7 Nicolas Lécureuil 2016-04-24 21:41:54 CEST
Please update. You should be able to install plasma-framework now.
Comment 8 Frank Griffin 2016-04-25 00:57:50 CEST
Yes, I forced it on a while ago.  But when I run DVDFab as a wine application (DVD ripper), in many cases it reads the volume label correctly while plasma notifications still only identifies it as "DVD-ROM".

This is with cauldron updated as of yesterday.
Comment 9 Frank Griffin 2016-04-25 01:00:09 CEST
Sorry, that should be DVDFab reads the volume label correctly in *all* cases whereas Plasma reports DVD-ROM in most cases.
Comment 10 Nicolas Lécureuil 2016-04-25 01:01:10 CEST
can you provide a screenshot please ? ( for me to understand better ).
Comment 11 Frank Griffin 2016-04-25 01:20:43 CEST
I'll try, but I'm not sure it's possible.  The "DVD-ROM" thing only shows up in the notification popup that indicates that a DVD has been inserted, and I'm pretty sure that disappears as soon as you do anything else on the desktop (like request a screenshot).

Just to be clear, you load a DVD; plasma plays with the drive for a few seconds, and then displays the notification panel which shows what is present in each mounted volume.  The first is usually the DVD, and displays the volume label of the inserted DVD.  In the error case, it displays only "DVD-ROM".  However, wine applications which read the drive directly have no trouble reading the volume label correctly.

Probably the best way to debug this is to grep the source for "DVD-ROM" and figure out what error is causing that to be chosen as the default.
Comment 12 Frank Griffin 2016-04-30 15:57:14 CEST
The notification popup shows "DVD-ROM" and lists a single available action - open with video player (DragonPlayer).  If you choose that, Dragon Player opens, but if you click Play, the icon changes correctly and a Pause icon appears, but almost immediately disappears and reverts to its original status with no error, i. e. it gets an error reading and gives up.

Meanwhile, a wine application is happily reading the DVD.
Samuel Verschelde 2016-08-25 16:25:17 CEST

Assignee: mageia => kde

Comment 13 Samuel Verschelde 2016-09-08 17:58:21 CEST
Is it still valid with latest plasma update?
Comment 14 JanKusanagi 2016-10-17 15:48:49 CEST
I just tried this, and it works fine for me in almost-current Cauldron (Plasma 5.8.0).

After inserting a regular DVD-R with a label, the device notifier pops up showing the correct DVD label, just as Dolphin does on its Places panel.

I don't know if this bug is related to movie DVD's, but I imagine it shouldn't make any difference.

CC: (none) => jan-bugs

Comment 15 JanKusanagi 2016-10-17 15:55:37 CEST
Follow-up: Tried with a regular Movie DVD, and the label also appears correctly. In this case, "Open with Dragon Player" also appears, and clicking it works as expected (DP launches and the movie starts playing).
Comment 16 Frank Griffin 2016-10-17 15:56:53 CEST
I haven't seen this for a few weeks now, so I'll close it for now.
Comment 17 Frank Griffin 2016-10-17 15:58:02 CEST

Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.