Bug 13893 - makemkv makes a mkv-file of your DVD
Summary: makemkv makes a mkv-file of your DVD
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: New RPM package request (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal normal
Target Milestone: Mageia 7
Assignee: All Packagers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-10 16:36 CEST by Kristoffer Grundström
Modified: 2017-08-11 00:14 CEST (History)
4 users (show)

See Also:
Source RPM: makemkv
CVE:
Status comment:


Attachments
Here's the spec-file (3.92 KB, text/x-rpm-spec)
2014-08-10 17:07 CEST, Kristoffer Grundström
Details
A new spec file for makemkv (3.80 KB, text/x-rpm-spec)
2016-09-13 00:34 CEST, Kristoffer Grundström
Details
Here's a fully working spec file to build with (3.04 KB, text/x-rpm-spec)
2016-10-16 03:57 CEST, Kristoffer Grundström
Details
Result of trying to install libffmpeg-devel (2.26 KB, text/plain)
2017-08-08 21:52 CEST, Kristoffer Grundström
Details
Problem still remains (11.35 KB, text/plain)
2017-08-09 04:14 CEST, Kristoffer Grundström
Details

Description Kristoffer Grundström 2014-08-10 16:36:12 CEST
Description of problem: I have managed to build and installed makemkv so that I get a menu-entry but as I try to start it I end up with a segmentationerror when it's about to read the DVD.

Version-Release number of selected component (if applicable): 1.8.11

How reproducible: Everytime.

Steps to Reproduce:
1. Open your desired webbrowser.
2. Go to http://rpm.pbone.net/index.php3/stat/4/idpl/25747561/dir/fedora_20/com/makemkv-1.8.8-1.fc20.x86_64.rpm.html and install all the deps that Fedora uses. The link to their SRPM isn't working.
3. Go to either http://www.makemkv.com/forum2/viewtopic.php?f=3&t=224 or https://launchpad.net/~heyarje/+archive/ubuntu/makemkv-beta to download the needed source-packages. I choose the Ubuntu-packages since the official packages fail to build.
3. Build and install the oss and bin RPM-packages using my spec-file.
4. Try to start makemkv from the menu.
5. Once it starts to read your DVD the gui disappears but you don't get any crash.

Reproducible: 

Steps to Reproduce:
Kristoffer Grundström 2014-08-10 16:36:23 CEST

Version: Cauldron => 4

Kristoffer Grundström 2014-08-10 16:36:31 CEST

Target Milestone: --- => Mageia 5

Kristoffer Grundström 2014-08-10 16:36:35 CEST

CC: (none) => kristoffer.grundstrom1983

Sander Lepik 2014-08-10 16:38:04 CEST

Severity: major => enhancement
CC: (none) => mageia
Version: 4 => Cauldron

Comment 1 Kristoffer Grundström 2014-08-10 17:07:19 CEST
Created attachment 5338 [details]
Here's the spec-file
Comment 2 Kristoffer Grundström 2014-08-13 00:33:19 CEST
Who have a working solution for the moc-qt4 error during making of the rpm-package?

which: no moc-qt4 in (/usr/local/bin:/usr/bin:/usr/games:/usr/lib/qt4/bin:/home/kristoffer/bin)

I found this thread about an older version of makemkv that might give a solution to it, but I don't have a clue what they mean by a "revdep-rebuild":

http://www.makemkv.com/forum2/viewtopic.php?f=3&t=4795
Comment 3 Kristoffer Grundström 2014-08-13 00:34:38 CEST
Might doing this help?

pkg-config --variable=moc_location QtCore
Comment 4 Kristoffer Grundström 2014-08-13 00:38:52 CEST
Seems like the Makefile.in in the oss-archive have the line:

MOC=$(strip $(shell which moc-qt4))

There is no moc-qt4 as far as I know.
Comment 5 Kristoffer Grundström 2014-08-13 00:45:35 CEST
On i586 with 3.12.26-desktop586-1.mga4 as kernel in my Toshiba Satellite L755-1DR it builds, installs and runs perfectly fine even thou the moc error appeared. I still think that this needs to be fixed thou.
Comment 6 Kristoffer Grundström 2014-08-13 01:02:38 CEST
(In reply to Kristoffer Grundström from comment #4)
> Seems like the Makefile.in in the oss-archive have the line:
> 
> MOC=$(strip $(shell which moc-qt4))
> 
> There is no moc-qt4 as far as I know.

This error is solved by removing -qt4 from that line.
Kristoffer Grundström 2014-08-13 01:03:07 CEST

Summary: Segmentationerror trying to run makemkv => makemkv makes a mkv-file of your DVD

Comment 7 Kristoffer Grundström 2016-09-13 00:34:24 CEST
Created attachment 8402 [details]
A new spec file for makemkv

I just built the latest version 1.10.2 and the rpm works just fine. Can someone please push this to Cauldron?

Attachment 5338 is obsolete: 0 => 1

Comment 8 Kristoffer Grundström 2016-09-27 00:34:20 CEST
Ping! Can anyone push it?
Comment 9 Rémi Verschelde 2016-09-27 10:31:21 CEST
No it can't be pushed, as your spec file is invalid. Most notably, you are installing upstream pre-compiled binaries instead of building them yourself from source, which is a *no go* in Mageia.

If it can't be built 100% from the source code, it's proprietary and likely won't be included in Mageia.
Comment 10 Kristoffer Grundström 2016-09-28 01:25:06 CEST
I just read this on the purchase page for makemkv:

MakeMKV contains both freeware and shareware functionality. You may use MakeMKV to convert or stream DVD and AVCHD discs for free, as much as you want. Converting or streaming Blu-ray discs is shareware functionality. You can use shareware functionality for free during 30-days trial period. If you like MakeMKV and you want to use it after your 30-days trial version expires, you need to purchase a registration key.

OpenSuse, Fedora and RedHat has this program in the repos according to rpm.pbone.net so Mageia should be able to release it as well.

Right?

According to the RedHat spec file it has been packaged with these licenses:

GuinpinSoft inc and Mozilla Public License Version 1.1 and LGPLv2.1+

The last license LGPLv2.1+, what does it permit?

When googling about that license form I found this page: https://www.gnu.org/licenses/old-licenses/lgpl-2.1.html

It does in fact allow you to package it as long as you don't claim to be the author of this program...... Or have I misunderstood?

The previous attached spec file can be fixed by anyone that wants to solve the problem because I don't have any problem packaging makemkv locally right now.
Comment 11 Rémi Verschelde 2016-09-28 09:18:04 CEST
The packages you found for openSUSE and Fedora are all third-party packages, so it does not give us any guarantee on the licensing.

> GuinpinSoft inc and Mozilla Public License Version 1.1 and LGPLv2.1+

The MPLv1.1 and LGPLv2.1+ are both free software licenses and allowed in our Core repo. But the first part "GuinpinSoft inc" is not a free software license, and if it's on the license field of the spec file, it probably means that it contains partly nonfree code.

There is no package for makemkv in any official distro repo. That doesn't mean that we can't package it, but the current spec file (which seems to follow upstream's install instructions) is not OK for Mageia's standards. Is there an upstream source repository?
Comment 12 Samuel Verschelde 2016-10-11 20:54:56 CEST
Assigning this package request to all packagers collectively. On a voluntary basis, one of them might want to integrate it to the distribution and maintain it for bug and security fixes.

You might also want to join the packager team to maintain this piece of software: see https://wiki.mageia.org/en/Becoming_a_Mageia_Packager

Assignee: bugsquad => pkg-bugs

Comment 13 Kristoffer Grundström 2016-10-16 03:57:35 CEST
Created attachment 8545 [details]
Here's a fully working spec file to build with

Attachment 8402 is obsolete: 0 => 1

Comment 14 Kristoffer Grundström 2016-10-16 04:10:36 CEST
I succesfully built this program in Cauldron now as well.
Comment 15 Kristoffer Grundström 2017-03-31 21:07:37 CEST
Any progress on this? I just built and tested the latest beta version of this wonderful program and no errors either with installing or running it.
Comment 16 José Jorge 2017-04-01 09:02:12 CEST
(In reply to Kristoffer Grundström from comment #15)
> Any progress on this? I just built and tested the latest beta version of
> this wonderful program and no errors either with installing or running it.

Well, no one has answered to the comment 11 problems. It will never progress if no one does.

CC: (none) => lists.jjorge

Comment 17 Kristoffer Grundström 2017-08-08 03:40:26 CEST
Something has changed so 1.10.6 won't build in Mageia 6 with the dependancies from the spec file I used in Mageia 5.

The issue is that libavcodec cannot be found even though it's installed.

configure: error: No package 'libavcodec' found
No package 'libavutil' found.

libffmpeg-devel + ffmpeg is installed.
libavcodec57 is installed.

libavutil55 is also installed.

I'm not using any Testing or Backports medias.
Comment 18 Kristoffer Grundström 2017-08-08 03:45:26 CEST
http://www.makemkv.com/forum2/viewtopic.php?f=3&t=224 shows you the following information regarding libavcodec that might be of use:

Starting with version 1.8.6 MakeMKV no longer uses ffmpeg application, but links directly to libavcodec. Please note that most distributions ship a very outdated version of libavcodec (either from ffmpeg or libav projects). You will have to compile a recent ffmpeg (at least 2.0) if you need a FLAC encoder that handles 24-bit audio. Also you will have to enable libfdk-aac support in ffmpeg in order to use AAC encoder. Here are generic instructions for building makemkv-oss with latest ffmpeg:

- download ffmpeg tarball from http://ffmpeg.org/download.html
- configure and build ffmpeg:

./configure --prefix=/tmp/ffmpeg --enable-static --disable-shared --enable-pic --disable-yasm

or with libfdk-aac support

./configure --prefix=/tmp/ffmpeg --enable-static --disable-shared --enable-pic --disable-yasm --enable-libfdk-aac

And I already tried those and still get the same error so I need some help on how to fix the spec file.
Comment 19 Rémi Verschelde 2017-08-08 10:53:17 CEST
Install ffmpeg-devel.
Comment 20 Kristoffer Grundström 2017-08-08 21:52:28 CEST
Created attachment 9575 [details]
Result of trying to install libffmpeg-devel
Kristoffer Grundström 2017-08-08 21:52:56 CEST

Target Milestone: Mageia 5 => Mageia 6

Comment 21 Florian Hubold 2017-08-08 23:08:53 CEST
(In reply to Kristoffer Grundström from comment #20)
> Created attachment 9575 [details]
> Result of trying to install libffmpeg-devel

Seems you have installed some packages that are newer then the ones in the repositories which conflicts with one of the packages that are about to be installed. That's a local issue to your box, I cannot reproduce here.

You were also told to install ffmpeg-devel not _lib_ffmpeg-devel.

Find out which package is causing that via LC_ALL=C urpmi --debug libffmpeg-devel and fix your local dependency issues first. But this does not belong in this _package request_ for ffmpeg - please keep in mind that bugzilla is not really a support forum.

CC: (none) => doktor5000

Comment 22 Kristoffer Grundström 2017-08-09 04:14:18 CEST
Created attachment 9577 [details]
Problem still remains
Comment 23 Kristoffer Grundström 2017-08-09 04:15:00 CEST
I even did urpme --auto-orphans --auto and the problem still remains.
Kristoffer Grundström 2017-08-11 00:14:15 CEST

Severity: enhancement => normal
Target Milestone: Mageia 6 => Mageia 7


Note You need to log in before you can comment on or make changes to this bug.