Bug 13829 - Hardware detection tool: 'kernel modules' makes a mess of the GUI and hdt stops working
Summary: Hardware detection tool: 'kernel modules' makes a mess of the GUI and hdt sto...
Status: RESOLVED OLD
Alias: None
Product: Mageia
Classification: Unclassified
Component: Release (media or process) (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: High normal
Target Milestone: Mageia 7
Assignee: Erwan VELU
QA Contact:
URL:
Whiteboard:
Keywords: 6sta2, FOR_ERRATA5, IN_ERRATA6
Depends on:
Blocks:
 
Reported: 2014-07-31 17:54 CEST by Dick Gevers
Modified: 2019-02-19 10:46 CET (History)
6 users (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments
result of "lspci -vv" (18.72 KB, text/plain)
2014-11-25 10:21 CET, Dick Gevers
Details
hdt-0.5.3-beta1 (672.99 KB, application/x-xz)
2015-03-19 12:22 CET, Erwan VELU
Details
hdt with pcilib fix (200 bytes, application/x-xz)
2015-03-20 10:33 CET, Erwan VELU
Details
hdt with pcilib fix (574.88 KB, application/x-xz)
2015-03-20 14:51 CET, Erwan VELU
Details

Description Dick Gevers 2014-07-31 17:54:15 CEST
Description of problem:

When sel4ecting hardware detection tool from the dual DVD built 30/7 all works well, except when selecting the menu entry "Kernel modules":

It makes a mess of the gui and the HDT stops working. 

All other choices work as expected.




Reproducible: 

Steps to Reproduce:
Dick Gevers 2014-07-31 17:54:31 CEST

Whiteboard: (none) => 5alpha2

David Walser 2014-07-31 22:11:21 CEST

Assignee: bugsquad => thierry.vignaud

Comment 1 Dick Gevers 2014-08-03 11:57:22 CEST
Applies to 32 bit classical iso.

Source RPM: Mageia-5-alpha2-dual-DVD built Wed Jul 30 16:13:04 => Mageia-5-alpha2-dual-DVD built Wed Jul 30 / 32 bit class.built Aug 01

Comment 2 Dick Gevers 2014-10-23 12:54:41 CEST
In beta1 first build applicable to 64 bit iso.

Should it not be fixed by final time, consider to remove from boot menu.

Source RPM: Mageia-5-alpha2-dual-DVD built Wed Jul 30 / 32 bit class.built Aug 01 => Mageia-5-beta1 built 23 Oct 2014
Whiteboard: 5alpha2 => 5beta1

Comment 3 Manuel Hiebel 2014-10-24 23:26:18 CEST
adding release manager then

Priority: Normal => release_blocker
Source RPM: Mageia-5-beta1 built 23 Oct 2014 => (none)
Assignee: thierry.vignaud => erwanaliasr1
CC: (none) => ennael1, tmb

Comment 4 Marja Van Waes 2014-11-02 19:19:03 CET
(In reply to Dick Gevers from comment #2)
> In beta1 first build applicable to 64 bit iso.
> 
> Should it not be fixed by final time, consider to remove from boot menu.

Here it is worse (classical 64bits from October 31st), just selecting the HDT tool made the system reboot the first time I tried. The second time it gave a frozen black screen with a blinking white underscore. Nothing worked, the only way to get out was powering off.

CC: (none) => marja11

Comment 5 Anne Nicolas 2014-11-24 23:22:05 CET
it works oerfectly on my side. on all installations
Comment 6 Dick Gevers 2014-11-25 10:21:30 CET
Created attachment 5642 [details]
result of "lspci -vv"

Yes, I acknowledge that on another machine it does,

But not on: https://wiki.mageia.org/en/QA_iso_hardware_list#Notebooks: item dvgevers.

I am attaching the result of "lspci -vv"
claire robinson 2014-12-15 13:45:55 CET

CC: (none) => eeeemail

Comment 7 Erwan VELU 2014-12-15 21:29:32 CET
Can you switch to the "CLI" mode of HDT and do "show kernel" and show me the result ?
Comment 8 Dick Gevers 2014-12-15 22:24:31 CET
Okay, this is all I see:

---
CPU (8 logical / 1 phys)
Manufacturer; Intel
POroduct: Intel (r) Celeron (R) CPU 1037U @ 1.80GHz
CPU Cores: 8
CPU Threads: 2
L2 Cache: 256K
Features: 1800 Mhz: x86_64 64 bit SMP HwVIRT
System
Manufacturer: TOSHIBA
Product Name: Satellite C55-A
Bios
Version: 1.30
Release: 09/16/2013
Memory Size: 12172 MB (12463728 KB)
PCI
NB devices: 13
Kenel modules
hdt>
---
Comment 9 Dick Gevers 2015-01-30 10:30:26 CET
Still valid.

Whiteboard: 5beta1 => 5beta3

Comment 10 Rémi Verschelde 2015-02-03 22:11:54 CET
Any clue about this one Erwan?

CC: (none) => remi

Thierry Vignaud 2015-02-24 12:59:44 CET

CC: (none) => sysadmin-bugs
Component: Installer => Release (media or process)

Comment 11 Dick Gevers 2015-02-26 16:25:33 CET
Valid for rc classical iso, build # 1

Whiteboard: 5beta3 => 5rc

Comment 12 Erwan VELU 2015-03-19 12:22:52 CET
Created attachment 6094 [details]
hdt-0.5.3-beta1
Comment 13 Erwan VELU 2015-03-19 12:25:31 CET
(In reply to Dick Gevers from comment #9)
> Still valid.

Can you make a try usb booting the image I've been attaching to this ticket ?
tar -xf hdt-0.5.3-beta1.img.xz
dd if=hdt-0.5.3-beta1.img. of=/dev/<your_usb_key>

Then boot on it.

If you could picture the graphical result and then do also the same "show" command from the cli and picture it also.

What would help me to understand that bug.

Thanks,
Comment 14 Erwan VELU 2015-03-20 10:30:52 CET
I've been able to reproduce your case in my testing case.

If for any reason, syslinux isn't able to read the modules.alias (corrupted iso, corrupted file, broken bios), the file is said to be valid and the menuing system is creating stupid entries which generates what your bug reports explains.

I've been fixing the modules.alias reading function to report a failure if we cannot read any valid line in it.

That should solve your case.

The .img I asked you to test doesn't have this fix.

Status: NEW => ASSIGNED

Comment 15 Erwan VELU 2015-03-20 10:33:12 CET
Created attachment 6103 [details]
hdt with pcilib fix

Can you try this usb bootable image to validate it does work properly with the patch ?

Thanks,
Comment 16 Erwan VELU 2015-03-20 10:33:49 CET
The proposed fix: https://svnweb.mageia.org/packages?view=revision&revision=818980
Comment 17 Dick Gevers 2015-03-20 10:47:58 CET
Yes, as soon as I find the time...
Comment 18 Dick Gevers 2015-03-20 14:39:53 CET
I don't understand what you want me to test: there is an image dated 19th but next you say it doesn't have the fix. Then there is a fixed image, but it is only 200 bytes. So is not going to boot. Please clarify.
Comment 19 Erwan VELU 2015-03-20 14:51:34 CET
Created attachment 6104 [details]
hdt with pcilib fix

Ok sorry for the confusing.

I was searching for your problem and asked you to test a build to better understand the situation.

Then I found a way to reproduce it and did upload another image with a fix.... Ok  I missed the upload.

Please find attached the proper image with the fix.

Tell me if it's better for you.

Cheers,
Comment 20 Dick Gevers 2015-03-21 09:07:58 CET
The "problem" is gone, because now the menu option "Kernel modules" is no longer available. As a result the HDT cannot be messed up anymore.

From cli the command 'show kernel' gives this result:

---
CPU (8 logical / 1 phys)
 Manufacturer: Intel
 Product: Intel (r) Celeron (R) CPU 1037U @ 1.80GHz
 CPU Cores: 8
 CPU Threads: 2
 L2 Cache: 256K
 Features: 1800 Mhz: x86_64 64 bit SMP HwVIRT
System
 Manufacturer: TOSHIBA
 Product Name: Satellite C55-A
Bios
 Version: 1.30
 Release: 09/16/2013
 Memory Size: 12172 MB (12463728 KB)
PCI
 NB devices: 13
Kenel modules
 modules.pcimap and modules.alias files are missing
hdt>
---
Comment 21 Erwan VELU 2015-03-23 09:04:20 CET
So that's a good news. I've been able to reproduce your case and the fix is working.

That doesn't still explain why you system is not able to read this file.

Did you double-check the md5 of your iso ?

What's your booting method ?
Comment 22 Dick Gevers 2015-03-23 09:58:15 CET
I booted with the image from attachment 6104 [details]. I a. not aware if this has an md5sum that is verifiable (and I am not using Linux at the moment, just ipad, so I can't check).

I wrote the image to a bootable CDRW, because the bios did not allow me in to change the boot order to use USB. But CDRW works as good as USB, I think.
Comment 23 Erwan VELU 2015-03-23 21:20:32 CET
So that's maybe a bios/syslinux issue...
Comment 24 Dick Gevers 2015-03-23 21:31:49 CET
Well the bios has always been accessible, last time was less than ~3 months ago. ItS a cheap machine or I am a fool that I can't access it. So in this respect the bios does not look to be the cause.
Comment 25 Erwan VELU 2015-03-23 21:35:35 CET
The fopen & fread is failing reading data from the bootable device.

Syslinux is using int13 from bios do to that and that bug shows that something is clearly wrong here.

So the bug is in between bios & syslinux.

I'll try to make a POC to show off this bug.
Comment 26 Anne Nicolas 2015-03-28 20:44:26 CET
Decreasing priority as seen in last council meeting. Screen is not borked anymore even if the module list does not exist anymore in some cases. Should be worked for Mageia 6

Priority: release_blocker => High

Comment 27 Rémi Verschelde 2015-03-29 13:11:33 CEST
Adding to the Mageia 6 tracker.

Blocks: (none) => 15527

Samuel Verschelde 2015-06-02 10:06:58 CEST

Whiteboard: 5rc => FOR_ERRATA
Target Milestone: --- => Mageia 6

Comment 28 Dick Gevers 2015-12-01 14:48:18 CET
Valid for today's classical iso - 32 bits

Whiteboard: FOR_ERRATA => FOR_ERRATA, 6dev1

Comment 29 Dick Gevers 2016-01-20 17:21:01 CET
Valid for today's new isos

Whiteboard: FOR_ERRATA, 6dev1 => 6dev1; FOR_ERRATA

Comment 30 Dick Gevers 2016-03-08 11:30:08 CET
Valid for isos dated 7th March.
Marja Van Waes 2016-04-05 19:18:34 CEST

Keywords: (none) => 6dev1
Whiteboard: 6dev1; FOR_ERRATA => FOR_ERRATA

Comment 31 Dick Gevers 2016-05-21 11:02:51 CEST
Valid for classical iso dated 20 May 2016 (64 bit)

Keywords: 6dev1 => 6sta1

Comment 32 Dick Gevers 2016-07-12 16:51:10 CEST
Valid for 6RC iso dated 12th July 2016

Keywords: 6sta1 => 6RC

Comment 33 Marja Van Waes 2016-07-12 17:11:48 CEST
Moving to a Mga7 tracker, because there seems to be no current activity to fix this issue.

@ Erwan

Of course, that doesn't mean it is forbidden to now work on it again ;-)

Target Milestone: Mageia 6 => Mageia 7
Blocks: 15527 => 18932

Samuel Verschelde 2016-10-18 13:03:09 CEST

Keywords: 6RC => FOR_ERRATA5, FOR_ERRATA6
Whiteboard: FOR_ERRATA => (none)

Samuel Verschelde 2016-11-10 10:36:01 CET

Blocks: 18932 => (none)

Comment 34 Dick Gevers 2016-12-05 17:43:35 CET
Valid for M6 sta2 dated 05 12 2016 (back in boot menu, thought it was removed earlier ??)
Dick Gevers 2016-12-06 02:33:44 CET

Keywords: (none) => 6sta2

Comment 35 Marja Van Waes 2017-03-06 16:42:29 CET
(In reply to Dick Gevers from comment #34)
> Valid for M6 sta2 dated 05 12 2016 (back in boot menu, thought it was
> removed earlier ??)

If it's still valid with current 6sta2, could you then please add it to https://wiki.mageia.org/en/Mageia_6_Errata ?
Comment 36 Dick Gevers 2017-03-06 17:52:03 CET
Marja this is unclear: it was decided earlier to remove HDT from the install disk boot menu but later it came back again (not clear why). It is not new: here for 3 years. I would rather have it removed until it is fixed or maybe it is already in earlier errata ??
Comment 37 Marja Van Waes 2017-03-06 20:46:28 CET
(In reply to Dick Gevers from comment #36)
> Marja this is unclear: it was decided earlier to remove HDT from the install
> disk boot menu but later it came back again (not clear why). It is not new:
> here for 3 years. I would rather have it removed until it is fixed or maybe
> it is already in earlier errata ??

Maybe because no one else reported this issue, and because it wouldn't make sense to remove all of HDT if only part of it dysfunctions on only some systems?

Btw, you don't seem to have the latest BIOS
http://www.toshiba.eu/support/bios/
Did you consider flashing a later version?

Was the Toshiba Satellite C55-A with bios v.1.30 the only system on which you've hit this bug, or do you see it on different hardware, too?

I've added:

  In rare cases, selecting 'kernel modules' can make a mess of the GUI and cause
  HDT to stop working

to the errata.

CC: sysadmin-bugs => isobuild
Keywords: FOR_ERRATA6 => IN_ERRATA6

Comment 38 Dick Gevers 2017-03-07 17:26:59 CET
(In reply to Marja van Waes from comment #37)
 
> Btw, you don't seem to have the latest BIOS
> http://www.toshiba.eu/support/bios/

Very clever that you found this, I wasn't aware of it: updated it but for this bug it makes no difference, though.

> Was the Toshiba Satellite C55-A with bios v.1.30 the only system on which
> you've hit this bug, or do you see it on different hardware, too?

That is the only machine I test on.
Comment 39 Dick Gevers 2019-02-19 10:46:36 CET
Closed since hdt is not (visible) on the isos

Status: ASSIGNED => RESOLVED
Resolution: (none) => OLD


Note You need to log in before you can comment on or make changes to this bug.