Bug 13370 - Update request: perl-URPM
Summary: Update request: perl-URPM
Alias: None
Product: Mageia
Classification: Unclassified
Component: Release (media or process) (show other bugs)
Version: 4
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
Whiteboard: MGA3TOO has_procedure mga4-32-ok mga3...
Keywords: validated_update
Depends on:
Reported: 2014-05-13 08:39 CEST by Jüri Ivask
Modified: 2014-05-22 19:29 CEST (History)
6 users (show)

See Also:
Source RPM: perl-URPM-4.29-1.mga4.src.rpm
Status comment:


Description Jüri Ivask 2014-05-13 08:39:44 CEST
Description of problem: Tried to update Mageia 4 to Cauldron according to Wiki:
However, after replacing the repositories, urpmi gave an error (translated from estonian):
Problem reading repository "Core Release" synthesize file
Can't call method "flag_skip" on an undefined value at /usr/lib/perl5/vendor_perl/5.18.1/i386-linux-thread-multi/URPM/Resolve.pm line 582.

Non-free and tainted repositories were OK.

Sander suggested to upgrade perl-URPM to the cauldron one, but I was unable to do so with urpmi as I had KDE 4.11.5 installed from Mageia 4 updates/testing and urpmi wished to replace many packages from it with the 4.11.4 ones.
Workaround was to use rpm -Uvh librpm3-4.11.2-3.mga5.i586.rpm perl-base-5.18.2-4.mga5.i586.rpm rpm-4.11.2-3.mga5.i586.rpm perl-5.18.2-4.mga5.i586.rpm perl-URPM-4.30-1.mga5.i586.rpm and then the cauldron update succeeded


Steps to Reproduce:
Comment 1 Thomas Backlund 2014-05-13 12:22:52 CEST
Yes, it's known.

The kernel provides has grown beyond allocated buffer space in perl-URPM.

we have it fixed in cauldron, and now that it has seem some testing there we will provide perl-URPM updates for both mga3 and mga4

CC: (none) => tmb

Comment 2 Thomas Backlund 2014-05-17 02:08:17 CEST
There is now fixed perl-URPM in mga3 and mga4 updates_testing thanks to tv.









Updated perl-URPM fixes buffer size for rpm provides.
Newer kernels has provides that does not fit into current 64k size limit,
making it impossible to add hdlists from cauldron and upcoming mga5
on a mga3 or mga4 system breaking chroot installs and online upgrades
on 32bit (i586) systems.

This update fixes the issue by doubling the buffer space so it can
handle all provides.

Try to add cauldron hdlists on a mga3 or mga4 32bit install, and it will
complain about kernel provides. 
Install the updated perl-URPM
Try to add cauldron hdlists again, it will now succeed.

CC: (none) => thierry.vignaud
Hardware: i586 => All
Assignee: bugsquad => qa-bugs
Summary: Update Mageia 4 -> Cauldron - problem reading repository "Core Release" synthesize file => Update request: perl-URPM
Whiteboard: (none) => MGA3TOO

Comment 3 Rémi Verschelde 2014-05-17 10:26:02 CEST
Testing on Mageia 4 32-bit. I added the cauldron mirrors along the Mageia 4 ones, and could confirm that I am unable to install any package from Cauldron.

Then I installed the update candidate perl-URPM-4.30-1.mga4.i586 and I was able to test the availability of the cauldron packages (with "urpmi --test dustrac", the latter being packaged on in cauldron).

I did not try an upgrade to cauldron though, but I checked that I was still able to install packages from Mageia 4's mirrors with the new perl-URPM.

CC: (none) => remi
Whiteboard: MGA3TOO => MGA3TOO has_procedure mga4-32-ok

Comment 4 José Jorge 2014-05-19 11:46:25 CEST
Testing on MGA3 i586. I added the cauldron mirrors, and could upgrade to cauldron.

CC: (none) => lists.jjorge

José Jorge 2014-05-19 11:47:40 CEST

Whiteboard: MGA3TOO has_procedure mga4-32-ok => MGA3TOO has_procedure mga4-32-ok mga3-64-ok

Comment 5 Rémi Verschelde 2014-05-19 11:52:01 CEST
(In reply to José Jorge from comment #4)
> Testing on MGA3 i586. I added the cauldron mirrors, and could upgrade to
> cauldron.

You said you tested on i586 but added the "mga3-64-ok" tag, shouldn't it be "mga3-32-ok"?
Comment 6 Jüri Ivask 2014-05-19 12:25:27 CEST
Tested on Mageia 4 i586.
Installed perl-URPM-4.30-1.mga4.i586.rpm from Mageia 4 /core/updates_testing and now urpmi is able to read Cauldron repository "Core Release" synthesize file.
Comment 7 José Jorge 2014-05-19 13:09:34 CEST
Sorry, it (In reply to Rémi Verschelde from comment #5)
> (In reply to José Jorge from comment #4)
> > Testing on MGA3 i586. I added the cauldron mirrors, and could upgrade to
> > cauldron.
> You said you tested on i586 but added the "mga3-64-ok" tag, shouldn't it be
> "mga3-32-ok"?

Sorry, my fault, it was really MGA3-64, so I leave the tag unchanged.
Comment 8 claire robinson 2014-05-19 14:30:35 CEST
Testing complete mga3 32 in vbox. It needs testing mga4 64 to validate.

Took a snapshot so it could be rolled back.

# urpmi.removemedia -a
# urpmi.addmedia --distrib http://mylocalmirror/distrib/cauldron/i586
# urpmi --auto-select

Lots of errors & problem reading synthesis file of medium "Core Release"

Rolled back the VM  and repeated with the update installed. Shows normal list of priority packages to be updated and starts to install them without error. I didn't complete the upgrade.

Rolled back the VM again and installed the update again and was able to install/remove/query packages without error in mga3. Used in testing drupal update.

Whiteboard: MGA3TOO has_procedure mga4-32-ok mga3-64-ok => MGA3TOO has_procedure mga4-32-ok mga3-32-ok mga3-64-ok

Comment 9 Thierry Vignaud 2014-05-19 18:30:29 CEST
Nice testing :-) !
Comment 10 claire robinson 2014-05-19 18:38:12 CEST
Thanks :)
Comment 11 David Remy 2014-05-19 21:58:00 CEST
Testing complete mga4 x64 in hyper-v.

Used snapshot to test, tried changing to cauldron before updating perl-URPM and received many errors. Rolled the system back to before changing and retesting.

After perl-URPM-4.30-1.mga4 was installed the system started installing cauldron rpms without issue. I stopped after about 30/443 packages were installed.

Rolled back a second time to install perl-URPM-4.30-1.mga4 and test packages without changing to cauldron. Installed a latest kernel-server and cifs-utils, hen removed kernel-server, no errors.

CC: (none) => dpremy
Whiteboard: MGA3TOO has_procedure mga4-32-ok mga3-32-ok mga3-64-ok => MGA3TOO has_procedure mga4-32-ok mga3-32-ok mga3-64-ok mga4-64-ok

Comment 12 Rémi Verschelde 2014-05-20 00:12:18 CEST
Validating the update, the advisory has been uploaded.

Please push perl-URPM to 3 & 4 core/updates. Thanks everyone for testing!

Keywords: (none) => validated_update
Whiteboard: MGA3TOO has_procedure mga4-32-ok mga3-32-ok mga3-64-ok mga4-64-ok => MGA3TOO has_procedure mga4-32-ok mga3-32-ok mga3-64-ok mga4-64-ok advisory

Comment 13 Thomas Backlund 2014-05-22 19:29:19 CEST
Update pushed:

Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.