Bug 12629 - Enabling CONFIG_MEMCG
: Enabling CONFIG_MEMCG
Status: RESOLVED FIXED
Product: Mageia
Classification: Unclassified
Component: RPM Packages
: 4
: All Linux
: Normal Severity: normal
: Mageia 4
Assigned To: Thomas Backlund
:
:
:
:
:
:
  Show dependency treegraph
 
Reported: 2014-02-06 11:34 CET by Erwan VELU
Modified: 2016-08-17 10:17 CEST (History)
1 user (show)

See Also:
Source RPM: kernel-desktop-3.12.8-2.mga4-1-1.mga4
CVE:
Status comment:


Attachments

Description Erwan VELU 2014-02-06 11:34:02 CET
Description of problem:
When trying to use lxc on my mga4, I need to get CONFIG_MEMCG at yes to make lxc-checkconfig happy

I've been recompiling the kernel with this option and since it works much better. Can you enable it in the next build please ?

[erwan@localhost ~]$ lxc-checkconfig 
--- Namespaces ---
Namespaces: enabled
Utsname namespace: enabled
Ipc namespace: enabled
Pid namespace: enabled
User namespace: enabled
Network namespace: enabled
Multiple /dev/pts instances: enabled

--- Control groups ---
Cgroup: enabled
Cgroup clone_children flag: enabled
Cgroup device: enabled
Cgroup sched: enabled
Cgroup cpu account: enabled
Cgroup memory controller: missing
Cgroup cpuset: enabled

--- Misc ---
Veth pair device: enabled
Macvlan: enabled
Vlan: enabled
File capabilities: enabled


Version-Release number of selected component (if applicable):


How reproducible:
Check lxc-checkconfig on this setup

Steps to Reproduce:
1.
2.
3.


Reproducible: 

Steps to Reproduce:
Comment 1 Erwan VELU 2014-02-06 14:54:21 CET
Please find the new checkconfig with the CONFIG_MEMCG
[root@localhost edeploy-lxc]# lxc-checkconfig 
--- Namespaces ---
Namespaces: enabled
Utsname namespace: enabled
Ipc namespace: enabled
Pid namespace: enabled
User namespace: enabled
Network namespace: enabled
Multiple /dev/pts instances: enabled

--- Control groups ---
Cgroup: enabled
Cgroup clone_children flag: enabled
Cgroup device: enabled
Cgroup sched: enabled
Cgroup cpu account: enabled
Cgroup memory controller: enabled
Cgroup cpuset: enabled

--- Misc ---
Veth pair device: enabled
Macvlan: enabled
Vlan: enabled
File capabilities: enabled
Comment 2 Erwan VELU 2014-02-06 14:57:28 CET
My diff looks like : 


--- /boot/config-3.12.8-desktop-2.mga4	2014-01-24 14:58:28.000000000 +0100
+++ /boot/config-3.12.8-2.mga4custom	2014-02-06 12:10:03.487924034 +0100
@@ -1,6 +1,6 @@
 #
 # Automatically generated file; DO NOT EDIT.
-# Linux/x86 3.12.8-desktop-2.mga4 Kernel Configuration
+# Linux/x86 3.12.8-2.mga4custom Kernel Configuration
 #
 CONFIG_64BIT=y
 CONFIG_X86_64=y
@@ -150,7 +150,10 @@
 CONFIG_PROC_PID_CPUSET=y
 CONFIG_CGROUP_CPUACCT=y
 CONFIG_RESOURCE_COUNTERS=y
-# CONFIG_MEMCG is not set
+CONFIG_MEMCG=y
+CONFIG_MEMCG_SWAP=y
+CONFIG_MEMCG_SWAP_ENABLED=y
+CONFIG_MEMCG_KMEM=y
 # CONFIG_CGROUP_HUGETLB is not set
 # CONFIG_CGROUP_PERF is not set
 CONFIG_CGROUP_SCHED=y
@@ -168,6 +171,7 @@
 CONFIG_NET_NS=y
 CONFIG_UIDGID_STRICT_TYPE_CHECKS=y
 CONFIG_SCHED_AUTOGROUP=y
+CONFIG_MM_OWNER=y
 # CONFIG_SYSFS_DEPRECATED is not set
 CONFIG_RELAY=y
 CONFIG_BLK_DEV_INITRD=y
Comment 3 Thomas Backlund 2014-02-07 17:30:50 CET
The trouble with enabling MEMCG is that it adds memory and fork/exit overhead...

I'm not sure we want that... atleast on desktop kernels... 

maybe only for server x86_64 kernel ...
Comment 4 Thomas Backlund 2014-02-22 01:56:19 CET

enabled is -server kernels in kernel-3.12.13-1.mga4/5 currently building
Comment 5 Erwan VELU 2014-02-23 19:38:40 CET
Thanks a lot.
Comment 6 Dag Nygren 2016-08-17 10:17:41 CEST
Excuse me for returning to this, but is the overhead really significant? I am runnuing a MGA5 here and really getting fed up with firefox starving out my 6GB of memory. Using a cgroup for firefox would solve the problem , but not wo. MEMCG.

Note You need to log in before you can comment on or make changes to this bug.